Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Sidebar Login Plugin Not Showing Logged-in User Avatar + Member Access Issue


  #1  
Old Jan 8, 2014, 09:28 PM
New WordPress Fan
 
141 posts · Jul 2010
In a site using Wordpress 3.8 and Atahualpa 3.7.13, I'm encountering the same problem as described in previous forum thread: http://forum.bytesforall.com/showthread.php?t=20598.

Sidebar Login Plugin does not display the Logged-in User Avatar unless you refresh the page. Same on any page you had open in your Browser's cache before logging in. But, if you navigate to a new page after logging in, then the logged-in User Avatar displays.

In addition, with the Member Access plugin activated, if you login from a "Members only" restricted access page, the "Members Only" restricted access message continues to display, and it does not recognize you as logged in for any of the Members Only pages. (You continue to go only to the Members Access re-direct page with the "Sorry, Members Only" message.)

After trying to log in from a Members Only page, if you then log out and log back in from a public page, you are still denied access to all the Members Only pages. Only when you log out, clear the browser's cache, and then log back in from a public page (and refresh the page to display the logged-in user avatar), are you then permitted access to the Members Only pages.

Have tried de-activating other plugins, but no help.

Any help will be much appreciated!

Last edited by New WordPress Fan; Jan 8, 2014 at 09:30 PM.
  #2  
Old Jan 9, 2014, 02:43 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What happens if you switch to twenty twelve?
Do you have a caching plugin active?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by lmilesw; Jan 9, 2014 at 10:38 AM.
  #3  
Old Jan 9, 2014, 10:41 AM
New WordPress Fan
 
141 posts · Jul 2010
No caching plugin installed or active.

I do not have this problem with the exact same set of plugins and same content files using Wordpress 3.2.1 and Atahualpa 3.6.4. The problem arose only when I moved the site to another host, and in the process had to update to Wordpress 3.8 and Atahualpa 3.7.13, and update all the plugins.

The active plugins on the site include: Akismet, Comment Reply Notification, Email Alerts, List Category Posts, Login Logo Customization (by Pigi), Login Page Logo Link Changer (for logo on wp-admin sign in page), Mail From, Member Access, Nextgen Gallery, Post Page Associator, Query Posts, Show ID for Post/Page/Category/Tag/Comment, Subpage Navigation Widget, Tako Movable Comments, User Profile Message (adds a message to the backend profile page), User Role Editor, and Widget Logic.

All are latest versions.
  #4  
Old Jan 9, 2014, 02:58 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What happens if you switch to twenty twelve?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jan 10, 2014, 12:56 PM
New WordPress Fan
 
141 posts · Jul 2010
Tried Twenty Twelve. Can't test, because site (which is designed for Atahualpa) does not render properly in Twenty Twelve -- Sidebar login widget does not appear, member only pages are showing in menu and member only content showing in sidebars throughout, etc.

Also tested with Atahualpa 3.6.4 (the original version of Atahualpa used for this site, which worked with Wordpress 3.2.1). But, same problem occurs in the new site with Wordpress 3.8

Basically, in summary, there seem to be two problems:

1. The Sidebar Login widget does not show you as logged in on the page on which you log in - or on any other pages open in your browser's cache at the time of login - until you refresh the browser; and

2. If you have any Members Only pages open in your brower's cache (i.e. redirected to the "Members Only" message page) at the time of login, then the Members Only plugin permanently redirects you to the "Members Only" message page for those pages, even after you login -- but allows you access after login to any Members Only pages that were not open in your browser's cache at the time of login.

These problems are occurring across all browsers and on several computers.

Help!

Last edited by New WordPress Fan; Jan 10, 2014 at 02:13 PM.
  #6  
Old Jan 10, 2014, 02:50 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
1. The Sidebar Login widget: did you try the solutions in http://wordpress.org/support/topic/p...gin?replies=15 ? this looks like a plugin issue

2. Members Only plugin: have you contacted the plugin author? I note that the plugin hasn't beenupdated in over 2 years, it may be broken with th ecurrent version of WP.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jan 11, 2014, 09:43 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I also did a quick search for the other plugins and found a few that haven't been updated in over 2 years. All bets are off on how they work with WP 3.8.1
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #8  
Old Jan 12, 2014, 03:14 PM
New WordPress Fan
 
141 posts · Jul 2010
Thank you, Juggledad.

1. For the Sidebar Login plugin, the solution suggested worked partially. Adding the code suggested in the sidebar-login.php did result in the Login Welcome Avatar and links showing on the page on which you sign in. However, it still does not show on any other pages that were open in the browser's cache at the time you signed in.

To minimize likely issues, I used the redirect option in the Sidebar Login widget to re-direct members on login to the members only page of the site.

2. For the Members Access plugin, I have partially re-designed the site and utilized a new re-direct option in the plugin settings (to the WP-Login page) as a work-around, for now. The Members Access plugin settings say: "Note that if you select "Wordpress Login Page" from the dropdown, the user will be sent back to the originally requested page after logging in."

I used this option for all Members-Only posts. For Members-Only pages, I re-designed the site so the public can only access one such page, which re-directs to a page with a message that the page is available only to signed-in members, and provides a link to the WP-Login re-direct page for that page provided by the Members Access plugin - where members can sign in.

I then installed Blue Login Style plugin, which let me customize the WP-login page appropriately.

For now, although not perfect, this works for this site.

Last edited by New WordPress Fan; Jan 12, 2014 at 03:19 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sidebar Login plugin - Logged-in User Avatar not Showing without manual Page New WordPress Fan Forum How-To 2 Jul 8, 2013 04:46 PM
BUGFIX 364-08: Using the 'Display Avatar' plugin causes two copies of the avatar juggledad Old Version fixes and change logs 0 Apr 26, 2011 06:35 AM
can't login, can't access wp-admin, need trailing / to access pages northcoastimports Atahualpa 3 Wordpress theme 12 Jan 3, 2011 04:23 PM
[SOLVED] Exclude sidebar for logged-in user everyman Sidebars & Widgets 4 Oct 24, 2010 06:13 PM
Unusual plugin/login issue jasonchamb Plugins & Atahualpa 7 Nov 8, 2009 01:19 PM


All times are GMT -6. The time now is 09:41 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.