Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » Forum Usage » Forum How-To »

[SOLVED] CSS Inserts not working on new site with Atahualpa 3.7.12 & Wordpress 3.7.1


  #1  
Old Dec 4, 2013, 11:37 PM
New WordPress Fan
 
141 posts · Jul 2010
CSS Inserts are not working as usual to style a new site I am building with Atahualpa 3.7.12 and Wordpress 3.7.1.

For example, the following CSS code (which has always worked on previous sites with Atahualpa 3.7.12 and previous Wordpress versions) now does not style the color of the link text with the RSS Post icon:

Code:
a.posts-icon  {
color: #ffffff !important;
}
And, the following code suggested in a forum here, also does not work to style the link text with the RSS posts icon:
Code:
div.rss-box a:link,
div.rss-box a:visited,
div.rss-box a:active {
color: #ffffff; }
Also, the following CSS code (which works on all my other sites with Atahualpa and Wordpress) now does not add borders under "Associated posts" displayed on a page via the post-page associator plugin:

Code:
div.associated-post {
border-bottom: 1px solid #cccccc;
}
This code should work, since the Page source code for the associated posts is:

Code:
<div class="associated-posts">  
    <div class="associated-post">
Are there known issues with CSS Inserts in Atahualpa 3.7.12 with Wordpress 3.7.1? I did not have this problem with the previous site I built - with Atahualpa 3.7.12 and Wordpress 3.5.2.

If necessary, how can I revert back to Wordpress 3.5.2?

Many thanks for any help!
  #2  
Old Dec 5, 2013, 12:36 AM
New WordPress Fan
 
141 posts · Jul 2010
Further to above, apparently others have also had problems with losing CSS styling when they freshly install or upgrade to Wordpress 3.7.1.

See e.g.
http://support.themeburn.com/topic/l...1-nginx-server (suggesting that "The problem is that wp-config.php file is outside the wordpress files," and therefore is not connecting to data base. "If you can't move it to default place go to themefolder/css/screen.css.variables and edit database details.")

See also: http://wordpress.org/support/topic/s...problem-urgent (CSS editor problem after upgrade to Wordpress 3.7.1).

Any ideas on how to correct the CSS editor problem with Wordpress 3.7.1 and Atahualpa 3.7.12?

Many thanks!
  #3  
Old Dec 5, 2013, 04:05 AM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Do you have your wp-config.php outside the wordpress root folder?
If so why and what happens if you put it back?

What is the url of the site?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Dec 5, 2013, 11:53 AM
New WordPress Fan
 
141 posts · Jul 2010
No, don't know that I do "have the wp-config.php outside the wordpress root folder." This was the problem diagnosed for the other person having a similar problem with CSS not working (to which I linked only as an example of others having problems with CSS Editor after installing Wordpress 3.7.1).

Will send you a PM with the url.

Thanks.
  #5  
Old Dec 5, 2013, 01:57 PM
New WordPress Fan
 
141 posts · Jul 2010
Did some more testing - and ATO > CSS Inserts is definitely not working.

Even the following basic CSS Code does nothing:

Code:
td#middle {
border: 2px solid #6f1294;
}
However, strangely, when I made changes within the pre-installed CSS Inserts (styling H1 through H6), that worked. E.g. to change the color of the headlines.

Just any newly added CSS Code does not work. Strange!
  #6  
Old Dec 5, 2013, 01:59 PM
New WordPress Fan
 
141 posts · Jul 2010
P.S. Styling within the other sections of Atahualpa Theme Options does seem to work. It is just the CSS Inserts that appear not to work.
  #7  
Old Dec 5, 2013, 02:01 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Try this, move your
HTML Code:
a.posts-icon  {
color: #ffffff !important;
}
to the begining of the CSSS Isnserts and see what happens.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Dec 5, 2013, 02:16 PM
New WordPress Fan
 
141 posts · Jul 2010
That worked!!! Juggledad, you are a Genius!

So, if I add all new CSS inserts above the pre-loaded inserts it works!! Thank you!!

(For the future, it will be interesting to find out why new CSS Inserts added below the pre-loaded code don't take, so someone can fix this in new updates... But, for now your work-around works perfectly!!)

Thanks again!
  #9  
Old Dec 5, 2013, 02:29 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
why don't you look at the css at the end and see if there are any syntax errors. (hint hint)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Dec 9, 2013, 12:18 PM
New WordPress Fan
 
141 posts · Jul 2010
Yes, that was it. Somehow the pre-inserted CSS code ended with a ")" rather than a "}"

Therefore any CSS code entered after that was not working.

Thanks very much, Juggledad.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
WordPress.org Automatic Update with Custom Site - Working, needs Testing LANtait New Versions, & Updating 0 Jun 10, 2011 05:46 PM
why Fields in the Atahualpa 3.3.3 does not expand? css inserts, html inserts krystyna New Versions, & Updating 3 Oct 28, 2010 12:22 PM
WP-Print Not Working in WordPress 2.9.1 with Atahualpa wilkel Plugins & Atahualpa 6 Jan 29, 2010 01:52 PM
[SOLVED] why Fields in the Atahualpa 3.3.3 does not expand? css inserts, html inserts ppat2 New Versions, & Updating 3 Jun 2, 2009 05:41 PM


All times are GMT -6. The time now is 09:04 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.