Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

[SOLVED] How to Make Images Display Alt text on mouse roll-over or hover?


  #1  
Old Jul 16, 2013, 05:44 PM
New WordPress Fan
 
141 posts · Jul 2010
I am using Atahualpa 3.7.12 and Wordpress 3.5.2.

In older versions of Atahualpa, images uploaded in posts or pages automatically displayed the title or alt text for the image on mouse roll-over. They do not do that in the current version.

How can I make them do that?

Many thanks.
  #2  
Old Jul 16, 2013, 07:04 PM
juggledad's Avatar
juggledad
 
23,465 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
both works for me, you just have to make sure the <img...> has a title="..." in it and the alt="..."
  #3  
Old Jul 16, 2013, 08:19 PM
New WordPress Fan
 
141 posts · Jul 2010
Yes, I do have the Title and Alt filled in for every image, but on the site I am building, they do not appear on mouse roll-over for any image except those displayed in Next Gen Galleries.

Maybe a plugin is interfering? Any, in particular, that might do this?

This has been happening for the last three websites I have built -- each of which has displayed multiple images using the Next Gen Gallery plugin. Is there something in that plugin that might affect mouse roll-over for other images on the site??

Any other suggestions?

Many thanks.
  #4  
Old Jul 17, 2013, 03:58 AM
juggledad's Avatar
juggledad
 
23,465 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What is the URL for the site?
  #5  
Old Jul 17, 2013, 12:10 PM
New WordPress Fan
 
141 posts · Jul 2010
Thank you, Juggledad. I sent you a PM with the URL.
  #6  
Old Jul 17, 2013, 01:43 PM
juggledad's Avatar
juggledad
 
23,465 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
i just went to your 'about' page. The images there do NOT have a title=... on any of the images
and when I go to your NEWS page I see the title showing when I hover the images - firefox and safari on the mac

Last edited by juggledad; Jul 17, 2013 at 02:09 PM.
  #7  
Old Jul 17, 2013, 02:08 PM
New WordPress Fan
 
141 posts · Jul 2010
Hi Juggledad,

Thank you for your response. Yes, I just looked at the source code, and I see what you mean. The source code for every page of the site seems to show only alt="...." for each image. It does not show Title="....".

However, in uploading each image, I always fill in both the Title and the Alt fields.

I just tested it to see if Title would show if I filled in just the Title field and leave the Alt field blank when I upload an image. However, the source code for my test post still showed only alt="...." (with no Title) for the image.

What could be causing the Theme/ site to show no image titles and convert image titles entered into "alt" text??

Many thanks for your help!
  #8  
Old Jul 17, 2013, 02:27 PM
New WordPress Fan
 
141 posts · Jul 2010
On further test, I see that I can hand code the title into the <img> code for any loaded image on any page or post, and then the roll-over works.

However, the "Add Media" function is not working. It does not include the Title or Description in the <img> code when an image is uploaded into a page or post -- whether it is uploaded from my computer or from the Media Library.

Strange!
  #9  
Old Jul 17, 2013, 02:31 PM
New WordPress Fan
 
141 posts · Jul 2010
P.S. On the News Page, the thumbnails showing there are placed there via the Post-Page Associator plugin, and the post title does show on roll-over for all thumbnails appearing via this plugin.

However, on the pages and posts themselves, the images uploaded via the Theme's Upload Media function are not including the title code, as referenced above, so they do not display anything on mouse roll-over.

Thanks.
  #10  
Old Jul 17, 2013, 04:00 PM
juggledad's Avatar
juggledad
 
23,465 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
read this http://wordpress.org/plugins/restore-image-title/
looks like this is a wordpress issue.
  #11  
Old Jul 19, 2013, 03:23 PM
New WordPress Fan
 
141 posts · Jul 2010
Thank you very much, Juggledad! Your link above answered my question:

Yes, it is a Wordpress issue, and the Restore Image Title plugin found via your link above does work to fix the problem for images uploaded after installing the plugin.

But you have to go back and manually add the "title" tag in the <img> HTML code for every image you have uploaded before installing this plugin, if you want the title (or any description) to appear on mouse roll-over for those images.

It seems this is an important issue, and many people would like to know in advance -- before uploading several images -- that "WordPress 3.5 introduced a new feature - when images are inserted into posts, the title attribute is not included in the image tag," as stated in the plugin you linked to.

This means that, if you are using Wordpress 3.5 or newer versions of Wordpress, mouse roll-over will not work to show image titles or description for any images you insert into pages or posts, unless you first install and activate the Restore Image Title plugin.

Hope this helps others.

Again, many thanks, Juggledad.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
PATCH 113-01: featured images behave 'strangely' may cover text, not show till hover juggledad New Versions & Updates 0 Oct 8, 2012 06:28 AM
[SOLVED] Every text in my website becomes underlined when mouse goes over it probiner Header configuration & styling 3 Jun 15, 2012 05:02 PM
Roll-over action and link from images allyevans Plugins & Atahualpa 1 Jul 3, 2011 04:37 AM
Table changes color/highlights with mouse hover. How do I stop it? InviteStory Atahualpa 3 Wordpress theme 2 Apr 24, 2009 01:05 PM


All times are GMT -6. The time now is 12:12 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.