Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » Forum Usage » Forum How-To »

[SOLVED] Sidebar Login plugin - Logged-in User Avatar not Showing without manual Page


  #1  
Old Jul 6, 2013, 12:48 PM
New WordPress Fan
 
141 posts · Jul 2010
Using Wordpress 3.5.2, Atahualpa 3.7.12.

Sidebar Login plugin works, but fails to show the logged-in user avatar after login (even though the option to show it is checked in the Sidebar Login widget). However, if, after signing in, you manually refresh the page with the Sidebar Login widget, then the logged-in user avatar shows.

This means that after login, the user would not know that he has been signed in, unless he goes to a post to comment -which shows that he is logged in.

Note: This same problem was commented in the Wordpress Forum here: http://wordpress.org/support/topic/p...sh-after-login. But, so far, no replies that solve the problem.

I have checked it, and the same problem is occurring in Firefox, IE, and Chrome - latest versions.

As I see it, the problem seems to be that browsers cache pages, and the login button on the sidebar login does not trigger a page refresh. If you manually refresh the page it works. Or, if you have a sidebar login widget on another page of your site that you have not yet opened in your browser, when you go there, the logged-in user avatar does show. However, if you log in on one page and then go to another page that is already open in your browser, the logged-in user avatar will not display in the Sidebar Login widget on that page either, without refreshing the page.

Is there any way to make the login button in the Sidebar Login widget trigger a page refresh?

I do not have this problem with a site built with Wordpress 3.5.1 and Atahualpa 3.7.10.

Many thanks in advance for help!
  #2  
Old Jul 6, 2013, 01:35 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Are you using this Sidebar Login plugin? If so it works fine for me. Do you have a caching plugin installed? Have you tried putting a redirect to the home page in the widget settings?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Jul 8, 2013, 04:46 PM
New WordPress Fan
 
141 posts · Jul 2010
Thank you very much, Larry, for pointing me to look at the other plugins!

I deactivated 3 plugins that I do not need but were active on install (GoDaddy Quick Setup, Jetpack by WP, and Welcome to WP). Don't know which one was the culprit, but that did it!

The Sidebar Login plugin now works as usual!

Again, thanks very much, Larry!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
BUGFIX 364-08: Using the 'Display Avatar' plugin causes two copies of the avatar juggledad Old Version fixes and change logs 0 Apr 26, 2011 06:35 AM
BUGFIX 361-02: Tab order on comment form incorrect when user is not logged in juggledad Old Version fixes and change logs 3 Feb 26, 2011 07:26 AM
[SOLVED] Exclude sidebar for logged-in user everyman Sidebars & Widgets 4 Oct 24, 2010 06:13 PM
New Widget Area named after logged user ID thanos Sidebars & Widgets 9 Sep 13, 2010 07:15 PM


All times are GMT -6. The time now is 10:48 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.