Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

[SOLVED] Image size and ALT text do not show up in sidebar text widget


  #1  
Old Mar 3, 2013, 12:47 AM
Shama
 
76 posts · Jun 2010
I am using ATA 3.7.3 and wp 3.5.1

I have a number of images in the left sidebar of my home page which are links to other pages:
http://thaihealingmassage.com
This is the code which I am putting in a text widget:
<a href="http://thaihealingmassage.com/courses/video-course/" target="_blank">
<img src="http://www.thaihealingmassage.com/wp-content/uploads/2011/12/video-course-library.png"
alt="visit our video course library" width="175px" height="45px" /></a>
<p>

My code includes an ALT text and the image size, but when I run my site through this tool: http://www.feedthebot.com/tools/alt/ which checks for missing ALT text and missing image size, then neither the ALT text nor the image size shows up. It tells me that the ALT text is "Generated Image" (not correct), and that the image size is missing.

However when I place an image in the center section of the home page, then the ALT text and the image size shows up with no problem.

And here is the really weird thing: The same sidebar image links show up on all my post pages. When I run a post page through the ALT checker utility (try http://www.thaihealingmassage.com/12...e-get-massage/, both the ALT text and the image dimensions do show up for the "Visit our Video Course Library" image. This works for post pages, but nothing shows up on page pages. However it does not work for all the subsequent images, only for the one. Can't figure that one out!

What could be the reason that the code location in a text widget in the sidebar of my page pages strips out this information, but not in post pages?
Is there another way I could code this so that it does show up?

Last edited by Shama; Mar 3, 2013 at 02:23 AM.
  #2  
Old Mar 3, 2013, 06:36 AM
juggledad's Avatar
juggledad
 
23,686 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try disabling ALL plugins
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 3, 2013, 08:06 AM
Shama
 
76 posts · Jun 2010
I found the offending plugin. It was Hyper Cache Extended. I just installed this a few days ago after the latest update to W3 Total Cache crashed my site. I don't have too much luck with caching plugins, it seems. After I deactivated Hyper Cache Extended, all the missing code info shows up as it is supposed to.

Bookmarks

Tags
code in sidebar, code in text widget, image code in text widget

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] text size in pages sidebar widget not the same for 1st and 2nd level pages Chrisrush Sidebars & Widgets 6 Oct 18, 2010 12:26 PM
I erased the text in the TEXT WIDGET and saved. But text and imgs still appear? gwpad Sidebars & Widgets 7 Mar 2, 2010 05:27 PM
[SOLVED] Change color of title text in sidebar text widget Andante Sidebars & Widgets 3 Feb 1, 2010 07:12 PM
Ad Sense in sidebar/widget text book is no show! mpennell Sidebars & Widgets 10 Aug 16, 2009 06:59 AM
Hw 2 Change Sidebar first level font size text ? RVB92 Sidebars & Widgets 1 May 3, 2009 06:37 AM


All times are GMT -6. The time now is 09:11 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.