Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] How to upload my own background image?


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Feb 8, 2013, 01:39 PM
roxybc
 
23 posts · May 2011
Can someone remind me how to upload my own image to use as my background? I've done it once, but didn't like it so removed it and now I can't figure it out!

I've uploaded the image to: /wp-content/themes/atahualpa/images/image_name but I'm not sure what code to put into my settings. Can someone remind me please? I've inserted the following code, as indicated in the layout instructions, but is's still not working

background: url(/wp-content/themes/atahualpa/images/ChevronLtGrey.jpeg) repeat top left;

Thanks very much!
  #2  
Old Feb 8, 2013, 02:02 PM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
Your image named ChevronLtGrey.jpeg does not appear to be in the /wp-content/themes/atahualpa/images folder or it is named differently in your code than it is in the folder.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Feb 8, 2013, 05:24 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I don't think .jpeg works, does it?
  #4  
Old Feb 8, 2013, 07:07 PM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
.jpg or .jpeg will both work
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Feb 9, 2013, 02:24 PM
roxybc
 
23 posts · May 2011
I've uploaded it again, an double checked the path and it's still not working. I have no idea what I've done wrong.

What I've done:

1. Clicked on File Manager in CPanel --> Web Root (public_html/www)
2. Click on public_html --> wordpress content --> themes --> atahualpa --> images
3. Then I upload my jpeg background and I can see it in the folder titled ChevronLtGrey.jpg (I typed jpeg in my first post, but correctly entered jpg in the design page)


** This post is continued in the next reply (the system isn't letting me post my entire message)
  #6  
Old Feb 9, 2013, 02:25 PM
roxybc
 
23 posts · May 2011
4. I try and change the background in my settings by entering the following:
background: url(/wp-content/themes/atahualpa/images/ChevronLtGrey.jpg) repeat top left;
Since that didn't work I have also tried: background: url(public_html/wp-content/themes/atahualpa/images/ChevronLtGrey.jpg) repeat top left; but that has not worked either.

I don't understand what I'm doing wrong??
  #7  
Old Feb 9, 2013, 02:49 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Can you give the site's URL?
  #8  
Old Feb 9, 2013, 02:54 PM
roxybc
 
23 posts · May 2011
Sure, it's: http://www.unbecomingmymother.com/
  #9  
Old Feb 9, 2013, 03:14 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Does the Athualpa theme folder have a version number, like atahualpa377? If so, that needs to be part of the link to the image too.
  #10  
Old Feb 9, 2013, 03:17 PM
roxybc
 
23 posts · May 2011
No, there's no numbers. Everything is exactly as I've written it.
  #11  
Old Feb 9, 2013, 04:59 PM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
If I go to www.unbecomingmymother.com/wp-content/themes/atahualpa/images/logo.gif I see the image that is there so that shows the path is OK.

If I go to www.unbecomingmymother.com/wp-content/themes/atahualpa/images/ChevronLtGrey.jpg I see nothing.

This indicates either the ChevronLtGrey.jpg is not in the folder, is spelled differently, has different upper or lower case letters, or doesn't have the proper rights.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Last edited by lmilesw; Feb 9, 2013 at 05:04 PM.
  #12  
Old Feb 9, 2013, 05:13 PM
roxybc
 
23 posts · May 2011
Quote:
Originally Posted by lmilesw
If I go to www.unbecomingmymother.com/wp-content/themes/atahualpa/images/ChevronLtGrey.jpg I see nothing.

This indicates either the ChevronLtGrey.jpg is not in the folder, is spelled differently, has different upper or lower case letters, or doesn't have the proper rights.
What do you mean by "doesn't have the proper rights"?
  #13  
Old Feb 9, 2013, 05:19 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I'll bet this is some kind of naming issue. I notice that you have your header image named with spaces:
Code:
http://www.unbecomingmymother.com/wp-content/themes/atahualpa/images/header/Unbecoming My Mother.jpg
. Web servers don't like that, so they add %20 in the spaces when the page is rendered in the browser.
  #14  
Old Feb 9, 2013, 05:34 PM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
Quote:
Originally Posted by roxybc
What do you mean by "doesn't have the proper rights"?
With FTP you can set who can see a folder or file. This is the least likely cause of your issue however.

If you look at the properties of the image with an FTP client you will see what the permissions for the file are.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #15  
Old Feb 9, 2013, 05:49 PM
roxybc
 
23 posts · May 2011
Quote:
Originally Posted by paulae
I'll bet this is some kind of naming issue. I notice that you have your header image named with spaces:
Code:
http://www.unbecomingmymother.com/wp-content/themes/atahualpa/images/header/Unbecoming My Mother.jpg
. Web servers don't like that, so they add %20 in the spaces when the page is rendered in the browser.
Ok, I feel like a total idiot because I obviously uploaded my header image and switched it from the standard one, but I can't find it anymore. I was sure I deleted the other 3 headers that came standard with the theme, but it appears that those standard three are back there in the Header folder, and the one I uploaded has disappeared. I'm not sure what's going on. The other thing is that I have no idea what section I even added the header code to in the Atahualpa theme settings. Can someone remind me so I can check? I don't think I would have named a file with spaces in it.
  #16  
Old Feb 9, 2013, 05:57 PM
roxybc
 
23 posts · May 2011
Quote:
Originally Posted by lmilesw
With FTP you can set who can see a folder or file. This is the least likely cause of your issue however.

If you look at the properties of the image with an FTP client you will see what the permissions for the file are.
I've clicked on the "change permissions" option of the background image I'm trying to load, and the file is listed as: /public_html/wp-content/themes/atahualpa/images/ChevronLtGrey.jpg and the permissions are: Read: = User, Group, World Write: = User Execute: =(none selected)
Permission values are: 6, 4, 4
  #17  
Old Feb 9, 2013, 05:59 PM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
It looks like you have it coded to be a background image for body of the site. Where do you want it to show?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #18  
Old Feb 9, 2013, 06:17 PM
roxybc
 
23 posts · May 2011
Ok, so it appears I was uploading my background image to the wrong folder.

I originally uploaded it to: public_html/wp-content/themes/atahualpa/images/

But should have uploaded it here: public_html/unbecomingmymother.com/wp-content/themes/atahualpa/images

And yes, I did also do something out of the ordinary and name my header image with spaces in it. Should I delete it and upload one without spaces, or is it fine since it's showing already?
  #19  
Old Feb 9, 2013, 06:59 PM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
It's just not certain it will show in all circumstances with the spaces. As for your background image the only thing I would say is that it is over 700 Kb in size. Images for web should be considerably smaller to reduce page load time. I suspect you can find a much smaller repeating image for this background.

Here is a link to where you can download smaller repeating chevron images.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Last edited by lmilesw; Feb 9, 2013 at 07:09 PM.
  #20  
Old Feb 9, 2013, 07:23 PM
roxybc
 
23 posts · May 2011
Ok, thanks very much for your help everyone! I couldn't get the file to open from the Chevron background site that you sent me to (they were exactly what I wanted though, but when I tried to open the file, it said no program could be found to open it with) so I have re-sized my background to 306kb and changed the name of my header to have no spaces.

Hopefully that should sort out any issues for my future readers now?

Bookmarks

Tags
background change, background images

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wordpress 3.5 - Media upload / Featured Image - Montezuma Informedia Montezuma Theme 2 Dec 15, 2012 05:58 AM
How to disable multiple image upload SharonJ Atahualpa 3 Wordpress theme 1 Jan 11, 2011 08:37 PM
background image over-sized - Full Page Background Image prokopino Atahualpa 3 Wordpress theme 2 Mar 30, 2010 05:42 AM
[SOLVED] How to get a background image show thru background color juggledad Header configuration & styling 3 Apr 18, 2009 06:03 AM
Changing repeated background image forces each page to reload background doctorrobert Atahualpa 3 Wordpress theme 8 Feb 15, 2009 07:36 AM


All times are GMT -6. The time now is 09:02 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.