Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

[SOLVED] Trying to add menu images, understanding Montezuma's menus


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 9, 2013, 11:12 PM
coolpillows
 
35 posts · Nov 2010
Just poking around Montezuma and it's a big difference from Atahualpa. Looks great.

Trying to add the menu icons. I got the proper code from the instruction page under Using Menu Icons. CSS for Icons in "Menu 1." I commented out the default menu1 CSS (#menu1 .page-blog, etc.) and replaced with this:

/* Part 1- for default state: */
#menu1 .sample-page > a > i { background-position: 0px 0px; }
#menu1 .donate > a > i { background-position: 0px -240px; }
#menu1 .gallery > a > i { background-position: 0px -264px; }
#menu1 .news > a > i { background-position: 0px -2112px; }
/* Part 2 - for hover state: */
#menu1 .sample-page:hover > a > i, #menu1 .sample-page.active > a > i { background-position: -24px 0px; }
#menu1 .donate:hover > a > i, #menu1 .donate.active > a > i { background-position: -24px -240px; }
#menu1 .gallery:hover > a > i, #menu1 .gallery.active > a > i { background-position: -24px -264px; }
#menu1 .news:hover > a > i, #menu1 .news.active > a > i { background-position: -24px -2112px; }

Site is currently here: www.thecatsquad.com/test/

But the images are not being replaced. I'm thinking this has something to do with having to create a custom menu in the WP Dashboard. Do I have to create the custom menu first? Then I'm thinking, backing further into the solution, do I have to create new main templates to make use of this new custom menu?

Thanks in advance!

lee
  #2  
Old Jan 10, 2013, 05:31 AM
juggledad's Avatar
juggledad
 
21,980 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
what is your permalinks set to?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Jan 10, 2013, 07:52 AM
coolpillows
 
35 posts · Nov 2010
default: http://thecatsquad.com/test/?p=123
  #4  
Old Jan 10, 2013, 08:01 AM
juggledad's Avatar
juggledad
 
21,980 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Try setting your permalink to post-name
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Jan 10, 2013, 08:27 AM
coolpillows
 
35 posts · Nov 2010
ok...just changed that and saved...still no change in icons. screenshot attached

<not sure why that would have any effect...why?>
Attached Thumbnails
Click image for larger version

Name:	permalink_settings.png
Views:	195
Size:	31.8 KB
ID:	2172  
  #6  
Old Jan 10, 2013, 10:54 AM
juggledad's Avatar
juggledad
 
21,980 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The problem is that the CSS classes are not matching what is being generated when the page is built. when the page is built you get
HTML Code:
<nav id="menu1-wrapper" class="menu-wrapper col7">
	<ul id="menu1" class="cf menu">
		<li class="page-sample-page"><a href="http://thecatsquad.com/test/sample-page/">About</a></li>
		<li class="page-donate"><a href="http://thecatsquad.com/test/donate/">Donate</a></li>
		<li class="page-gallery"><a href="http://thecatsquad.com/test/gallery/">Gallery</a></li>
		<li class="page-news"><a href="http://thecatsquad.com/test/news/">News</a></li>
</ul></nav>
but your CSS is
HTML Code:
/* Part 1- for default state: */
#menu1 .sample-page > a > i { background-position: 0px 0px; }
#menu1 .donate > a > i { background-position: 0px -240px; }
#menu1 .gallery > a > i { background-position: 0px -264px; }
#menu1 .news > a > i { background-position: 0px -2112px; }
/* Part 2 - for hover state: */
#menu1 .sample-page:hover > a > i, #menu1 .sample-page.active > a > i { background-position: -24px 0px; }
#menu1 .donate:hover > a > i, #menu1 .donate.active > a > i { background-position: -24px -240px; }
#menu1 .gallery:hover > a > i, #menu1 .gallery.active > a > i { background-position: -24px -264px; }
#menu1 .news:hover > a > i, #menu1 .news.active > a > i { background-position: -24px -2112px; }
so the classes don't match so they need to be
HTML Code:
/* Part 1- for default state: */
#menu1 .page-sample-page > a > i { background-position: 0px 0px; }
#menu1 .page-donate > a > i { background-position: 0px -240px; }
#menu1 .page-gallery > a > i { background-position: 0px -264px; }
#menu1 .page-news > a > i { background-position: 0px -2112px; }
/* Part 2 - for hover state: */
#menu1 .page-sample-page:hover > a > i, #menu1 .page-sample-page.active > a > i { background-position: -24px 0px; }
#menu1 .page-donate:hover > a > i, #menu1 .page-donate.active > a > i { background-position: -24px -240px; }
#menu1 .page-gallery:hover > a > i, #menu1 .page-gallery.active > a > i { background-position: -24px -264px; }
#menu1 .page-news:hover > a > i, #menu1 .page-news.active > a > i { background-position: -24px -2112px; }
There is a bug and I've reported it to the developer.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old Jan 10, 2013, 11:01 AM
coolpillows
 
35 posts · Nov 2010
thanks for your help, JD!

okay...so i'm not crazy at least. conceivably, i could change the classes to match, but that might break other stuff. or should i just wait for an update in the codebase?
  #8  
Old Jan 10, 2013, 11:38 AM
juggledad's Avatar
juggledad
 
21,980 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
If you want to use it now, I would change the classes to match. I don't know when an update is coming.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old Jan 10, 2013, 11:52 AM
coolpillows
 
35 posts · Nov 2010
ok cool. is Mtz really new? i haven't been tracking.

also, i have a question about removing the breadcrumb bar. seems superfluous...where would i do that?
  #10  
Old Jan 10, 2013, 12:27 PM
juggledad's Avatar
juggledad
 
21,980 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
In the header.php virtual templete
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #11  
Old Jan 10, 2013, 12:35 PM
coolpillows
 
35 posts · Nov 2010
cool thanks!

Bookmarks

Tags
css, icons, menu1

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Child sub menus overlap parent menus on H-Page menu bar cainj99 Page & Category Menu Bars 0 Jan 6, 2012 01:12 PM
Understanding the theme lukerichardson09 ThemeFrame Presales 1 Aug 12, 2011 03:59 PM
Understanding Widget Placement morenqt Sidebars & Widgets 3 Oct 27, 2010 09:25 AM
Help understanding instruction on widget page tim55057 Sidebars & Widgets 1 Oct 13, 2010 09:34 PM


All times are GMT -6. The time now is 11:12 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.