Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

CSS for widget title


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Nov 21, 2012, 11:26 AM
esa036
 
15 posts · Sep 2012
I want to format the widget title area differently for different widgets.
www.esa.org/scalingup/student-workshop

vs.

www.esa.org/scalingup/early-career-scientists-workshop


I added the following CSS code to the "Add HTML/CSS inserts" ATO.
In Internet Explorer 8 they work fine.
In Firefox 16.0.2 only the first bit code works.


/*Widget sidebar title colors*/
/*student workshop*/
td#left-inner div.widget-title{
background: #df9536;
}

/*early career workshop*/
td#left div.widget-title{
background: #cb6d27;
}
  #2  
Old Nov 21, 2012, 01:55 PM
juggledad's Avatar
juggledad
 
22,516 posts · Mar 2009
OSX 10.10.1 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Well, it looks like you corrected it since they look the same to me.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 21, 2012, 01:58 PM
esa036
 
15 posts · Sep 2012
I did not fix the problem.

I don't want them to look the same. I want them to be different.

they look the same in firefox,
But they look different in IE (the look I want)

Thanks in advance for your help.
  #4  
Old Nov 21, 2012, 02:00 PM
esa036
 
15 posts · Sep 2012
I found a workaround.. using the Widget Title Box

but it seems like an odd fix.
  #5  
Old Nov 21, 2012, 03:47 PM
juggledad's Avatar
juggledad
 
22,516 posts · Mar 2009
OSX 10.10.1 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
It might be caused becaused you used the background shorthand, but did no add all the elements.
Try using 'background-color: #df9536;' instead of 'background: #df9536;'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Nov 26, 2012, 10:46 AM
esa036
 
15 posts · Sep 2012
That is not the issue. I changed 'background' to 'background-color'

It seems that
As long as I have the widget title box as:

background-color: #df9536;

and the CSS insert:

/*student workshop*/
#left-inner .widget-title{
background-color: #df9536;
}

/*early career workshop*/
#left .widget-title{
background-color: #cb6d27;
}

It doesn't make sense to me as to why I need to have both codes for the inserts. But it works. I would have thought that I could have only used the #left insert. But it doesn't work if I do that. Nor does it work if the inserts are in the opposite order.

Thanks!

Bookmarks

Tags
widget title background

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Widget Title for admin use only ksmith101 Sidebars & Widgets 1 Jan 17, 2011 03:35 PM
Replacing widget title with image - image and title are displaying at same time barefaced Sidebars & Widgets 4 Apr 27, 2010 04:56 PM


All times are GMT -6. The time now is 06:46 PM.


Powered by vBulletin® Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.