Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

Replacing bfa_excerpt() with the_content() in postformat.php causes mismatch


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Nov 15, 2012, 03:01 PM
Jonathan Harford
 
1 posts · Nov 2012
I've looked over "full posts on the front page" a number of times and come to the conclusion that replacing bfa_excerpt( 55, ' ...' ) with the_content() in postformat.php should give the result that widdy previously desired and I now desire.

I have done so, and indeed, my front page shows full content instead of just excerpts... except that instead of:
Title 8
Content 8

Title 7

Content 7

Title 6
Content 6
etc., I have:

Title 8
Content 7

Title 6
Content 5

Title 4
Content 3
I have been hitting my head against this puzzle for a while now.

Is there anyone who could teach me... how to solve problems? Or how to fish? My Wordpress and PHP knowledge are pretty minimal. Thanks in advance.
  #2  
Old Nov 22, 2012, 07:43 PM
monbosapin
 
1 posts · Nov 2012
I have the exact same issue here: I replaced bfa_excerpt( 55, ' ...' ) with the_content() in postformat.php. Same thing happened with titles and contents getting mixed up for lists of posts.

I'm doing this for the category archives. Right now they show half the actual number of posts as any appearance of a post (whether in title or in content) is being counted as "shown".

Thanks for your knowledgeable help!
  #3  
Old Nov 23, 2012, 02:34 AM
juggledad's Avatar
juggledad
 
22,049 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The developer has been made aware of the issue.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #4  
Old Nov 28, 2012, 06:05 PM
joseanu
 
2 posts · Nov 2012
I have the same problem, have been looking the code for a solution.

I've temporally modified the bfa_excerpt function in template_tags.php but i know is not the right solution for this.

My suspect is the theme's loop function.... will keep diggin.
  #5  
Old Jan 7, 2013, 02:15 PM
richardjones
 
1 posts · Jan 2013
Has a fix been made for this issue? Basically what we are looking for is a way to make the landing page have the full version of the post, with the same layout as the post. When we replace the excerpt with the content however it doesn't work.

Any suggestions?

Thanks in advance.

Richard
  #6  
Old Jan 7, 2013, 02:16 PM
juggledad's Avatar
juggledad
 
22,049 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
see PATCH 113-03: Using 'the_content()' in a virtual template may incorrect results
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Tags
bfa_excerpt, excerpt, postformat, template, the_content

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
bfa_excerpt kal Montezuma Theme 6 Jan 7, 2013 01:34 PM
<?php bfa_excerpt(); ?> is not showing the excerpts Heka Montezuma Theme 5 Oct 4, 2012 02:27 AM
Where is the Function Called the_content() ? GRF Atahualpa 3 Wordpress theme 1 May 21, 2012 07:53 AM
[SOLVED] How can I style the image retrieved with the_content() tag? reradu Excerpts, Read more, Pagination 4 Oct 19, 2009 11:19 AM


All times are GMT -6. The time now is 07:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.