Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Upgrade has me terrified


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Nov 12, 2012, 11:21 AM
runnerb0y
 
67 posts · Nov 2010
Hello,

First of all this is a fantastic theme.

I'm running a website using WordPress 3.0.5 and ATA version 3.5.3. I'm getting ready to do the WordPress upgrade to their latest stable version, and would like to upgrade ATA to 3.7.9. I've got backups of everything and have exported my custom settings in ATA to a text file.

In reading through the various ATA upgrade notifications I cannot tell but it seems to me that WordPress isn't allowing any more custom code (or is that only custom PHP?)? If either of these is a true statement, will I not be able to import my customizations in ATA to the 'new' WP and ATA versions?

Thanks for any light anyone can shed on this!

~runner
  #2  
Old Nov 12, 2012, 11:26 AM
juggledad's Avatar
juggledad
 
22,150 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
No php is allowed in the theme options anymore.
If you have done a BDB backup and have a backup of your wordpress folder, I would do the WP upgrade, then manually install Atahualpa 3.7.9 then you can swap back and forth between 379 and 353
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #3  
Old Nov 12, 2012, 11:51 AM
runnerb0y
 
67 posts · Nov 2010
Juggledad,

Thanks for the advice, that was the method I was going to use.

Just so I'm clear,... any custom HTML/CSS inserts I've done will carry over (once I import them)?
but,
I won't be able to have custom code in the Style & Edit Center Column (the Loop) once I upgrade to the latest WP version??
  #4  
Old Nov 12, 2012, 12:57 PM
juggledad's Avatar
juggledad
 
22,150 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You won't even have to import them since they are stored in the database the new version will just yes them
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #5  
Old Nov 12, 2012, 01:01 PM
runnerb0y
 
67 posts · Nov 2010
10-4 on that being in the database and wouldn't have to import...makes sense.

What about my custom php in the Loop section of ATA? Will that be lost/unusable with the migration to the newest WordPress?
  #6  
Old Nov 12, 2012, 01:16 PM
juggledad's Avatar
juggledad
 
22,150 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Any custom code in 'the LOOP' option will be lost and needs to be moved int the index.php in 379 - this is due to an (!$%#&) requirement be WordPress.

This is why you should
1) back everything up - DB and files
2) upgrade WP
3) check things out
4) manually install 379
5) copy the code you have in 'The LOOP' option of 353 to a text file
6) edit the index.php in 379 to add in the code you customized
7) activate 379
8) test things - if there is aglitch, re activate 353

and if you are really nervious, hire someone to do it for you.

you could even copy the entire site and install it in a subdomain that you can use for testing, then you could go thru the steps whit that site and make sure things work first.
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #7  
Old Nov 12, 2012, 03:13 PM
runnerb0y
 
67 posts · Nov 2010
Thanks Juggledad. With those assurances (moving the Loop PHP changes/additions) and knowing that I won't have any version disasters moving from 3.5.3 to 3.7.9. I can totally tackle this.

Thank you very much sir!

~runner

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.51 to 3.67 upgrade concern....auto upgrade working correctly? CounterPoint New Versions, & Updating 1 Jun 21, 2011 12:36 PM
How to upgrade from 3.4.4 to 3.4.9 using WP Auto Upgrade without Losing Customization dpnstl New Versions, & Updating 3 Jun 6, 2010 03:48 PM
[SOLVED] How to upgrade the theme to a new version (upgrade "readme"?) joe hark New Versions, & Updating 4 Nov 7, 2009 06:46 AM
OK to upgrade to PHP 5? joe hark Atahualpa 3 Wordpress theme 1 Mar 2, 2009 03:45 AM


All times are GMT -6. The time now is 08:01 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.