Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

[SOLVED] Problem with menus on IE8


  #1  
Old Oct 28, 2012, 02:40 AM
billc108
 
22 posts · Jun 2009
Menu dropdowns are not appearing for me on IE8.

I'm running ATA 3.7.9 on WP 3.4.2. The dropdowns are actually appearing a tiny bit - a couple of pixels where the dropdown overlaps the parent menu item shows up and is clickable to the first sub menu item. But the rest of it appears to be hidden behind the center and side columns.

I've searched around here a fair bit and haven't found any problems that are similar.

The development site is dev.windcoalition.net. I've already tried turning off all the plugins... no difference.

Would entering a z-index value somewhere help? And if so, where?

Any hints or ideas appreciated.

Thanks!
  #2  
Old Oct 28, 2012, 04:33 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what happens if you remove all the contents in CSS Inserts? (copy it to a text file so you can put it back in)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 28, 2012, 05:02 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The real way to fix this is to increase the number of columns the logo area takes up and decrease the number that the menu takes up. Remember you hav to think responsive here. The changes would take place in the 'header.php' sub-template.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Oct 28, 2012, 12:03 PM
billc108
 
22 posts · Jun 2009
Quote:
Originally Posted by juggledad
what happens if you remove all the contents in CSS Inserts? (copy it to a text file so you can put it back in)
Well, aside from totally messing up the layout of the rest of the page, it doesn't do much to the menus on IE. Dropdowns are still there on everything but IE. (Firefox, Safari, Opera, Chrome on Mac, Firefox on Windows all show dropdowns).
  #5  
Old Oct 28, 2012, 12:18 PM
billc108
 
22 posts · Jun 2009
Quote:
Originally Posted by juggledad
The real way to fix this is to increase the number of columns the logo area takes up and decrease the number that the menu takes up. Remember you hav to think responsive here. The changes would take place in the 'header.php' sub-template.
Sorry if I'm being dense...

I see at line 60 in header.php:

<td id="header" colspan="<?php echo $cols; ?>">

<?php echo bfa_header_config(); ?>

Those are the only lines in the section marked Header. There's a lot more detail in bfa_header_config.php for both logo area and menu, did you mean there instead? If so, I don't see any explicit mention of number of columns.
  #6  
Old Oct 28, 2012, 12:41 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Sorry my last post was an answer for a different thread - I've got to cut down having so many windows open at the same time
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Oct 28, 2012, 12:54 PM
billc108
 
22 posts · Jun 2009
No prob. That explains why I was confused, at least.

Still, just 1 or 2 px of the dropdowns are displaying in IE, with or without the CSS inserts.

Any ideas? As much as I hate to do so, I still have to support IE for this site.
  #8  
Old Oct 28, 2012, 03:42 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Your problem is that you have multiple syntax errors in your CSS and it would take too long to wade thru them to isolate the one that is causing your issue.

here is what to do.
1) export your settings
2) go to the CSS Inserts and remove everything
3) test it - is it fixed, then the error is in your CSS inserts - if still broken go to (4)
4) go to each page of the atahualpa settings and hit the red 'Reset Settings' button
5) test again - if fixed it has something to do with the settings on that page if not go to the next page and try again.

you might start with the menu page options.
remember is you get messed up you can re-import the settings you saved in step (1)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Oct 31, 2012, 08:49 PM
billc108
 
22 posts · Jun 2009
Thanks. Got 'em fixed up, mostly. I've got a couple little details to straighten up still but the IE problem is gone as are several others.

Bookmarks

Tags
dropdown, ie8, menu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] page menu options with sub-menus problem cway Page & Category Menu Bars 3 Mar 9, 2012 01:07 PM
Child sub menus overlap parent menus on H-Page menu bar cainj99 Page & Category Menu Bars 0 Jan 6, 2012 01:12 PM
Menus howardhill Atahualpa 3 Wordpress theme 11 Feb 17, 2011 05:14 AM
Animated Menus? nick51 Page & Category Menu Bars 3 Aug 26, 2010 09:40 AM


All times are GMT -6. The time now is 09:18 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.