Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Body color and image together


  #1  
Old Oct 6, 2012, 03:22 PM
devarah's Avatar
devarah
 
6 posts · Jan 2010
Hi there, I've spent 30 minutes looking through the forum to find the solution before posting but still was not able to resolve this... it's such a simple problem but I can't get a body image PLUS background color to show together. Here's the site under development: http://choose-light.com/


I have the following code in ATO - Body text & links - body style

font-family: Georgia, serif;
font-size: 1em;
padding-top: 125px; padding-bottom: 20px;
background: #EEEEEE; url(/wp-content/themes/atahualpa/images/spectrum_body.png) no-repeat top center;

Depending on the browser, I can see the background color OR the image but not both. Testing on current versions of FF, Chrome and IE on Vista as well as 10.6.8. I've tried with a .jpg and same results.

Running: Atahualpa 3.7.9
Wordpress 3.4.2
No cache plugin enabled
Running Multisite
  #2  
Old Oct 6, 2012, 09:10 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
One thing is there should be no semicolon after the color... Just a space

Also when I put the url directly to your image I see nothing. Is that the correct spelling including case?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Last edited by lmilesw; Oct 6, 2012 at 09:15 PM.
  #3  
Old Oct 12, 2012, 03:40 PM
devarah's Avatar
devarah
 
6 posts · Jan 2010
THANK YOU so much, it was the semicolon after the color that was gumming up the works, I wound up changing the file type to a .jpg, that's why the .png was not showing for you. This is huge for me to have this resolved, thank you!!


I have another question, I can't seem to hold onto the rounded corners in the body - I have the following in Body Text and Links, Body Style:

font-family: Georgia, serif;
font-size: 1em;
line-height: 23px;
padding-top: 125px; padding-bottom: 20px;
background: #EEEEEE url(/wp-content/themes/atahualpa/images/spectrum_body.jpg) no-repeat top center;
/*trying to add radius to upper corners of above image but not sure it's doing anything*/
-moz-border-top-left-radius: 15px;
-moz-border-top-right-radius: 15px;


And also this in Style & configure Layout, Layout Container Style:

padding: 0px;/*This effectively only affects top/bottom padding */
background: #ffffff;

box-shadow: 0 0 15px #333;
-moz-box-shadow: 0 0 15px #333;
/* uncomment next block for round corners */

-moz-border-radius:15px;
-khtml-border-radius: 15px;
-webkit-border-radius:15px;
border-radius: 15px;
-khtml-border-top-left-radius: 15px;
-khtml-border-top-right-radius: 15px;
-webkit-border-top-left-radius: 15px;
-webkit-border-top-left-radius: 15px;
border-top-left-radius: 15px;
border-top-right-radius: 15px;

If you go to my site and refresh the page you can see the rounded corners in FF and Chrome for a split second but then they go back to being square...

I will make another donation to the forum to thank you for your help, it's much appreciated!!!
  #4  
Old Oct 12, 2012, 04:04 PM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
the radius is there, your issue is the image has square edges and is overlaying the round corners. You need to give #imagecontainer the same corners.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Oct 12, 2012, 04:37 PM
devarah's Avatar
devarah
 
6 posts · Jan 2010
Thank you so much again, that did the trick! Thread closed!

Best Wishes to you - Deb

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Background image on home page only without body color kagorges Center area post/pages 2 Aug 21, 2011 05:10 PM
[SOLVED] Body background color and image not working in IE luciehall Atahualpa 3 Wordpress theme 2 Mar 3, 2011 07:27 PM
[SOLVED] how to change the entire background color, not the body color? crobertl Forum How-To 24 Sep 12, 2010 11:00 AM
[SOLVED] body background - setting image & color soni Atahualpa 3 Wordpress theme 11 Mar 16, 2010 03:55 PM
Fixed width site. Different page background color from body color? blueprairie Forum How-To 1 Mar 20, 2009 09:55 PM


All times are GMT -6. The time now is 05:48 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.