Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

Dual Title Colour Problem


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Oct 4, 2012, 02:11 PM
simon_me
 
6 posts · Oct 2012
Hi there! Thanks for great theme firstly. But i have a problem with a dual title colour.

I want to highlight my title like "com." - with one colour, "press" - with another.
I have read about firstpart code, but simply didn't find where to edit or paste it
Thanks
  #2  
Old Oct 4, 2012, 06:39 PM
juggledad's Avatar
juggledad
 
21,986 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
The blog title is set in the virtual sub-template header.php and comes from a WordPress function. So you would want to replace that whit a hard coded text and put the two color code there.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Oct 5, 2012, 02:04 AM
simon_me
 
6 posts · Oct 2012
Thanks! I did
HTML Code:
<h1 id="sitetitle">   
          <a href = "http://testagain.hostenko.com">
      <span class="firstpart">com.</span> 
  press
   </a>
</h1>
But now it's some space after "com."

How can i fix it?
Thanks

Last edited by juggledad; Oct 5, 2012 at 05:44 AM.
  #4  
Old Oct 5, 2012, 07:29 AM
juggledad's Avatar
juggledad
 
21,986 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Currently there is no way to do this. the code will split the title in half to have the dual color. So if your title is 15 characters, the split will be at 7

I'll create an RFE for this
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Oct 6, 2012, 12:18 AM
jerryc
 
367 posts · Oct 2012
Florida
Quote:
Originally Posted by simon_me
...

But now it's some space after "com."

How can i fix it?
To eliminate the space, try this code, with no spaces or newlines:

Code:
<a href = "http://testagain.hostenko.com"><span class="firstpart">com.</span>press</a>
If it works, please post the rest of the code to make it not split the color in the middle. I'd like to do something similar.
  #6  
Old Oct 6, 2012, 04:11 AM
juggledad's Avatar
juggledad
 
21,986 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
jerryc: good idea, I had the same one and tried it but it doesn't work, the whole line becomes the same color.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old Oct 6, 2012, 09:35 AM
jerryc
 
367 posts · Oct 2012
Florida
Quote:
Originally Posted by juggledad
jerryc: good idea, I had the same one and tried it but it doesn't work, the whole line becomes the same color.
Me, too, jug. That's why I asked simon for the rest of the code. He got that part to work, and you and I got the space to go away.

Simon, did you do something else, like maybe in the css, to get both colors to show?
  #8  
Old Oct 6, 2012, 10:05 AM
juggledad's Avatar
juggledad
 
21,986 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
it has to do with how the code that parses the dual color titles works and spaces that are added in. I've created an RFE asking for more control. see RFE 113-02: allow Dual Color to specify where the color change happens
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old Oct 13, 2012, 02:57 PM
simon_me
 
6 posts · Oct 2012
Quote:
Originally Posted by jerryc
If it works, please post the rest of the code to make it not split the color in the middle. I'd like to do something similar.
no, all text became black
  #10  
Old Oct 13, 2012, 06:20 PM
jerryc
 
367 posts · Oct 2012
Florida
Quote:
Originally Posted by simon_me
no, all text became black
I've been thinking about this, but I haven't tried it yet. How about spanning the whole thing with a tag that says
HTML Code:
<span style = "word-spacing:0px;"> ... </span>
and leaving the rest of the code the way you laid it out.
  #11  
Old Oct 14, 2012, 11:34 AM
juggledad's Avatar
juggledad
 
21,986 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I've played with this and created an RFE asking for more control. Feel free to mess with the code and try different things, maybe you will find a way, but I think it has to do with the parsing of the code and what results. You will have to dig into the theme code.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #12  
Old Nov 5, 2012, 10:42 PM
jerryc
 
367 posts · Oct 2012
Florida
Quote:
Originally Posted by juggledad
I've played with this and created an RFE asking for more control. Feel free to mess with the code and try different things, maybe you will find a way, but I think it has to do with the parsing of the code and what results. You will have to dig into the theme code.
I found a workable hack and posted it on this related thread.
  #13  
Old Nov 21, 2012, 02:57 PM
troyp
 
10 posts · Mar 2011
The javascript doesn't look like it is checking for a preexisting span.firstpart so it will try to parse the text of the title anyway.

There's a bug in the code that inserts an extra space after the closing span tag in includes/get_javascript.php.

See this related thread with updated code to allow checking for punctuation. You could use this mod and add the period to the section of tests.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Post Title Colour Dave The Drummer Center area post/pages 11 Mar 2, 2011 03:12 PM
dual languages website? dinoc Page & Category Menu Bars 2 Oct 24, 2010 01:19 AM
Help to change my blog title position and background colour: winphil Header configuration & styling 2 Jun 18, 2010 06:32 PM
How do I change the colour of the Category title? robdeluxe Page & Category Menu Bars 1 Oct 21, 2009 03:56 PM
Post title colour Newgamer Atahualpa 3 Wordpress theme 3 Jan 9, 2009 01:26 PM


All times are GMT -6. The time now is 05:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.