Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[bug] category URL if you put /0 (zero) at the end php error occurs


  #1  
Old Jun 14, 2012, 05:04 AM
orac1971
 
3 posts · Jun 2012
Firstly thanks to the creator of Atahualpa, its a fantastic theme.

I have found a bug:

On a category URL if you put /0 (zero) at the end of the url an error occurs:

i.e.

http://wordpress.bytesforall.com/category/themeframe/0

Warning: reset() [function.reset]: Passed variable is not an array or object in /home/wordpres/public_html/wp-includes/query.php on line 2934

Warning: reset() [function.reset]: Passed variable is not an array or object in /home/wordpres/public_html/wp-includes/query.php on line 2934

Warning: Cannot modify header information - headers already sent by (output started at /home/wordpres/public_html/wp-includes/query.php:2934) in /home/wordpres/public_html/wp-includes/pluggable.php on line 934

I have tried it on a few Atahualpa themed sites with the same results/

Any idea of what the issue is please - doesn't seem to do it on other wordpress sites that are using other themes.
  #2  
Old Jun 14, 2012, 06:52 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Please try this, swap to the twenty-eleven theme and see if it still happens. If it does, it is a wordpress issue not a theme issue (which I suspect it is)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jun 14, 2012, 07:06 AM
orac1971
 
3 posts · Jun 2012
Quote:
Originally Posted by juggledad
Please try this, swap to the twenty-eleven theme and see if it still happens. If it does, it is a wordpress issue not a theme issue (which I suspect it is)
How come its an issue with the actual Atahualpa site though?
  #4  
Old Jun 14, 2012, 07:41 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Themes are just a small part of a Wordpress site. Most of what happens is run by the Wordpress engine, the theme just presents the look of the site.

By temporallary swapping to twenty eleven, it will tell us if the issue is theme related or a bug(??) with Wordpress itself.

Once you have tested it, you can swap back to atahualpa

Why are you putting 0's at the end?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jun 14, 2012, 07:51 AM
orac1971
 
3 posts · Jun 2012
OK, I apologise - does the same in twenty eleven.

The reason I have queried this is due to the fact that looking into the server logs, someone has been hitting my site hard with links containing 0 (zero) at the end of the path.
  #6  
Old Jun 14, 2012, 08:11 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Ahh you might want to look at http://perishablepress.com/5g-blacklist/
I have tons of IP's that I am banning - amazing how many people from china a nd russia want to look at my personal family site (grin)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Need help with this error massage: Parse error: syntax error, unexpected ' Siya Header configuration & styling 6 Jan 28, 2012 03:25 PM
[SOLVED] ERROR MESSAGE: Parse error: syntax error, unexpected T_STRING in /hsphere/lo Candy Atahualpa 3 Wordpress theme 1 Oct 31, 2010 03:00 PM
Developed a new Category Error when in Excerpt Mode pennyb46 Page & Category Menu Bars 1 May 31, 2010 11:27 AM
[SOLVED] Error In Category and Archive Link walcab Page & Category Menu Bars 2 Feb 9, 2010 03:57 PM
[SOLVED] Parse error: syntax error, unexpected ':', expecting ')' in /home/cwicsol/pu norwichkaren Page & Category Menu Bars 1 Jul 12, 2009 10:04 AM


All times are GMT -6. The time now is 04:21 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.