Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Languages & Translations »

3.7.7 CSS options for Header Image Alignment are translated into locale


  #1  
Old Jun 11, 2012, 04:39 AM
Gert
 
6 posts · Apr 2011
In my case, 'midden boven' shows up where 'center top' is expected.

It looks like only the default setting is in error; using the selection + saving, and re-selecting 'top center' and saving
inserts the right code into the page
  #2  
Old Jun 11, 2012, 06:37 AM
juggledad's Avatar
juggledad
 
23,499 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
which po file are you using?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jun 11, 2012, 12:25 PM
Gert
 
6 posts · Apr 2011
The .po file is nl_NL.po, the header of this file is below.

Please note: 'midden' is Dutch for 'middle', this is in the po file. 'boven' is Dutch for 'above', no entry to be found. The entries in this file for top and center are:

msgid "Top"
msgstr "Bovenkant"

msgid "Center"
msgstr "Gecentreerd"

I noticed this error in 3.7.3. After upgrading to 3.7.7 the 'midden boven' was inserted again.

# Translation of 3.3.x in Dutch
# This file is distributed under the same license as the 3.3.x package.
msgid ""
msgstr ""
"PO-Revision-Date: 2012-04-20 16:58:17+0000\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: GlotPress/0.1\n"
"Project-Id-Version: 3.3.x\n"
  #4  
Old Jun 11, 2012, 01:50 PM
juggledad's Avatar
juggledad
 
23,499 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
where did you get this po file? the pot was updated for 3.7.6 - you should see
HTML Code:
"Project-Id-Version: Atahualpa 3.7.6\n"
where you are showing
HTML Code:
"Project-Id-Version: 3.3.x\n"
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jun 11, 2012, 02:29 PM
Gert
 
6 posts · Apr 2011
The header was of the .po file for the Dutch WP translation, I could not find another .po file.
There is a .pot file in the Atahualpa directory, that is "Project-Id-Version: Atahualpa 3.7.6\n"

The 'midden boven' occurs on terms that shouldn't be translated. The values of the selection-items for the header-image alignment are OK. I can't find 'midden boven' in the files for Atahualpa. So I am puzzled where this text is introduced into the system.

this is the element where things go wrong:

<div id="imagecontainer" class="header-image-container" style="background: url('http://www.harderwiek.nl/wp-content/themes/atahualpa/images/header/vischmarkt.jpg') top center no-repeat;">

Maybe the 'midden boven' was re-introduced in the html after upgrade to 3.7.7, and then only after selecting another header-image and setting a new image-height.
  #6  
Old Jun 11, 2012, 04:57 PM
juggledad's Avatar
juggledad
 
23,499 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
We don't provide the translation, just the pot file that other users use 'poedit' (do a google search for info) to create the translation file - the 'po' file.

it may be that this po file hasn't been updated...

but in any case if you are talking about the values for the option ato->Header Image->Header Image: Alignment, I don't beleive they are translated. Check teh file bfa_theme_Options.php line 735-745 it should be
HTML Code:
    array(    "name" => "Header Image: Alignment",
    	    "category" => "header-image",
            "id" => "headerimage_alignment",
            "type" => "select",
            "std" => "top center",
            "options" => array("top center", "top left", "top right", "center left", "center center", "center right", 
			"bottom left", "bottom center", "bottom right"),
            "info" => "The aligned edge or end of the image will be the fixed part, and the image will be cut off from 
			the opposite edge or end if it doesn't fit into the visitor's browser viewport. <br /><br />
			<strong>Example:</strong> If you choose \"Top Left\" as the alignment, then the image(s) will be cut off 
			from the opposite edge, which would be \"Bottom Right\" in this case."),
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jun 12, 2012, 04:37 AM
Gert
 
6 posts · Apr 2011
Yes, the values in the array are correct, that is what is described in the original post, using the selection-popup inserts valid style-code for the imagecontainer. The problem occurs in some default case, at a moment before these values of the array come into view. Is there a special case in the software when only 1 image is available for the header, or when no user-defined value for the headerimage alignment is available yet?
  #8  
Old Jun 12, 2012, 04:48 AM
juggledad's Avatar
juggledad
 
23,499 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Not that I am aware of - have you tried disabling all plugins to see if one of them is doing it?
Other than that, I wold have to get in the backend to take a peek
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Jun 12, 2012, 06:02 AM
Gert
 
6 posts · Apr 2011
The text 'midden boven' was found in a database record with options for Atahualpa, and getting rid of it was by means of using a setting of Atahualpa, so Atahualpa was the first direction I was looking into. It is not a daily recurring problem for the website, and I will not spend more time on it for now. I'l come back whenever new info comes available.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adjust alignment of header image? kaiasgram Header configuration & styling 4 Mar 14, 2011 06:39 AM
Header alignment set to "top center," but image still cuts off from the right stainton Header configuration & styling 5 Jul 5, 2010 04:52 PM
Date is all messed up in comment section using Dutch locale! Taquoriaan Languages & Translations 6 Feb 3, 2010 06:26 AM
[SOLVED] sad lack of satisfactory “image handling” -- image alignment driving me bonk boldizar Atahualpa 3 Wordpress theme 3 Sep 27, 2009 10:06 PM


All times are GMT -6. The time now is 11:36 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.