Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

Adding Static Header to Blog


  #1  
Old May 30, 2012, 03:49 PM
petro7447
 
20 posts · Mar 2012
Hello,

I have a self hosted site (www.choosemyplan.com) and I am trying to set up the blog portion to where all I have to do is add articles or posts...which seems like it will never happen. I am not a web person, so forgive me if I confuse the terminology.

What I am trying to do:
Add a static header to the blog portion of the site that will not change when you are on the blog's home page or viewing a single post.....Just how the content on the sidebars don't change. I also would like to have one or two lines describing the blog with possibly some social icons.
-I have added the image to: /wp-content/themes/atahualpa/images/header and removed the others...so only that image is in the directory.
- In ATO>Style & Edit Header Area I have %image with the name of the image (exactly) in the "show logo image?"
I have "show blog title?"-Yes;
I am not sure what else to do...One thing that really annoys me and I am not sure if it relates or hinders what I am trying to do...but by default, the page title was showing up on my static pages...I looked around in the forum and saw to hide the post-headline style. So I changed it to

div.post-headline h1,
div.post-headline h2 {
display:none;
margin: 0;
padding: 0;
color:#474646;
text-shadow: 0 1px 1px #FFFFFF, 0 1px 0 rgba(255, 255, 255, 0);
<?php bfa_incl('post_headline_style_text') ?>
}

Which worked, but now the titles on the posts don't display....I think this is for another post...but I thought I would include it just in case....

I am using ATA 3.7.1 & WP 3.3

Thank you to anyone who decides to respond....

Last edited by lmilesw; May 30, 2012 at 06:04 PM.
  #2  
Old May 30, 2012, 06:12 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
This code MIGHT work for you.
HTML Code:
.blog  div.post-headline h1, .blog div.post-headline h2 {
display: block;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old May 31, 2012, 09:03 AM
petro7447
 
20 posts · Mar 2012
Imilesw....thank you for the response...adding the code you recommended now displays the headline of the post in the excerpt view without adding it to my pages....thank you!

However, it still doesn't show the logo on the blog home page....I am curious if I am explaining my problem correctly? Basically I am looking to insert a static banner on the blog page that will sit above the left sidebar and center column where I can add the image, description, and 2-3 social icons....

Similar to what you see at http://net.tutsplus.com/. Where the ad banner would be where my logo would be and the social icons to the right...

Thanks again for any help
  #4  
Old May 31, 2012, 09:27 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Most likely you would use a new widget area and CSS to create what you want but there is not a simple step by step. You will have to take a look a how to create the widget area and play with positioning etc. Then you would add the necessary widgets to the new widget area(s)
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Jun 1, 2012, 09:58 AM
petro7447
 
20 posts · Mar 2012
That's what I thought...I did try one thing and the header did show up...however it adds it on all pages and posts....is there a way to hide it on the pages, and display it on posts only? Here is what I added after <td id="middle"> in header.php:

<div class="post-header"><img src="http://www.choosemyplan.com/wp-content/themes/atahualpa/images/header/CMPPlusLogo.png" repeat-no center /></div>

Thanks again
  #6  
Old Jun 1, 2012, 10:03 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Is there a reason you added it to a theme file rather than somewhere in the theme settings? I don't edit theme files as they will not survive an upgrade and Atahualpa let's me do most anything I want within the theme options.

You could add that same code to the configure header area box and then use CSS to display where you want.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Jun 1, 2012, 12:15 PM
petro7447
 
20 posts · Mar 2012
Ignorance and desperation is really the only reason...
I had made those changes in ATO...with no luck....uploaded the image to the image/header directory; added the image name within header settings, etc... I guess it wasn't meant to be.

Thanks for trying, Imilesw....I appreciate it...

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] adding link to blog in menu (main page is static page) quidoloremipsum Page & Category Menu Bars 2 Mar 15, 2011 02:40 PM
How to make header image "static" or size Blog name to fill image space Publinaut Header configuration & styling 2 Dec 12, 2010 01:59 PM
Howto: Header Image on (static) frontpage ONLY (not rest of blog) RuBeQK Header configuration & styling 1 Jul 28, 2010 01:24 PM
[SOLVED] Adding borders to sides of blog with blog centred in middle of page rhymes Page & Category Menu Bars 1 May 15, 2009 11:38 PM


All times are GMT -6. The time now is 12:20 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.