Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

image in sidebar


  #1  
Old May 23, 2009, 07:17 AM
jim
 
50 posts · Mar 2009
I have been trying to put an image above my page widget in the left sidebar.
I managed to do it through the title box styling in attahualpa theme options but could not get rid of the title text without losing the image. Now i have followed flynns instructions of the 4th february to put the image url in a text widget which has worked except i have one of those little box symbols instead of the gif image itself.
i dont know what that means and i am exhausted from hours of struggle.
how do i deal with that little symbol and get my image?
Is there something i am missing which would solve this?........please.... jim
  #2  
Old May 23, 2009, 11:00 AM
juggledad's Avatar
juggledad
 
23,684 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Jim,
the url address for the image you want to display is wrong. Somehow it looks like you have a double Atahualpa folder i.e In wp-contents/theme you have an atahualpa331 folder, inside that you have a atahualpa331 folder in it is the images folder and that is where your image is.

So the problem is that you are telling the code to go display an image from:
http://tothegarden.org/wp/wp-content...eadercopy1.gif

when it is actually located
http://tothegarden.org/wp/wp-content...eadercopy1.gif

You really should clean up your directories before you do anything else or you are going to continue to give yourself headaches

Why not install atahualpa333, copt the images and clean things up

p.s. I'm making the assumptions of your directory structure by viewing the code that is generated when I when your site. I'm not actually looking at your file structure, just what got generated. I then typed the url into my browser to see if I could find the image and when I entered http://tothegarden.org/wp/wp-content...eadercopy1.gif the image showed up, so I drew the above conclusions.

Last edited by juggledad; May 23, 2009 at 11:04 AM.
  #3  
Old May 24, 2009, 05:40 AM
jim
 
50 posts · Mar 2009
Many thanks for projecting into my problem like that.
It is now fixed and i can move on........
Its a bit like that dream where you break down at the side of the road, your pretty sure its the carburretor, youve got a screwdriver, but you are driving a spaceshuttle!!!.....Tinkering at the edge of the abysss, trying not to venture too far as to lose your bearings. These are images that come to mind.
Thanks again
  #4  
Old May 24, 2009, 06:13 AM
juggledad's Avatar
juggledad
 
23,684 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Jim,
if you don't mind my asking, Why do you have the double folders - i.e. atahulpa331 inside atahulapa331?? this is really just going to be a source of confusion for you (and anyone who trys to help you)
  #5  
Old May 25, 2009, 05:16 AM
jim
 
50 posts · Mar 2009
A good question.....So i upgraded to 333 and got the same configuration and have now realised that what i am dragging from my unzipped downloads folder is a 333folder in a 333folder. I dont know why it does it like that but now i know and have dealt with it.
333 has messed a bit with my opening page giving me a right sidebar and a footer that i had excluded.....The right sidebar was easy to deal with in the theme options but i can not remember how i excluded the footer, i guess i will bang my head against that one for a while.
Thanks for the advise.....jim
  #6  
Old May 25, 2009, 08:30 AM
jim
 
50 posts · Mar 2009
By the way i have moved back to 331-331 while i check into this.....jim
  #7  
Old May 25, 2009, 01:24 PM
nasu
 
34 posts · May 2009
Jim or Juggledad or anyone, will you please tell me how you place a image in the side bar a little more in detail? I'd like to do this. You say, "I managed to do it through the title box styling in attahualpa theme options." Where do I find "the title box styling options"? Also, is it possible to put different images on different "pages" side bars? I come from html world, so this is what I'm used to do. Thanks.
  #8  
Old May 25, 2009, 01:34 PM
juggledad's Avatar
juggledad
 
23,684 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Jim can confirm, but I think he means ATO-> Widgets -> Widget Title Box
  #9  
Old May 25, 2009, 02:28 PM
jim
 
50 posts · Mar 2009
Yes thats right i meant the widget title styling box. I wanted an image in the top lefthand corner and figured that it was a convenient space as i am using only the one sidebar widget but i gave up on that and now i know its a lot more functional to add a text widget into the sidebar and put the image url into the text widget.
I am not sure if its possible to organise different images into the sidebar of different pages as the side bar is the same sidebar even if the pages are different.....Maybe there is some kind of plugin that takes care of that.....
  #10  
Old May 25, 2009, 04:08 PM
nasu
 
34 posts · May 2009
Ok. I found it. Thank you. So to put an image in the side bar, do I type in the name of the photo (jpg) in the ATO/Widget/Widget Title Box? I did that, but nothing happened. (BTW, I saw "Widget Title" box below "Widget Title Box" box, where I could change the font style. I was happy about that, which I was going to do next.) Thank you for the help!
  #11  
Old May 25, 2009, 05:49 PM
nasu
 
34 posts · May 2009
The site url I'm workng on is: masaueharadesign.com (I'm practicing WordPress here.):
When I was experimenting with Widget Title Box, (I think I typed in a jpg image name there in the box and later deleted it when no image showed in the right side bar--so the Widget Title Box is blank now back again--, but I don't know the cause of the following really but..) the blank space and a dotted line appeared on the center column-body text-section on the top, which were not there before.

This happens when I click Recent Posts - "Caneine and feline medicine" on the right bar. But if I click on "Uncategorized (1)" in Categories section below Recent Posts in the right side bar, the blank space and the dotted line don't appear. Will you be able to tell me how to get rid of the blank space and the dotted line? I have no idea what's happening. Thank you VERY much!!
  #12  
Old May 26, 2009, 01:44 AM
jim
 
50 posts · Mar 2009
Im sure our time difference is not helping you much as im in the mediteranean, same climate type as california but a big time difference.......
For that matter im not sure i can be of that much help anyway as i am pretty much as an eskimo might be in a rainforest.....
However i think what you need to do is experiment with sections of the -Theme Options- like --- --Post/Page Styling-.
The area you are trying to get rid of looks like it might be the kicker box.
I would tinker and tweak around the boxes in the theme options that have default settings in them remembering that you can always reset them to default. Visit the different sections and mess around a bit.....
Did you get the gist of the 'image in the text widget' sidebar thing....cheers....jim
  #13  
Old May 26, 2009, 03:27 AM
jim
 
50 posts · Mar 2009
Back to the image in the sidebar text widget.
You need to drag the image from your computer into your image folder under you theme in your ftp setup, make sure it has a name with no spaces and put the url into the text widget and it will find and show the image. I hope that is correct and clear and that if its not someone else will point out.......jim
  #14  
Old May 26, 2009, 02:23 PM
nasu
 
34 posts · May 2009
How to put an image in the side bar: Just to test, I put /wp-content/themes/atahualpa/images/logo.gif in the Widget Title Box. but the picture doesn't show up on the right side bar. Do I need to install another Widget for this? Riht now, I have Search, Recent posts, and Categories Widgets. Can some help me? (masaueharadesign.com --I'm practicing WordPress here.)
  #15  
Old May 27, 2009, 01:21 AM
jim
 
50 posts · Mar 2009
Yes you need another widget....a TEXT WIDGET
Add the TEXT WIDGET to your sidebar
Then type <img src="imageurl" alt="imagename" /></a>
If that is not clear.......
See bottom of post #2 in this thread... http://forum.bytesforall.com/showthread.php?t=186

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to Make Sidebar Titles An Image ftf79 Sidebars & Widgets 6 Oct 31, 2009 11:46 AM
Place image about sidebar tim5046 Sidebars & Widgets 3 Jun 11, 2009 02:55 PM
Sidebar Image Resizing baskenburg Sidebars & Widgets 1 Apr 17, 2009 06:49 PM
Problem with 160x600 image in sidebar. pebble Sidebars & Widgets 2 Apr 9, 2009 10:17 PM
How to add an image to the sidebar? charlieb Sidebars & Widgets 1 Feb 9, 2009 06:01 PM


All times are GMT -6. The time now is 11:08 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.