Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Left and right sidebars not sitting plush up against the header


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old May 22, 2009, 04:12 AM
Pope_gumby
 
4 posts · May 2009
hey everyone, new member here, I am setting up a site which has coloured backgrounds on the sidebars, and the same colour background on the header image.

the only problem is, the sidebars dont sit plush against the header image, so there's a white line appearing, only 1 or 2 pixels wide, between them.

Any idea where I can find the setting which will remove this? Im not sure if its padding around the sidebar, or padding around the header image.

Thanks.
  #2  
Old May 22, 2009, 12:10 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
its probably a 'bar' what do you have set in ATO->Header->Configure Header Area ?? Read what each of the items in that option does
  #3  
Old May 22, 2009, 04:16 PM
Pope_gumby
 
4 posts · May 2009
Quote:
Originally Posted by juggledad
its probably a 'bar' what do you have set in ATO->Header->Configure Header Area ?? Read what each of the items in that option does
Hi, nope, unfortunately its not that, as my header is just %bar1 %image
  #4  
Old May 22, 2009, 05:21 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What's the url? so I can see what you mean
  #5  
Old May 22, 2009, 07:30 PM
Pope_gumby
 
4 posts · May 2009
http://wegaveitseven.com/

thanks for your help.
  #6  
Old May 23, 2009, 05:27 AM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
One thing I notice is that while you say the header image will be 150 px in height, your image is only 146. Try dropping the height to 146 and see what happens
  #7  
Old May 23, 2009, 04:41 PM
Pope_gumby
 
4 posts · May 2009
awesome, that works, thanks for that...
  #8  
Old Jun 4, 2009, 09:20 AM
mal1986
 
17 posts · Jun 2009
I'm having the exact same problem except I know the specified height of my header is correct. I am using an image map in the theme and in order to achieve this, I placed the image and map right under <--Header--> in the header.php file. I then left the theme option - Header completely blank. Could someone please take a look? I just CANNOT figure it out.

site: http://jt4breakfast.com/test/
  #9  
Old Jun 4, 2009, 09:45 AM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ummm, if you're talking about the space under the black curved tab looking area and above the colums...go look at your image that area is in the image
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jun 4, 2009 at 01:57 PM.
  #10  
Old Jun 4, 2009, 04:19 PM
mal1986
 
17 posts · Jun 2009
Quote:
Originally Posted by juggledad
Ummm, if you're talking about the space under the black curved tab looking area and above the colums...go look at your image that area is in the image
I wish that were the problem I am referring to the small space in between the header and the sidebars. I've tried manipulating every margin attribute I could think of, to no avail. Any other suggestions?


By the way, in case we're speaking of the same thing (I just re-read your comment), I've just cropped the bottom portion of the image just to be sure. Something in the coding is adding this space . . .
  #11  
Old Jun 4, 2009, 04:44 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok, that is the sidebar styling and/or the widget styling. In your case it is just the Sidebar Styling

Change ATO->Sidebars->LEFT sidebar style: (and the right sidebar styling too)

padding: 10px 10px 10px 10px;

to:

padding: 0 10px 10px 10px;
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #12  
Old Jun 4, 2009, 05:04 PM
mal1986
 
17 posts · Jun 2009
Unfortunately, nothing changed . . .

P.S. Thanks for the incredibly fast responses.
  #13  
Old Jun 4, 2009, 05:12 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ummmm it did in my browser, did you clear your cache?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #14  
Old Jun 4, 2009, 05:41 PM
mal1986
 
17 posts · Jun 2009
Yes, several times . . . Maybe I'm doing something wrong? I use Firefox. I just go to Tools - Clear Private Data - Clear Private Data Now (Cache clicked). I've done this several times, closed and then restarted the browser . . . I even tried in IE. It still looks the same to me .. . .
  #15  
Old Jun 4, 2009, 05:58 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Just checked on IE8 and firefox, the issue is resolved. Try quitting Firefox and starting it up again.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #16  
Old Jun 4, 2009, 06:15 PM
mal1986
 
17 posts · Jun 2009
I'm sorry, I just do not see a change . . . . I just cleared the cache, closed the browser, ran CCleaner and then restarted my computer . . . . it still looks the same. How is this possible?


Thinking . . . . Ok, well If I use %image in A. Options - Header then it looks perfect, but I lose my image map. Is there another way to add it besides putting it under header.php? Or can I add the map to header.php and call the image in A. Options? I am pulling at straws here . . .

Last edited by mal1986; Jun 4, 2009 at 06:19 PM.
  #17  
Old Jun 4, 2009, 06:30 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
1) view the source of the page, search for 'td#left' - verify you see this
HTML Code:
td#left {
	border-right: solid 1px #332233;
padding: 0px 5px 10px 5px;
background: #faedd3;	}
if you do, can you add a new post titled 'testing' so we both know we are getting a refresh?

and just to make sure, you are still seeing a big space between the label 'Current Projects' and the gray line above it. Not the gap between the gray line and the black area the ticked stub is on.

Am I correct?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #18  
Old Jun 4, 2009, 06:42 PM
mal1986
 
17 posts · Jun 2009
OK. I can see the code you're referring to in page source. I've added a Testing post to verify we're looking at the same thing, and to verify we're speaking of the same space, please refer to the thumbnail below. I apologize if I've been unclear in nay way so far . . .

  #19  
Old Jun 4, 2009, 06:57 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Here is what I see in IE8 and FireFox in XP and Safari/Firefox on the Mac
Click image for larger version

Name:	Picture 2.jpg
Views:	603
Size:	86.1 KB
ID:	148
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #20  
Old Jun 4, 2009, 07:03 PM
mal1986
 
17 posts · Jun 2009
Quote:
Originally Posted by juggledad
Here is what I see in IE8 and FireFox in XP and Safari/Firefox on the Mac
Attachment 148
Ok, this is exactly what I see (except the alignment seems a bit off on the bg). The black arrow in the thumbnail above is sitting smack dab in between the space. It is small, but noticeable b/c of the color change.
  #21  
Old Jun 4, 2009, 07:19 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I've got an idea, lets go the other way

Change ATO->Sidebars->LEFT sidebar style: (and the right sidebar styling too)

padding: 50px 10px 10px 10px;

this should cause a big gap to occur
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #22  
Old Jun 4, 2009, 07:30 PM
mal1986
 
17 posts · Jun 2009
There's certainly a gap . . . the same space is there as well
  #23  
Old Jun 4, 2009, 07:47 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I'm not sure what is happening at your end. From the label "Current Projects' going up, there is a large gap that ends at a line that is just a bit above the word 'Testing' (which is in the middle column)
then there is the line, then a small gap (which is actually part of the image)

Is this what you see?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jun 4, 2009 at 07:52 PM.
  #24  
Old Jun 4, 2009, 08:10 PM
mal1986
 
17 posts · Jun 2009
Yes, except the gap isn't actually apart of the image. Check it out below in photoshop:

  #25  
Old Jun 4, 2009, 08:37 PM
juggledad's Avatar
juggledad
 
21,713 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
So if the space at the bottom of the image is not the gap you are talking about, I'm at a loss because I can't see it.

Here is my suggestion. view the page in IE8 where you see the gap, then view the source and save the source to your My Documents. Then open that source in IE8 and start taking chunks out of the code till teh gap disapeard.

1) remove the footer
2) remove all the posts
3) remove all but the first widget
4) start deleting things out of the inline style

eventually something should make it go away (if you cut stuff from the source in notepad, then save the file, then do a refresh in IE, if something goes wrong you can go back to notepag and do an undo and save it again.

I'm off to bed, good luck, let me know what you find out
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jun 9, 2009 at 05:36 AM.

Bookmarks

Tags
header image, sidebar

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Printing entire page including sidebars, header, etc. peterf Atahualpa 3 Wordpress theme 8 Dec 20, 2011 07:18 PM
[SOLVED] An easy way to have a logo over left sidebar area of header? mgclark Header configuration & styling 11 Jul 29, 2009 05:36 AM
Left anchor header image? blueprairie Header configuration & styling 1 Jun 28, 2009 08:09 PM
Indenting left margin without a left sidebar showing rhymes Sidebars & Widgets 0 Apr 28, 2009 09:02 PM
Sidebars, Left and Right WaterfrontGazette Sidebars & Widgets 1 Dec 13, 2008 12:47 PM


All times are GMT -6. The time now is 12:15 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.