Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

[SOLVED] Font color in sidebar differs from text links


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 20, 2012, 11:40 PM
Jeanie Lee
 
16 posts · Apr 2012
Hi,

My text link default color is currently this color: 0179C1. My manual links that I put on my right sidebar is also the same color(0179C1) which is good and what I want. But unfortunately the links being shown on the right sidebar for 'widget:recent posts' is showing a different link color(it looks a different shade of blue compared with the link default color). I like to either change my default color to this color or change the widget recent posts link color to that of the link default color. Can you tell me how to do this. Where should I go to make this change.

Thanks
Jeanie
  #2  
Old Apr 21, 2012, 06:40 AM
lmilesw's Avatar
lmilesw
 
10,085 posts · Jul 2009
Central New York State USA
The styling for widgets is often different because of the selectors they use. You just have to determine the selectors using a tool like Firebug and define the proper CSS.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Apr 21, 2012, 07:31 AM
juggledad's Avatar
juggledad
 
22,186 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
did you look at the 'Style WIDGETs' options?
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #4  
Old Apr 21, 2012, 09:38 AM
Jeanie Lee
 
16 posts · Apr 2012
I just took a look as suggested. Under widget list items, the font color shows 0179C1 which is the same as the default link color. It's strange because the colors shown on the site are different. Here take a look at my website and you will see the different colorremoved)

Any other suggestions will be welcome.

Thanks
Jeanie

Last edited by Jeanie Lee; Apr 23, 2012 at 03:12 AM.
  #5  
Old Apr 21, 2012, 10:23 AM
juggledad's Avatar
juggledad
 
22,186 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
If you look at the links in the front page, they are using #0179C1 with the exception of the link for 'Best Infant Car Seat' in the first line. That has an in line style of #000000 (black) and the inlink style takes precidence over the style.css settings.
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #6  
Old Apr 21, 2012, 07:53 PM
Jeanie Lee
 
16 posts · Apr 2012
Hi,

Thanks for your reply. I wasn't referring to that link you mentioned. I was referring to the links in the right side bar. If you take a look at the right side bar - look for 'Bestselling Infant Car Seats' - the 10 links used the link color '0179C1'. Now just below this under 'Latest Articles' the link color of those links looks different from the color in those links in 'Bestselling Infant Car Seats'. But when I checked the style widget options link color it seems to be '0179C1'. But the 2 colors really look different. Not sure if my eyes are playing a trick or if I need do something to get the same color. Imilesw says its supposed to be different for widgets but I don't have firebug to check that. But where can I change the color of the widget to match '0179C1' if I do confirm it's different. But if you have firebug and help check that, it would be good too.

Thanks again
Jeanie

Last edited by Jeanie Lee; Apr 21, 2012 at 08:14 PM.
  #7  
Old Apr 22, 2012, 05:29 AM
juggledad's Avatar
juggledad
 
22,186 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Styling is done using ID's and CLASS's assigned to HTML elements.

If every plugin developer/theme writer used the same names for their classes (insert hysterical laughter here) then it would be easy. Atahualpa tries to use the same that WordPress uses but other developers code their HTML differently and so you may have to change them adding CSS to the 'CSS Inserts' option

Now how to find it - couple ways
1) view a page, look at the source, find the widget and look at the ID/CLASS's involved (best way to learn)
2) use a code inspector like 'FireBug' (which is an addon extension for FireFox) - Chrome and Safari also have code inspectors.

it looks like you have already added some CSS to the CSS Inserts that are changing colors - do you understand what it does?
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #8  
Old Apr 22, 2012, 07:15 AM
Jeanie Lee
 
16 posts · Apr 2012
I downloaded firebug and was able to inspect the code element of the culprit widget and identified the link color as #2361A1. The thing is I understand these changes are only effecting the way my browser sees the page, at this particular moment – you aren’t actually changing anything on the page itself, so the next time I load the page, it will go back to the way it was. That is not what I want. I want to be able to change #2361A1 link color (in widget) to that of #0179C1, the link color all my other links are using. There must be a way that I can change the color of the widget link color since I've identified the color to change from. Can you tell me where (in appearance template editor?) I should go and change the widget color. I am kind of stuck because the easier way would be to change the link default color(body style) to #2361A1 - because I prefer the original body style link color. Any help for this noob will be appreciated?

Thanks again
Jeanie
  #9  
Old Apr 22, 2012, 11:49 AM
juggledad's Avatar
juggledad
 
22,186 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
read the last line of my previous post
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #10  
Old Apr 23, 2012, 03:06 AM
Jeanie Lee
 
16 posts · Apr 2012
Thanks so much- that's the missing link. I went to CSS Inserts to change the link color. But just to answer you. I did not put those inserts codes there in the first place as you thought. When I first installed my Atahualpa theme I received the Atahualpa settings extract file (from Marc,Wordpress Academy) and told to copy paste into the extract area and import the settings. Well I learned something today that I can change the widget link colors from here.

Thanks so much for helping to solve this.

Jeanie

Last edited by Jeanie Lee; Apr 23, 2012 at 03:09 AM.

Bookmarks

Tags
default link color

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] changing default font size, spacing and color of links in posts and comments singldedudetravel Center area post/pages 2 Jan 12, 2011 10:16 AM
[SOLVED] Can't seem to change font in Body, Text and Links SamuelGoh Atahualpa 3 Wordpress theme 3 Feb 10, 2010 04:36 PM
[SOLVED] Changing font color for selected text only wardrob Center area post/pages 2 Jan 27, 2010 03:26 PM
How to change font color on links i header? MrStark Header configuration & styling 1 Jan 3, 2010 02:48 PM
[SOLVED] Having trouble setting the font colour in 'Body, text & links' thesis Atahualpa 3 Wordpress theme 7 Nov 2, 2009 06:30 AM


All times are GMT -6. The time now is 11:50 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.