Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

[SOLVED] Leave a Reply form is messed up...


  #1  
Old May 20, 2009, 12:50 PM
Mike
 
3 posts · May 2009
None of the fields start at the begining when you click them.
I took a screenshot that shows where the text starts in each field. I marked it with the word "here":



Also, notice that the field's descripition (i.e. Name, Mail etc) is on the right instead of the left.

I would also like to center the submit button.

Any ideas?
  #2  
Old May 21, 2009, 05:13 AM
juggledad's Avatar
juggledad
 
23,648 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what widget/plugin are you using? what's the site url?
  #3  
Old May 21, 2009, 11:09 AM
Mike
 
3 posts · May 2009
http://elvis.nanocake.com

Not using any special widgets.
  #4  
Old May 21, 2009, 12:07 PM
juggledad's Avatar
juggledad
 
23,648 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Hmmm when I go and try to make a comment, my entries all line up at the left where you would expect them to.

to move the submit button, ou could edit the comments.php in the theme and at eh bottom locate

<!-- Submit -->
<p><input name="submit" type="submit" class="button" id="submit"

and change it to

<!-- Submit -->
<p><input style="position:relative; left:50px" name="submit" type="submit" class="button" id="submit"

and adjust the 50px to a size that works for you
  #5  
Old May 21, 2009, 09:01 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I could replicate this, seems to be caused by the line breaks inside the input and textarea HTML, on certain browser/OS combinations. To fix it in 3.3.3 (also in 3.3.2) edit comments.php by removing these 4 line breaks (the version below is the fixed version):


<input class="text author" type="text" name="author" id="author" value="<?php echo $comment_author; ?>" size="30" tabindex="1" />&nbsp;
<label for="<?php _e('author','atahualpa'); ?>"> <strong>
<?php _e('Name ','atahualpa'); echo "</strong>";
if ($req) _e('(required)','atahualpa'); ?></label>
</p>

<p>
<input class="text email" type="text" name="email" id="email" value="<?php echo $comment_author_email; ?>" size="30" tabindex="2" />&nbsp;
<label for="<?php _e('email','atahualpa'); ?>"> <strong>
<?php _e('Mail</strong> (will not be published) ','atahualpa');
if ($req) _e('(required)','atahualpa'); ?></label>
</p>

<p>
<input class="text url" type="text" name="url" id="url" value="<?php echo $comment_author_url; ?>" size="30" tabindex="3" />&nbsp;
<label for="<?php _e('url','atahualpa'); ?>">
<?php _e('Website','atahualpa'); ?></label>
</p>

<?php endif; ?>

<?php // Display Quicktags or allowed XHTML Tags
if (function_exists('lmbbox_comment_quicktags_display ')) {

echo "<p>"; lmbbox_comment_quicktags_display(); echo "</p>";

} else {

if ($bfa_ata['show_xhtml_tags'] == "Yes") { ?>
<p class="thesetags clearfix">
<?php printf(__('You can use %1$sthese HTML tags</a>','atahualpa'),
'<a class="xhtmltags" href="#" onclick="return false;">'); ?></p>
<div class="xhtml-tags"><p><code><?php echo allowed_tags(); ?>
</code></p></div>

<?php }
} ?>

<!-- Comment Textarea -->
<p><textarea name="comment" id="comment" rows="10" cols="10" tabindex="4"></textarea></p>
<?php do_action('comment_form', $post->ID); ?>
  #6  
Old May 22, 2009, 08:21 AM
Mike
 
3 posts · May 2009
Thank you both! Everything works flawlessly now.
  #7  
Old Jun 6, 2009, 06:06 PM
fromtheranks
 
149 posts · Apr 2009
Dev Env't: XP Pro SP3, IIS 5.1, MySQL 5.1, PHP 5.2.x, WP 2.7.1, Atahualpa 3.3.3, IE 7, FF 3.0.x
Flynn,

The fix below definitely fixed the issue I was having with the default values for name, mail and web-site being right justified and nearly invisible. Thank you for that.

But, I still have another issue with Leave Reply:

Where are these default values coming from? And: Why are there default values?

In my dev environment (XP Pro, IIS 5.1, WP 2.7.1, etc.) the Leave Reply form is defaulting to my Author name, my personal e-mail address (which is not set in WP that I know of) and the URL for my soon to be (but not yet) released blog-site. ... This isn't normal is it? Defaulting values like this? ... And I can't find a setting anywhere (in WP or Atahualpa) that controls this. ... Note: I have not yet turned on "Users must be registered and logged in to comment" in the Discussions Settings.

?

I can't enter the URL for an image as I don't have my site up yet (soon but not yet).

Thanks in advance.
  #8  
Old Jun 8, 2009, 09:41 AM
fromtheranks
 
149 posts · Apr 2009
Dev Env't: XP Pro SP3, IIS 5.1, MySQL 5.1, PHP 5.2.x, WP 2.7.1, Atahualpa 3.3.3, IE 7, FF 3.0.x
As a brief update, I found where my non-site e-mail address was coming from (Settings --> General). It was set during install and forgotten.

However, the rest of the issue (as slightly amended below) remains:
In my dev environment (XP Pro, IIS 5.1, WP 2.7.1, Atahualpa 3.3.3. etc.) the Leave Reply form is defaulting to my Author name, my ... e-mail address ... and the URL for my soon to be (but not yet) released blog-site. ... This isn't normal is it? Defaulting values like this? ... And I can't find a setting anywhere (in WP or Atahualpa) that controls this. ... Note: I have not yet turned on "Users must be registered and logged in to comment" in the Discussions Settings, or "Anyone can register".
I've attached a cropped screen shot of what I see.

Thanks in advance.
Attached Thumbnails
Click image for larger version

Name:	leave-reply-partial-fix-cropped.jpg
Views:	940
Size:	48.3 KB
ID:	151  
  #9  
Old Jun 9, 2009, 03:11 AM
juggledad's Avatar
juggledad
 
23,648 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try clearing your cookies
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Jun 9, 2009, 08:33 AM
fromtheranks
 
149 posts · Apr 2009
Dev Env't: XP Pro SP3, IIS 5.1, MySQL 5.1, PHP 5.2.x, WP 2.7.1, Atahualpa 3.3.3, IE 7, FF 3.0.x
Bingo! I use FireFox 99% of the time, which auto clears cookies when I close, but since I have it open for research on several sites I've been using IE 7 for testing my WordPress build. ... Completely forgot about IE's penchant for clinging to cookies. ... Paint my cheeks pink.

Thanks, Juggledad.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Controlling "Leave a Reply" area FairfieldPhoto Atahualpa 3 Wordpress theme 4 Oct 8, 2009 04:25 AM
[SOLVED] Leave A Comment title instead of Leave A Reply Title. fromtheranks Comments, trackbacks & pings 4 Jun 16, 2009 01:15 PM
How do I make the font of "Leave a Reply" smaller? nasu Comments, trackbacks & pings 4 May 28, 2009 06:41 PM
On comments page for post Leave a Reply and comments are white daisy24 Comments, trackbacks & pings 4 Feb 19, 2009 06:40 AM
Avatar load times and XHTML under leave a reply Artists Garden Atahualpa 3 Wordpress theme 2 Jan 18, 2009 08:24 AM


All times are GMT -6. The time now is 05:19 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.