Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Issue with generated names of custom widgets


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #26  
Old Feb 21, 2012, 07:10 PM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
If the your site was working on the old server - and the host moved your site to a new server - and now you have an issue - then there is some setting on the new server that is different than was on the old server.

i.e. the wordpress, theme and plugin code did not change, therefore is is a setting on the server.

This is not a issue with more than a few sites (two that I am aware - you and the other user) so it is environmental (ie the server you are running on) - your host is going to blame the theme and plugin because they don't want to spend the time looking into the issue. If they can point to an issue with the theme, I'll be happy to investigate, but it works for me and all the sites on the different servers I have access to (westhoost.com, godaddy.com, registar.com to name a few)

I wish I could do more for you but this is beyond the theme support that I can offer for free (being an unpaid volunteer moderator). I hope you understand.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #27  
Old Feb 21, 2012, 08:47 PM
TraciBunkers
 
32 posts · Jan 2012
My web host said the only difference between the server I was on and the one I was moved to is it uses PHP 5.3.

I don't know.

I understand you can't spend anymore time on this because you are a volunteer. If you think any of the codes listed on the page for stripping out the backslashes would help, and you know which one for me to use & exactly where to put, I'd appreciate it.

Thanks for trying to help me out.
  #28  
Old Feb 22, 2012, 09:45 AM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
one other thought, find out from your host how to add a php.ini in and set the magic quotes off to see if that changes anything
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #29  
Old Feb 22, 2012, 10:30 AM
lmilesw's Avatar
lmilesw
 
10,111 posts · Jul 2009
Central New York State USA
Do you have a php.ini file in the root of your hosting site or in the root of your site? If you do you can edit it to turn off Magic Quotes. The lines in my php.ini are
HTML Code:
; Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc = Off

; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
magic_quotes_runtime = Off

; Use Sybase-style magic quotes (escape ' with '' instead of \').
magic_quotes_sybase = Off
I did have to set my hosting to use a single.php for all my sites. This was a control panel setting. You might also be able to add your own php.ini with the proper code to turn off Magic Quotes or at the very least get rid of the false positive.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #30  
Old Feb 23, 2012, 08:35 AM
TraciBunkers
 
32 posts · Jan 2012
I will check on the files you are talking about.

But, my site is now moved to a different web host, and the same problem exists:

w/mailchimp turned off in Atahualpa: backslashes in the custom header widgets
w/mailshimp turned off in Twenty-Ten: no backslashes

My new web host seems like they will be much more helpful, so hopefully they can help me figure it out.
  #31  
Old Mar 3, 2012, 05:00 PM
TraciBunkers
 
32 posts · Jan 2012
My new webhost installed the php.ini file to turn off magic quotes, and it didn't change anything. With mailchimp deactivated, I still get backslashes in Atahualpa in the custom header widgets, but not in Twenty-Ten.
  #32  
Old Mar 3, 2012, 07:33 PM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
At this point I don't know what to offer as advice. For me do do any more I'd have to dig inside your site and that is beyond the free help I can offer on the forums.

but the fact that a plugin gets backslashes tells me (in my experience) that this is not a theme related issue - ie the theme isn't causing the plugin to get the backslash. Now it is possible that the plugin and the theme are both doing something similar, that in your environment/setup, is causing the backslash to show up. But not being in that environment I can't guess at what it might be.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #33  
Old Apr 14, 2012, 01:48 PM
juggledad's Avatar
juggledad
 
22,382 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
the backslash's in the code are caused by the PHP option 'magic_quotes_gpc' being set to 'on'.
you need to edit the php.ini and add
HTML Code:
magic_quotes_gpc = off
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing/Deleting Custom Field Names UnionBreeze Atahualpa 3 Wordpress theme 1 Jan 3, 2011 05:51 PM
Custom Thumbnail Size Issue InstigatorGaming Center area post/pages 4 Aug 23, 2010 05:12 PM
[SOLVED] Custom Author Names? Kesava Atahualpa 3 Wordpress theme 11 Jun 27, 2010 12:58 AM
Help - Using Custom Page Names as Permalinks Matthew Krichbaum Page & Category Menu Bars 4 Apr 30, 2010 09:28 PM
Issue with IE (text sizes in custom widget boxes) abnerdoon Sidebars & Widgets 1 Feb 2, 2010 08:47 PM


All times are GMT -6. The time now is 10:54 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.