Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

[SOLVED] Submit buttons: strange behavior


  #1  
Old Jan 18, 2012, 06:58 AM
JulesG
 
47 posts · Sep 2011
I want the text in my submit buttons to become black, bold and underlined when hovering. So I programmed the buttons accordingly in Style Forms/Submit Buttons:/Default and Hover Style.
Default Style:
HTML Code:
background-color: #dddddd;
color: #333333;
border: solid 1px #333333;
padding: 5px 5px 28px 5px;
font-size: 1.2em;
line-height: 1.5em;
height: 36px;
-moz-border-radius: 10px;
-khtml-border-radius: 10px;
-webkit-border-radius: 10px;
border-radius: 10px;

/* Shadow */
box-shadow: 10px 6px 15px #666666;
border-radius: 10px; -moz-border-radius: 10px;
-moz-box-shadow: 10px 6px 15px #666666;
-moz-border-radius:10px;
-webkit-box-shadow: 10px 6px 15px #666666;
-webkit-border-radius:10px;
-khtml-box-shadow: 10px 6px 15px #666666;
-khtml-border-radius: 10px;
Hover Style:
HTML Code:
background-color: #dddddd;
color: #000000 !important;
text-decoration: underline !important;
font-weight:bold !important; 
border: solid 1px #333333;
padding: 5px 5px 28px 5px;
font-size: 1.2em;
line-height: 1.5em;
height: 36px;
-moz-border-radius: 10px;
-khtml-border-radius: 10px;
-webkit-border-radius: 10px;
border-radius: 10px;

/* Shadow */
box-shadow: 10px 6px 15px #666666;
border-radius: 10px; -moz-border-radius: 10px;
-moz-box-shadow: 10px 6px 15px #666666;
-moz-border-radius:10px;
-webkit-box-shadow: 10px 6px 15px #666666;
-webkit-border-radius:10px;
-khtml-box-shadow: 10px 6px 15px #666666;
-khtml-border-radius: 10px;
However, nothing happens when hovering as you can see here:
http://julesgobeil.com/gestion/?page_id=113

Strangely, changing elements in the Default Style do change the submit buttons but changing elements in the Hover Style do nothing.

Even more, changing elements in the Hover Style affect the Comments button as they should:
Quote:
Submit Button Style.
Style the comment submit button, i.e. give it margin to move it around. This section here is specifically for the comment submit button. Additionally, default button styles will be applied, see menu tab "Forms", options "Submit Buttons: Default Style" and "Submit Buttons: Hover Style"
The Style And Configure Comments/Submit Button Style box is empty, so the Comments button takes all its parameters from the Submit Buttons configuration, Default and Hover. This button works as it should.
See here:
http://julesgobeil.com/gestion/?p=170#comments

Before you ask, there is nothing in Add HTML/CSS Inserts that can affect the buttons.

I can't understand ! Do you ?

Thanks
Jules
  #2  
Old Jan 18, 2012, 08:14 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
The styling in the theme options will affect SOME buttons depending on how they are created. In your case I would just add your code to CSS Inserts and use the selector for the button. The hover state selector should be something like
HTML Code:
.button, .Button, input[type="submit"]:hover
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Jan 18, 2012, 08:57 AM
JulesG
 
47 posts · Sep 2011
Great ! It works fine! 1000 thanks...

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange behavior... JulesG Excerpts, Read more, Pagination 7 Oct 23, 2012 11:58 PM
[SOLVED] Strange behavior in clicking links Tamara-IT Atahualpa 3 Wordpress theme 10 Feb 25, 2011 09:58 AM
Strange behavior Karin Atahualpa 3 Wordpress theme 1 Feb 16, 2011 12:04 PM
[SOLVED] Strange Post behavior on some Page pages blueprairie Plugins & Atahualpa 6 Nov 9, 2009 07:34 PM
Strange behavior when editing bfa_header_config.php jacoblo Header configuration & styling 2 Mar 24, 2009 05:45 AM


All times are GMT -6. The time now is 12:58 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.