Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] bfa_post_parts.php


  #1  
Old Sep 7, 2011, 09:42 PM
ljwahl
 
5 posts · Sep 2011
Hi everyone,

I screwed up my bfa_post_parts.php and now I can't even access wp-admin nor the front-end.

I get this error

Parse error: syntax error, unexpected '<' in /data/web/culturelink/culturelink.com.sg/wp-content/themes/atahualpa/functions/bfa_post_parts.php on line 56

I tried to upload an original copy of the file I had on my computer via FTP, but the error is still there, and I'm entirely mortified that I managed to shut down the entire website in the blink of an eye. I've attached the file here. Is there any reason why uploading a clean original bfa_post_parts.php file won't work?

HELP!!
Attached Files
File Type: txt bfa_post_parts(something wrong).txt (8.1 KB, 755 views)
  #2  
Old Sep 8, 2011, 05:26 AM
juggledad's Avatar
juggledad
 
23,575 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you uploaded a fresh unedited copy it should work. It could be you have a caching plugin that is displaying the error.

Do this, use FTP and navigate to the wp-content/themes/atahualpa folder. Rename index.php to index.old

This should cause wordpress to switch to the default twenty-eleven theme so you can get in. Then check to see if you have a caching plugin and disable it and flush the cache (you can turn it on again later) next go backhand rename the index.old to index.ph and see if the error occurs again
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Sep 8, 2011, 12:33 PM
juggledad's Avatar
juggledad
 
23,575 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I just compared the file you uploaded to the original and there is no difference
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Sep 8, 2011, 10:19 PM
ljwahl
 
5 posts · Sep 2011
Thank you Juggledad!

It turns out that I wasn't actually able upload the original file afterall, even via FTP. My server admin tells me that this was because I had installed Wordpress via a PHP process, so I'm not allowed to edit Wordpress folders and files via FTP.

I don't understand why this should be the case, but in the end, the admin unlocked something specific to the corrupted file, and I was able to replace it with the fresh copy. All has been fixed now.

In any case, thank you very much for your advice!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in bfa_post_parts.php BUGFIX flyboy New Versions, & Updating 2 May 27, 2011 08:59 AM
[SOLVED] Help with bfa_post_parts.php 757CoffeeNews Center area post/pages 8 Apr 29, 2011 12:11 PM


All times are GMT -6. The time now is 03:10 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.