Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Parse error: syntax error, unexpected $end, expecting ')' bfa_theme_options.php


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Aug 25, 2011, 05:50 AM
Joan-BlogBizBuzz
 
7 posts · Aug 2010
South Africa
Currently running WP 3.2.1 and ATA 3.6.4 where I am incurring 404's on http://www.blogbizbuzz.com/wp-conten...364/custom.css.

All files, headers, favicon etc. prepared for 3.6.7 upgrade - WP doing a preview, I get the following message:-

Parse error: syntax error, unexpected $end, expecting ')' in /home/joan1911/public_html/wp-content/themes/atahualpa367/functions/bfa_theme_options.php on line 2497

Please advise, will not activate before receiving some expert advice.

Thanking you in anticipation
Joan
  #2  
Old Aug 25, 2011, 06:21 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
That url
HTML Code:
http://www.blogbizbuzz.com/wp-content/themes/atahualpa.3.6.4/atahualpa364/custom.css
do you really have an atahualpa folder in an atahualpa folder?

I see no 404 in the site
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 25, 2011, 08:32 AM
Joan-BlogBizBuzz
 
7 posts · Aug 2010
South Africa
Hi Juggledad,

Yes this was my first upgrade that I did from 3.2 to 3.6.4 and kept every note, bugfix etc in a folder and worked into a new folder with the name atahualpha 364 - somehow in my trying to get it right, ended up putting and ata into an ata with a different name.

From cPanel Errors
/wp-content/themes/atahualpa.3.6.4/atahualpa364/custom.css 347 http://www.blogbizbuzz.com/pl/%3Cspan/
/wp-content/themes/atahualpa.3.6.4/atahualpa364/styles/default.css 347 http://www.blogbizbuzz.com/pl/%3Cspan/

This was the reason I wished to upgrade to ATA.367

Thanks for the quick response,

Last edited by Joan-BlogBizBuzz; Aug 25, 2011 at 09:46 AM.
  #4  
Old Aug 25, 2011, 09:45 AM
Joan-BlogBizBuzz
 
7 posts · Aug 2010
South Africa
All files, headers, favicon etc. have been prepared for 3.6.7 upgrade and uploaded via FTP. In WP doing a 'preview', I get the following message:-

Parse error: syntax error, unexpected $end, expecting ')' in /home/joan1911/public_html/wp-content/themes/atahualpa367/functions/bfa_theme_options.php on line 2497

Once I have ATA.367 up correctly the ATA.364, double folder will become dormant and hopefully with my second attempt, the third will roll out as smooth as a dream.
  #5  
Old Aug 25, 2011, 11:25 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
you can just rename the atahualpa folder 'atahualpa367' and put it in the themes folder and have multiple versions. This is what I do. take a look at this thread: HOWTO: upgrade Atahualpa to a new version
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Aug 26, 2011, 07:53 AM
Joan-BlogBizBuzz
 
7 posts · Aug 2010
South Africa
In WordPress I am able to go back to ATA 3.2 no problems, ATA 3.6.4 is currently running, upgrade to ATA 3.6.7 is where I get this message:-

Site is in WP 3.2.1 > Themes > Activate | Preview | Delete

All of this theme’s files are located in /themes/atahualpa367.

Parse error: syntax error, unexpected $end, expecting ')' in /home/joan1911/public_html/wp-content/themes/atahualpa367/functions/bfa_theme_options.php on line 2497

Due to the 'Preview' throwing up an error message, after stepping through your instructions for a manual upgrade (excellent instructions BTW), I am reluctant about hitting the 'Activate' button.
  #7  
Old Aug 26, 2011, 08:33 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I can't reproduce this, could I take a look - sif so send me a PM with an admin ID/PW and I'll see what I can find
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Aug 26, 2011, 08:56 AM
Joan-BlogBizBuzz
 
7 posts · Aug 2010
South Africa
Please advise how to go about doing a PM in this forum and thank you so much for your assistance.
  #9  
Old Aug 26, 2011, 09:09 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
click on my ID on any of the posts and you will see an option for sending a Private message (PM)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Aug 26, 2011, 11:13 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
It looks like the install of Atahuala pa 367 must have failed. If you look at bfa_theme_options.php the file is not complete. Your version ends at line 2497 while the file actually has 3231 lines

This could have been caused by a server time out it you were using the wordpress automatic install.

I would delete the theme folder and manually install it.

p,s, make sure to put it in the themes folder, not inside the existing atahualpa folder, download it to your computer, unzip it and rename the folder to atahualpa367 before you upload it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Aug 27, 2011, 03:27 AM
Joan-BlogBizBuzz
 
7 posts · Aug 2010
South Africa
Thanks Juggledad,

Living in Africa with our bad internet connections, anything could happen!

I will do a manual download again if required, first check the file I have on my desktop to see the lines on the original download.

The file the error may have occurred on the upload via FTP.

Normally do everything early morning over here since that is when we get the better speed online.

Thank You again for the assistance, it is greatly appreciated.

Bookmarks

Tags
ata367, syntax error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parse error: syntax error, unexpected '<' in the functions.php file pingitt Atahualpa 3 Wordpress theme 6 Mar 12, 2013 03:52 AM
Please help Parse error: syntax error, unexpected ';', expecting ')' in /home/content archiex Installing & running WordPress 2 Jul 6, 2011 07:58 PM
[SOLVED] ERROR MESSAGE: Parse error: syntax error, unexpected T_STRING in /hsphere/lo Candy Atahualpa 3 Wordpress theme 1 Oct 31, 2010 03:00 PM
Parse error: syntax error, unexpected '<' in /home6/jonesber/public_html/wp-content/ jonesberries Atahualpa 3 Wordpress theme 2 Nov 30, 2009 03:33 AM
[SOLVED] Parse error: syntax error, unexpected ':', expecting ')' in /home/cwicsol/pu norwichkaren Page & Category Menu Bars 1 Jul 12, 2009 10:04 AM


All times are GMT -6. The time now is 01:57 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.