Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Missing RSS Feed

Old May 21, 2011, 09:06 PM
flyboy's Avatar
115 posts · Sep 2010
I never even realized, but I've been with RSS feed for a while (not even sure at which version of Atahualpa the feeds stopped working since I don't really subscribe to my own feeds, but I do have a 6.4.4 installation that seems fine)

Basically the feed gets a parsing error - XMP abruptly stops after <content:encoded><![CDATA[ when the permalinks are set to /%postname%/

Changing to a different theme resolves the issue (requires dumping browser cache)

So out of the following feeds only one works:

.../feed/ (doesn't work)
.../feed/rss/ (works)
.../feed/rss2/ (doesn't work)
.../feed/rdf/ (doesn't work)
.../feed/atom/ (doesn't work)

Last edited by flyboy; May 21, 2011 at 09:08 PM. Reason: URLs get automatically converted into links
Old May 22, 2011, 10:59 AM
flyboy's Avatar
115 posts · Sep 2010
Once again I answer my own question

It turns out that I tested the following already but I forgot to dump cache between that and checking RSS and so I dismissed an actual cause of the problem as it looked like everything is honky dory

Today I tried installing nothing but atahualpa and importing a bunch of posts to see if a barenaked install produces RSS: all clear.

Cache dumped and loaded the Ata settings. Rss check: all clear
Installed my usual plugins, dumped cache and did an RSS check: all clear
Started activating plugins one-by-one (with the cache dump and RSS in between) when gremlins jumped out and clubbed me upside the head

So I'm happy to report that a combo of a "Allow PHP in posts and pages" plugin and Atahualpa caused my misery. Deactivating the plugin OR changing to a dif theme fixes a problem.

I think I'll deactivate the PHP plugin and simply iframe the product of the script into a post instead

Moderators - you can mark this post as solved


bug, feeds, rss

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
RSS buttons going to Atom feed instead of RSS someonewhobakes RSS, Feeds & Subscribing 0 Nov 2, 2010 08:59 PM
Seachbox and RSS feeds missing Shack Header configuration & styling 0 Aug 16, 2010 11:43 AM
RSS Feed timmoj Header configuration & styling 4 Aug 14, 2010 05:56 AM
Newbie: What is the difference between an RSS feed and an Atom feed? reesecoli RSS, Feeds & Subscribing 2 Jul 21, 2010 03:44 PM
Trying to subscribe to an RSS feed using the RSS widget peterf RSS, Feeds & Subscribing 2 May 27, 2010 07:46 PM

All times are GMT -6. The time now is 03:46 PM.

Powered by vBulletin® Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.