Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

[SOLVED] Problem with Bold Nesting in Links


  #1  
Old May 15, 2011, 08:44 PM
OldMan1's Avatar
OldMan1
 
12 posts · Apr 2010
I've had a problem for a while but just getting around to addressing it (it's starting to be time consuming). When I make a link bold in my editing area of WordPress, it places "<strong>" in front of the URL. However the link does not display in bold unless I move the "<strong>" directly in from of the text I want bold, which of course, means I have to move the "</strong>" in front of the "</a>" of the URL for proper nesting. I have tested this in both Firefox and Internet Explorer and the result is the same. I have switched to the default theme in WordPress and it displays properly in bold. Therefore I can only assume the problem is with Atahualpa. Is this a known problem? Iíve searched the forum with no luck.

PS: I am running the latest WP Version and Atahualpa version 3.6.1.
  #2  
Old May 15, 2011, 08:56 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I just tested this with Atahualpa 3.6.7 and the TwentyTen theme and got the same results. Moving the <strong> tags makes no difference in how the link shows in Atahualpa for me.

Could you create a page with the <strong> tags in two different positions and send a link to the page?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old May 15, 2011, 09:53 PM
OldMan1's Avatar
OldMan1
 
12 posts · Apr 2010
Thanks Imilesw for replying. I started out making a page at your request, and discovered something. It worked fine. That is to say, when typing in the editor and creating the link with bold in the editor, it nest the "<strong>" in front of the text. To say the least, I was confused. So I created the same link in Word and inserted the link using the "Paste from Word" option as I've always done, and it nested the "<strong>" in front of the URL. This has been my procedure for years, but never noticed the problem until just the past year or so. I guess that was because it didn't make a difference in other themes. So the problem is associated with pasting with word. No sure if that is a compatibility problem or not, but I just re-tested with the Twenty-Ten theme, and it displays correctly with pasting from Word although ď<strong>Ē is nested in front of the URL. Weird, but I guess Iíll have to see if I can find why pasting from Word does that.

Thanks for your help.
  #4  
Old May 15, 2011, 11:15 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Can you show me an example of the code that gets pasted the is incorrect and some that is correct?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old May 16, 2011, 08:27 AM
OldMan1's Avatar
OldMan1
 
12 posts · Apr 2010
lmilesw, I have created a page for you to look at, called Test for Links. I've removed the sidebar widgets for that page so the "Source" isn't so cluttered.

( Just in case the link above doesn't take: http://www.cps-news.com/archives/test-for-links/ )

The following is copied from the html window of the text editor.

This was typed and hyperlinked in Word then inserted using the "Paste from Word" option in Text Editor:

<strong><a href="http://cps-news.com/">Common Peoples Source for News</a></strong>

This was typed and linked in the text editor applying "Bold" <strong><em>after</em></strong> the link was added:

<strong><a href="http://cps-news.com">Common Peoples Source for News</a></strong>

This was typed and linked in the text editor applying "Bold" <strong><em>before</em></strong> the link was added:

<a href="http://cps-news.com"><strong>Common Peoples Source for News</strong></a>
  #6  
Old May 16, 2011, 09:56 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You have font-weight: normal applied to your links so the <strong> tag is not effective. I suspect this may be in the Body, Text, & Links section of the theme options. Just remove that line.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old May 16, 2011, 06:06 PM
OldMan1's Avatar
OldMan1
 
12 posts · Apr 2010
I took a look at what you a pointed out on the "font-weight: normal". You are right in that it is in the Body, Text, & Links. However, it only gives me an option of "Normal" or "Bold" (I changed it to bold for test and the source page showed it changed to bold, and all links did go bold). I can not remove that line unless I find it in the Editor and comment it out (unless there is some other way of doing that). And if I select "Bold", then all my links in a post will be bold, rather than just the ones I want bold.

In a normal post or page, I wanted my links to be normal so it doesn't distract from reading, thus the reason I changed my link color from the normal blue in post and pages only (see my code for that below, compliments of you, imilesw, back in January --- and again, thanks). The only time I would like to have bold links is when I'm giving a list of links at the bottom of a post or when I use "<li>" or numbers for a list of links in the post.

The following code is in my CSS for post, which also affects pages.

div.post a {
border-bottom: 1px dotted #000000;
color: #603311;
}

div.post a:visited {
border-bottom: 1px solid #388E8E;
color: #388E8E; text-decoration: none;
}

div.post a:hover {
border-bottom: 1px solid red;
color: #000000;
}
  #8  
Old May 16, 2011, 06:33 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I finally took the time to really look at this and the issue is the way Atahualpa handles links as you surmised. You can "correct" this so that all links will be normal unless you bold them by adding the following to ATO>Add HTML/CSS Inserts>CSS Inserts and it won't matter where the <strong> tags are.
HTML Code:
.post-bodycopy a:link {
    font-weight: inherit;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #9  
Old May 16, 2011, 08:24 PM
OldMan1's Avatar
OldMan1
 
12 posts · Apr 2010
Imilesw - YOU DA MAN! Once again, you've solved the problem. Take a look at the link again. I changed nothing except adding the code in my CSS, and now all the links are bold. Great going! This will save me a lot of time.

I'll mark this thread as "Solved".

Bookmarks

Tags
bold, links, nesting, strong

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Widgets not making links bold... interage Sidebars & Widgets 2 Oct 4, 2010 03:35 PM
How Do I Make Page Links Bold In Menu Bar ClearStreams Atahualpa 3 Wordpress theme 3 Apr 21, 2010 04:32 PM
Bold text problem sevensins Center area post/pages 1 Mar 7, 2010 06:14 AM
[SOLVED] I want links not bold but h2 on home page bold...how? jankph New Versions, & Updating 1 Jul 19, 2009 11:30 AM


All times are GMT -6. The time now is 01:30 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.