Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » eCommerce & Atahualpa »

Category Page Broken WP ecommerce


  #1  
Old Apr 25, 2011, 07:28 PM
brideoflinux
 
13 posts · Jan 2011
I just upgraded to wp ecommerce version 3.8.1 and upgraded WP at the same time to 3.1.1 for a site that's still in the build stage but about to go live. Every thing seems to be fine, but... There's always that "but..." If you click on a product category, you get a page that's pretty much broken. No links. Text that should be part of a script displays, all fonts default size... If you click the "all products" page, everything works perfectly.

View a broken category page here: http://tea-sanctuary.com/products-page/bulk-herbs/

View a properly displaying page here: http://tea-sanctuary.com/products-page/

I've pretty well narrowed this down to a theme problem. Everything works fine using the Twenty Ten theme. This site is currently running Atahualpa 3.6.4 - but I had a similar problem running version 3.5.1.

Any help would be greatly appreciated!
  #2  
Old Apr 25, 2011, 08:08 PM
juggledad's Avatar
juggledad
 
23,553 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
There is not enough information to try to help you. How did you build your products, how many products, categories, are all the fields in the products filled in, what values, are you using any extra options (if the plugin has any)

without having access to the site, there are too many variables to try to reproduce something like this. You said you had a similar problem in 3.5.1, well what did you do to fix it then?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Apr 25, 2011, 08:47 PM
brideoflinux
 
13 posts · Jan 2011
It was the same site that had the problem in 3.5.1 after I upgraded wp ecommerce. Upgrading to 3.6.4 solved a related problem (sidebar not showing up on category page). If you follow the links I provided on the first post you can see what I mean and all of the other questions will be answered. As I said, everything displays fine if you look at a list of all products, but when you look at a category page, it's like much of the html is stripped from the source. (Again, all links and images are gone, etc...)
  #4  
Old Apr 25, 2011, 08:48 PM
brideoflinux
 
13 posts · Jan 2011
There are four categories and about seventeen products at this time. My client is adding more even as I try to get this fixed...
  #5  
Old Apr 25, 2011, 09:10 PM
juggledad's Avatar
juggledad
 
23,553 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Chech to see at ato->configure excerpts if you are showing foll posts or excerpts on the various pages. When showing excerpts, HTML is stripped unless you fill in the 'do not strip' option
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Apr 25, 2011, 09:43 PM
brideoflinux
 
13 posts · Jan 2011
Ah, we're getting started. Setting to full doesn't help (evidently wp ecommerce overwrites setting?), but the "do not strip" option works until I get to the AJAX to post to the shopping cart. Maybe I'm just not sure of WHAT to strip here?
  #7  
Old Apr 26, 2011, 06:15 AM
juggledad's Avatar
juggledad
 
23,553 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Since I don't know what you have added to the products, I have no way of knowing. I created a couple products and had no issue, of course I didn't fill them completely in. So like I said, without knowing what is part of the product (ie where and what ajax code did you use)...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Apr 26, 2011, 11:03 AM
brideoflinux
 
13 posts · Jan 2011
We haven't "used" any AJAX code. Whenever you create a new product, a "Add to Cart" button is created in the category list view so that the visitor can purchase the product without any further ado. This is a function of the wp e-commerce app. This "Add to Cart" refers to AJAX code.

Here is an example of the code as it renders in another theme, displaying properly:

<div id="post-123" class="post-123 wpsc-product type-wpsc-product status-publish hentry">

<h1 class="entry-title">Bulk Herbs</h1>

<div class="entry-content">

<div id='products_page_container' class="wrap wpsc_container">








<div class='wpsc_category_details'>

</div>


<!-- Start Pagination -->
<!-- End Pagination -->


<div class="productdisplay default_product_display product_view_123 bulk-herbs">
<div class="textcol">


<div class="imagecol">
<div class="item_no_image">
<a href="http://tea-sanctuary.com/products-page/bulk-herbs/organic-catnip/">
<span>No Image Available</span>
</a>
</div>
</div>

<div class="producttext">

<h2 class="prodtitles">

<a class="wpsc_product_title" href="http://tea-sanctuary.com/products-page/bulk-herbs/organic-catnip/">Organic Catnip</a>


<a class='wpsc_edit_product' href='http://tea-sanctuary.com/wp-admin/post.php?action=edit&amp;post=123'>Edit</a> </h2>



<div class='wpsc_description'><p>Catnip is a member of the mint family. It has calming properties so it works great for anxiety and stress. It also helps with insomnia, stomach ailments, and headaches.</p>
<p>2 oz</p>
</div>





<form class='product_form' enctype="multipart/form-data" action="http://tea-sanctuary.com/products-page/bulk-herbs/organic-catnip/" method="post" name="product_123" id="product_123" >


<div class="custom_meta">
</div>



<div class="wpsc_variation_forms">
</div>

<!-- THIS IS THE QUANTITY OPTION MUST BE ENABLED FROM ADMIN SETTINGS -->

<p class="wpsc_extras_forms"/>
<div class="wpsc_product_price">
<span id="product_price_123" class="pricedisplay"> $5.49</span>Price:<br/>


</div>

<input type="hidden" value="add_to_cart" name="wpsc_ajax_action"/>
<input type="hidden" value="123" name="product_id"/>

<!-- END OF QUANTITY OPTION -->
<div class='wpsc_buy_button_container'>
<input type='image' src='http://tea-sanctuary.com/wp-content/plugins/wp-e-commerce/themes/marketplace/images/atc.gif' id='product_123_submit_button' class='wpsc_buy_button' name='Buy' value="Add To Cart" />

<div class='wpsc_loading_animation'>
<img title="Loading" alt="Loading" src="http://tea-sanctuary.com/wp-content/plugins/wp-e-commerce/images/indicator.gif" class="loadingimage"/>

Updating cart... </div>
</div>
</form>



</div>




This is the code rendered through Atahualpa 3.6.4 that displays broken:

<div class="post-123 wpsc-product type-wpsc-product status-publish hentry odd" id="post-123">

<div class="post-headline"> <h2> <a href="http://tea-sanctuary.com/products-page/bulk-herbs/organic-catnip/" rel="bookmark" title="Permanent Link to Organic Catnip">Organic Catnip</a></h2>
</div>

<div class="post-bodycopy clearfix"><p> <a href="http://tea-sanctuary.com/products-page/bulk-herbs/organic-catnip/"> <span>No Image Available</span> </a><br />
<h2 class="prodtitles"> <a class="wpsc_product_title" href="http://tea-sanctuary.com/products-page/bulk-herbs/organic-catnip/">Organic Catnip</a> <a class='wpsc_edit_product' href='http://tea-sanctuary.com/wp-admin/post.php?action=edit&amp;post=123'>Edit</a> </h2>

<p>Catnip is a member of the mint family. It has calming properties so it works great for anxiety and stress. It also helps with insomnia, stomach ailments, and headaches.</p>
<p>2 oz</p>
<form class='product_form' enctype="multipart/form-data" action="http://tea-sanctuary.com/products-page/bulk-herbs/organic-catnip/" method="post" name="product_123" id="product_123" >
<p class="wpsc_extras_forms"/>
<p> <span id="product_price_123" class="pricedisplay"> $5.49</span>Price:</p>
<p> <img title="Loading" alt="Loading" src="http://tea-sanctuary.com/wp-content/plugins/wp-e-commerce/images/indicator.gif" class="loadingimage"/><br />
Updating cartů </p></form>

<p> <a href="http://tea-sanctuary.com/products-page/bulk-herbs/organic-chamomile/"><br />
<span>No Image Available</span><br />
</a></p>
  #9  
Old Apr 26, 2011, 11:05 AM
brideoflinux
 
13 posts · Jan 2011
The above example is from the top of the column to the end of the first product listing.
  #10  
Old Apr 26, 2011, 12:24 PM
brideoflinux
 
13 posts · Jan 2011
What would help, perhaps, is if I could get no tags inside a category post stripped.
  #11  
Old Apr 26, 2011, 01:09 PM
brideoflinux
 
13 posts · Jan 2011
Okay, I've got the display problem solved for the category pages, except for the fact that the category name at the top of the column, which should read as the name of the category itself, such as "medicinal teas" is now reading as one of the products in that category. Any ideas?
  #12  
Old Apr 26, 2011, 03:54 PM
juggledad's Avatar
juggledad
 
23,553 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
looks like you got it fixed - Yes...No??
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #13  
Old Apr 27, 2011, 08:17 PM
brideoflinux
 
13 posts · Jan 2011
That problem, yes. However, at the top of each category, where it should have the name of the category, I'm getting the name of one of the products.
  #14  
Old Apr 28, 2011, 05:16 AM
juggledad's Avatar
juggledad
 
23,553 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What did you do to 'fix' it, the fix may be the cause of the new problem
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #15  
Old May 6, 2011, 01:47 PM
MikeBegley
 
2 posts · May 2011
I'm running into something similar for a site I'm building for a friend. The site can be seen here:

http://www.lotusluxuries.com/glow-stuff/

In the left column, at the top I'm using the Product Catagory widget, and when a user clicks on a category, the category isn't displayed properly, and the url is http://machine/category-name

Also, at the bottom of the left column, I've simulated the proper behavior using a custom menu. In this case, when the user clicks a link in this menu, I've set the target URL to http://machine/product-page/category-name.

This doesn't happen when I use other themes. This also doesn't happen with the current atahualpa and WP-EC 3.7.x, so I'm not sure if the bug lies in the theme, WP-EC or some interesting interaction between the two.

Thanks for any assistance you can offer!

-mike
  #16  
Old May 19, 2011, 07:21 AM
edwardmccaughan
 
3 posts · May 2011
I'm having a similar problem, but I suspect the problem is that the category view isn't using the ecommerce catagory template to render, but is actually using the blog post (or something along those lines)

(quick warning before I begin, the carneval links are for an adult toys site I'm building for someone. there's no nudity or anything eye watering on it, but if you open it at work, colleagues might get a bit suspicious about your hobbies)

on mine, viewing a catagory throws out the right text, but doesn't bring in the formatting, javascript or custom images that it should:
http://www.buzzwordoverload.co.uk/pe...ory=restraints

changing back to twentyten theme makes it display correctly.

I came across a similar and possibly connected issue on the getshopped support forum:
http://getshopped.org/forums/topic.php?id=19612
but putting the template files in place like it said didn't seem to help me

does anyone with better ideas of how atahualpa picks up custom templates got any clues?
  #17  
Old May 20, 2011, 06:52 AM
edwardmccaughan
 
3 posts · May 2011
One other clue that might help someone solve this, there was a similar issue on a different theme, which was supposedly fixed:
http://getshopped.org/forums/topic.php?id=16329

so when I try:
http://www.buzzwordoverload.co.uk/pe...ory=restraints
it uses the standard blog post template, which doesn't have any formatting, but if I add the page id of the main store page:
http://www.buzzwordoverload.co.uk/pe...ints&page_id=4
it magically starts using the correct template and working perfectly

I'm still learning the internals of wordpress, so poking at the code hasn't given me any obvious solutions, but I will continue poking.
  #18  
Old May 22, 2011, 06:56 AM
lds
 
1 posts · May 2011
#brideoflinux, ref. to post13 and 14, what did you do to solv the problem.

Have the same problem here, been looking for bug fix for weeks, without any results.
  #19  
Old May 22, 2011, 05:25 PM
lmilesw's Avatar
lmilesw
 
10,173 posts · Jul 2009
Central New York State USA
It looks like @brideoflinux switch from WP eCommerce to eShop.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #20  
Old May 23, 2011, 09:19 AM
edwardmccaughan
 
3 posts · May 2011
I've managed to fix this on my site, in an only slightly cludgy way.

I took the Atahualpa "themes/atahualpa364/index.php" template file and replaced the part that normally displays posts with the single product display template from "plugins/wp-e-commerce/wpsc-theme/wpsc-single_product.php" and saved it as: "themes/atahualpa364/taxonomy-wpsc_product_category.php"

this makes atahualpa use that template on that the category view and hey presto, it seems to work as it should.

if anyone wants to try and see if it fixes the problem for them, I've put the file up here:
http://www.buzzwordoverload.co.uk/mi...tegory.php.zip
just drop the .php file inside into your atahualpa theme folder and it should work. probably.

This still doesn't answer the question of why the problem occurs in the first place though :-/
  #21  
Old May 26, 2011, 08:19 PM
jeroenbinken
 
8 posts · Feb 2011
Took me hours to find the cause of the problem! Standard theme does not give any problems, but switching to Atahualpa creates it. Will give "edwardmccaughan" solution a go.
  #22  
Old May 26, 2011, 08:41 PM
jeroenbinken
 
8 posts · Feb 2011
This gives me the extensive list view, how do I edit this file to give me the grid view? Something like a grid of 4x4 thumbnails of the products? In addition, I would like to have a white background (I think it is transparent now?), TIA!

Website is: http://interieurdeco.nl/

Last edited by jeroenbinken; May 26, 2011 at 09:00 PM.
  #23  
Old May 27, 2011, 03:21 PM
jeroenbinken
 
8 posts · Feb 2011
I set ATO>configure excerpts all to show full, but this did not solve the problem. Anybody any ideas, TIA?

BTW I have the latest version all 3 (Atahualpa, Wordpress, WP E-commerce)

Last edited by lmilesw; May 27, 2011 at 08:35 PM.
  #24  
Old May 30, 2011, 06:14 PM
jeroenbinken
 
8 posts · Feb 2011
Anybody any suggestions? I have been trying to figure out what is going wrong, but can't solve this issue.
  #25  
Old May 30, 2011, 11:18 PM
jeroenbinken
 
8 posts · Feb 2011
06:00 in the morning and I found the problem. The product categories widget displays the following link, which does not work

HTML Code:
http://binkengroep.nl/interieurdeco/?wpsc_product_category=kunst
but the link below does work

HTML Code:
http://binkengroep.nl/interieurdeco/?page_id=7&wpsc_product_category=kunst
I assume that I will have to edit the "wpsc-category_widget.php" file? Which contains the following code

<?php
$curr_cat = get_term( $category_id, 'wpsc_product_category', ARRAY_A );
$category_list = get_terms( 'wpsc_product_category', 'hide_empty=0&parent=' . $category_id );
$link = get_term_link((int)$category_id , 'wpsc_product_category');
$category_image = wpsc_get_categorymeta( $curr_cat['term_id'], 'image' );
$category_image = WPSC_CATEGORY_URL . $category_image;
$show_name = $instance['show_name'];

if ( $grid ) : ?>

<a href="<?php echo $link; ?>" style="padding: 4px 4px 0 0; width:<?php echo $width; ?>px; height:<?php echo $height; ?>px;" title="<?php echo $curr_cat['name']; ?>" class="wpsc_category_grid_item">
<?php wpsc_parent_category_image( $show_thumbnails, $category_image , $width, $height, true ,$show_name); ?>
</a>

<?php wpsc_start_category_query( array( 'parent_category_id' => $category_id, 'show_thumbnails' => $show_thumbnails, 'show_name' => $show_name) ); ?>

<a href="<?php wpsc_print_category_url(); ?>" style="width:<?php echo $width; ?>px; height:<?php echo $height; ?>px" class="wpsc_category_grid_item" title="<?php wpsc_print_category_name(); ?>">
<?php wpsc_print_category_image( $width, $height ); ?>
</a>

<?php wpsc_print_subcategory( '', '' ); ?>

<?php wpsc_end_category_query(); ?>

<?php else : ?>
<div class="wpsc_categorisation_group" id="categorisation_group_<?php echo $category_id; ?>">
<ul class="wpsc_categories wpsc_top_level_categories">
<li class="wpsc_category_<?php echo $curr_cat['term_id']; wpsc_print_category_classes($curr_cat); ?>">
<?php if(! ($category_image == WPSC_CATEGORY_URL) ){ ?>
<a href="<?php echo $link; ?>" class="wpsc_category_image_link"><?php
wpsc_parent_category_image( $show_thumbnails, $category_image , $width, $height, false, $show_name ); ?></a>
<?php } ?>

<a href="<?php echo $link; ?>"><?php echo esc_html( $curr_cat['name'] ); ?></a>

<ul class="wpsc_categories wpsc_second_level_categories">

<?php wpsc_start_category_query( array( 'parent_category_id' => $category_id, 'show_thumbnails' => $show_thumbnails , 'show_name' => $show_name) ); ?>

<li class="wpsc_category_<?php wpsc_print_category_id(); wpsc_print_category_classes_section();?>">
<a href="<?php wpsc_print_category_url(); ?>" class="wpsc_category_image_link">

<?php wpsc_print_category_image( $width, $height ); ?>

</a>

<a href="<?php wpsc_print_category_url(); ?>" class="wpsc_category_link">

<?php wpsc_print_category_name(); ?>

<?php if ( 1 == get_option( 'show_category_count') ) wpsc_print_category_products_count( "(",")" ); ?>

</a>

<?php wpsc_print_subcategory( '<ul>', '</ul>' ); ?>

</li>

<?php wpsc_end_category_query(); ?>

</ul>
</li>
</ul>

<div class="clear_category_group"></div>
</div>

<?php endif; ?>

Last edited by juggledad; May 30, 2011 at 11:50 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
WP-eCommerce Examples SupraTT eCommerce & Atahualpa 19 Aug 11, 2011 11:41 AM
Ecommerce issues imwiththebandlq eCommerce & Atahualpa 6 Jul 18, 2010 11:30 PM
[SOLVED] Broken Front Page riw777 Center area post/pages 1 Jun 10, 2010 09:05 PM
eCommerce and Atahualpa jack96161 eCommerce & Atahualpa 32 Jun 9, 2010 01:19 AM
Thanks for the new eCommerce section!! jack96161 eCommerce & Atahualpa 2 Dec 22, 2009 10:20 AM


All times are GMT -6. The time now is 12:14 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.