Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Help required: Warning: fclose(): supplied argument is not a valid stream re


  #1  
Old Apr 20, 2011, 07:02 AM
markwalker's Avatar
markwalker
 
7 posts · Mar 2010
United Kingdom
Send a message via Skype™ to markwalker
Hello Forum,

A warning has appeared at the very top of my blog at: www.whoismarkwalker.com

It reads:

Warning: fclose(): supplied argument is not a valid stream resource in /homepages/5/d75894289/htdocs/wordpress/wp-content/themes/atahualpa346/header.php on line 37

Has anyone received this on theirs and found a fix to remove it?

I would really appreciate any ideas or thoughts.

Thank you so much for taking time to read my post.

Regards,
Mark Walker
  #2  
Old Apr 20, 2011, 08:17 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what did you change?
new plugin?
new post?
did the server change anything?

What version are you running?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Apr 20, 2011 at 08:19 AM.
  #3  
Old Apr 20, 2011, 11:38 AM
markwalker's Avatar
markwalker
 
7 posts · Mar 2010
United Kingdom
Send a message via Skype™ to markwalker
Hi,

Sounds bizarre but nothing... Last post was 29th March... all was well. Updated to latest Wordpress version today but the error was already showing as someone visiting my site emailed me.

I've read up on fclose() but have no idea if I should track down the header.php file and delete it?

I am running Atahualpa v.3.4.5 not had any issue at all so haven't upgraded to 3.6.4 as a) everything has been ok and b) am concerned at loosing my posts, settings etc and loosing time re-writing content or re-installing backups.

Thank you for your help. Any possible suggestions?
  #4  
Old Apr 20, 2011, 12:13 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Atahualpa doesn't use fopen/fclose in 345.
What version of wordpress?
what happens if you switch to another theme temporally
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Apr 20, 2011, 12:40 PM
markwalker's Avatar
markwalker
 
7 posts · Mar 2010
United Kingdom
Send a message via Skype™ to markwalker
Thanks for the reply.

I changed it to: Twenty Ten 1.2 by the WordPress team
The error went away
I changed back to: Atahualpa 3.4.6 by BytesForAll
The error re-appeared
I changed back to the old: Atahualpa 3.4.5 by BytesForAll
The error has re-appeared

I have left it using: Atahualpa 3.4.6 by BytesForAll
- have you seen it on my page?

Thanks again.
  #6  
Old Apr 20, 2011, 12:50 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I'm not seeing it anymore
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Apr 20, 2011, 12:52 PM
markwalker's Avatar
markwalker
 
7 posts · Mar 2010
United Kingdom
Send a message via Skype™ to markwalker
Apologies that should have read
I changed back to the old: Atahualpa 3.4.5 by BytesForAll
The error has disappeared

Thank you.
  #8  
Old Apr 20, 2011, 12:59 PM
markwalker's Avatar
markwalker
 
7 posts · Mar 2010
United Kingdom
Send a message via Skype™ to markwalker
I have left it using: Atahualpa 3.4.6 by BytesForAll

It's there now, right across the top of the page... cheers
  #9  
Old Apr 20, 2011, 02:19 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
can you send me a PM with an admin id/pw - I'd like to look at the code in header.php
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Apr 20, 2011, 02:31 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
also, what version of WP?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Apr 20, 2011, 03:47 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try disabling all your plugins
also you should do something so that if someone visits teh site on an iPad, they don't go to the mobile version - at least give the option to go to the full site.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Apr 21, 2011, 03:41 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Ok, it looks ilke you - or someone - has edited the themes header.php and add a bunch of code for the 'MoFuse Premium API' - that is what is causing the problem. Line 37 is an fclose, but it is not Atahualpa's code. Lines 4-53 are NOT Atahualpa. You need to contact who ever wrote 'MoFuse'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #13  
Old Apr 21, 2011, 04:46 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The user removed that code and everything is now working.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
atahualpa, fclose(), warning message

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is ThemeFrame using Stream wrappers? interfasys ThemeFrame Presales 2 Mar 24, 2011 05:41 PM
Line 42 Char 9 - invalid argument error SunnyL Atahualpa 3 Wordpress theme 4 Sep 2, 2009 08:05 AM
[SOLVED] Errors: Invalid argument supplied for foreach() Call to undefined function skyline Atahualpa 3 Wordpress theme 1 Jun 4, 2009 01:41 AM
All supplied graphics disappeared. Huge thanks from a Newbie for your help. tpatpa Atahualpa 3 Wordpress theme 2 Feb 28, 2009 12:46 PM


All times are GMT -6. The time now is 05:31 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.