Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Godaddy - Error 500


  #1  
Old Apr 1, 2011, 12:13 AM
daxryan
 
4 posts · Feb 2009
I'm using Atahualpa 3.6 and WP 3.0.4 with Godaddy hosting. The site has worked fine up until today with no changes and now I get the 500 Internal Server Error. I can access the backend fine but can't figure out why it's not working now. Godaddy says it's a theme issue but I dont' buy that since it's worked in the past and I have other sites that are working fine as well. The only thing is that other themes do work. I also turned off all plugins to no avail. Any thoughts? Thanks.

Last edited by daxryan; Apr 1, 2011 at 12:17 AM.
  #2  
Old Apr 1, 2011, 04:30 AM
juggledad's Avatar
juggledad
 
23,686 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
this could be a .htaccess file error or you might have the suhosin error.
can you get into the backend.? If so go to the permalinks and switch to the default and see what happens.

If you can't get into the backend, FTP to the site and go to the wp-content/themes folder and rename the atahualpa folder to something else and go into it and rename index.php to indexold.php. Doing this should force WordPress to switch to the default Twenty-ten theme and your site will be back up.

Then I would manually install 3.5.3 and 3.6.4 and look at the 'Suhosin' thread
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Apr 1, 2011, 12:03 PM
brainigirl
 
2 posts · Sep 2010
I've been having the same issue with godaddy since yesterday. They are "working on it" but they don't seem to know what the problem is. My page won't load and I get this message:
IIS 7.0 Detailed Error -- 500.0 - Internal Server Error.

I can't find my .htaccess file on godaddy to make the suggested changes. Any ideas on where to look? Thanks!
  #4  
Old Apr 1, 2011, 02:27 PM
juggledad's Avatar
juggledad
 
23,686 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
did you ask goDaddy what they did yesterday? (What changes they made?)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Apr 4, 2011, 12:28 PM
julieanne
 
1 posts · Apr 2011
I'm having the same issue with GoDaddy. Atahualpa 3.6.4 and WP 3.1
Everything has been working fine... until today. No changes on my end. This has been a static page for months. Now I get the 500 internal server error. I can login to the backend. If I switch to a different theme it works fine, but when I switch back I have the same results. GoDaddy has said that nothing changed on their end.
I'll try reinstalling the theme tonight.

**Also, I have tried disabling all plugins, but it's had no effect.

Last edited by julieanne; Apr 4, 2011 at 12:39 PM.
  #6  
Old Apr 4, 2011, 01:17 PM
juggledad's Avatar
juggledad
 
23,686 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I would ask GoDaddy what change they made to the server., cause if you didn't change anything and it was working, only a change on the server would explain this.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Apr 5, 2011, 04:33 PM
lorenatwork's Avatar
lorenatwork
 
9 posts · Mar 2011
I just tried installing Atahualpa 3.6.4 on a freshly updated install of WP 3.1.1. I had been using the Twenty Ten 1.2 theme with no problems. Immediately after activating Aatahuala I get the Error 500 notice. Changing back to the Twenty Ten theme fixes the Error 500 message.

I am also using Godaddy.

One other thing that I am wondering about. I have WP installed in a /wordpress directory and have site homepage set to the root directory. Again, this setup works fine while using the Twenty Ten theme but I get the error immediately after activating Atahualpa.

Any ideas?
  #8  
Old Apr 5, 2011, 04:46 PM
Lone Prairie
 
3 posts · Sep 2010
On the Wordpress forum, one user noted that upgrading (for free) to Godaddy's GH4 hosting not only fixed his 500 errors but sped his site up considerably. My experience today corroborates this.

GoDaddy also says suhosin is not used or even available on shared or 'web' hosting (GH4), which is what most folks use. It can be installed on virtual and dedicated hosting though.

WP 3.1.1
ATA 3.6.4

Good luck,
e.
  #9  
Old Apr 5, 2011, 05:44 PM
lorenatwork's Avatar
lorenatwork
 
9 posts · Mar 2011
Thanks for the suggestion Lone Prairie. I have the support ticked in for the upgrade at GoDaddy. I will post an update if this solves my problem.

The tech at GoDaddy also pointed out that my hosting was set up to run in the Windows environment instead of Lynix. He said that Wordpress works better and has more options when running in Lynix. Unfortunately, my upgrade path only allowed him to bring my site up to 4GH Windows. We will reevaluate after 24 hours. If the switch to 4GH solves the problem, we may delay the switch to Lynix. I guess that making one change at a time is a better diagnostic tool anyway.
  #10  
Old Apr 6, 2011, 07:00 AM
lorenatwork's Avatar
lorenatwork
 
9 posts · Mar 2011
I got my notice from GoDaddy that my site was now ready. I logged in to my WP Dashboard, activated the Atahualpa theme, logged out, and ta da, Error 500. Went back to the Twenty Ten theme and the error went away.

I guess the next step is to switch the hosting from Windows to Lynix.

Anybody have any other ideas?

The blog is at www.kismettoday.com
  #11  
Old Apr 6, 2011, 07:24 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You might want to try Atahualpa 3.5.3.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #12  
Old Apr 6, 2011, 08:14 AM
lorenatwork's Avatar
lorenatwork
 
9 posts · Mar 2011
Thank you lmilesw.

3.5.3 did the trick.

Do you think that migrating to Linux will allow me to run 3.6.4? Given that this "solved" the problem, do you know what the problem was/is?

Last edited by lmilesw; Apr 6, 2011 at 12:53 PM.
  #13  
Old Apr 6, 2011, 08:39 AM
juggledad's Avatar
juggledad
 
23,686 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Starting with 3.6 the theme author had to change how he was processing the internal PHP. WordPress forbids the use of the eval() function, so he switched to using stream wrappers.

I suspect that you need to tell the server to allow 'bfa' as a stream wrapper. You can try with the php.ini described in the 'Suhosin issue' thread, but I have no experience with windows servers so can't give you any guidance on where to set it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Apr 6, 2011, 10:10 AM
lorenatwork's Avatar
lorenatwork
 
9 posts · Mar 2011
I just got off the phone with GoDaddy. Rather than spend more time troubleshooting in the Windows Server environment, I decided to go ahead with the migration to Linux. My site will be down for 24-72 hours. Maybe the switch to Linux will allow me to use the latest Atahualpa version. Whether this resolves my issues or not, ultimately I believe that working in the Linux environment is a better option.

Thanks to all for your help.

Last edited by lmilesw; Apr 6, 2011 at 12:53 PM.
  #15  
Old Apr 7, 2011, 07:01 AM
lorenatwork's Avatar
lorenatwork
 
9 posts · Mar 2011
Good news. The migration is complete. Atahualpa 3.6.4 and Wordpress 3.1.1 are both working.

Thank you again for all the help and suggestions. And just a little shout out to GoDaddy. Their support staff was helpful, professional, and fast-acting through this process.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Please help. error 500 with subscribe2 plugin and balnk page with wp-mail brains11 Plugins & Atahualpa 3 Feb 11, 2010 11:17 AM
Error 500 - Internal server error gpeery Installing & running WordPress 5 Mar 1, 2009 07:05 PM


All times are GMT -6. The time now is 09:30 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.