Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

v3.3.2 Everywhere "Write a comment" but not activated


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 20, 2009, 10:35 AM
bg74blogger
 
18 posts · Feb 2009
Hello Flynn,

I have problem with the new version of Atahualpa (v3.3.2).

At the moment I am using version 3.2 (see http://www.veilchen-blog.de).
Now I have uploaded v3.3.2 and take a look at the preview version.

Only some articles are activated for comments, but with the new version, on the homepage the footer of the article summary are always shown "Kommentar schreiben" ("Write a comment")...

Is it a bug? Where is the problem?

The link for my preview is:
http://www.veilchen-blog.de/?preview...t=atahualpa332

I hope you can help me.

Thank you
Sven

Last edited by bg74blogger; Apr 20, 2009 at 10:39 AM.
  #2  
Old Apr 20, 2009, 06:56 PM
Flynn's Avatar
Flynn
 
3,762 posts · Oct 2008
Munich, Germany
Your individual setting are probably not passed to the previewed version. It is probably showing the default settings which is to show the comments link on the Homepage, too.
  #3  
Old Apr 21, 2009, 10:29 AM
bg74blogger
 
18 posts · Feb 2009
Hi,

now the new version is activated, but the footer's are still wrong, all articles have the text ("Kommentar schreiben")...
  #4  
Old Apr 24, 2009, 03:50 AM
bg74blogger
 
18 posts · Feb 2009
Hey Flynn,
do you know where the mistake could be?
  #5  
Old Apr 25, 2009, 05:25 AM
Flynn's Avatar
Flynn
 
3,762 posts · Oct 2008
Munich, Germany
Check your settings at Theme Options -> Post / Page Info Items
  #6  
Old Apr 26, 2009, 05:48 AM
bg74blogger
 
18 posts · Feb 2009
Sorry for annoying,

but it doesn't work until now. I reset the settings for "Post/Page Info Items", but in the footer is still written "Leave a comment" for all items!?!? But thats wrong

thx Sven
  #7  
Old Apr 27, 2009, 05:50 PM
Flynn's Avatar
Flynn
 
3,762 posts · Oct 2008
Munich, Germany
What do you have at
Theme Options -> Post / Page Info Items -> FOOTER: Homepage
  #8  
Old Apr 28, 2009, 08:55 AM
bg74blogger
 
18 posts · Feb 2009
this is the text in FOOTER: Homepage

Quote:
%date('F jS, Y')% | %tags-linked('Tags: ', ', ', ' | ')% Category: %categories-linked(', ')% | %comments('Leave a comment', 'One comment', '% comments', 'Comments are closed')% %edit(' | ', 'Edit this post', '')%
here is a screenshot. The content is the standard text after resetting:
http://www.abload.de/img/screenshot19cu.jpg

Last edited by bg74blogger; Apr 28, 2009 at 09:02 AM.
  #9  
Old Apr 28, 2009, 11:02 AM
Flynn's Avatar
Flynn
 
3,762 posts · Oct 2008
Munich, Germany
Delete this:

| %comments('Leave a comment', 'One comment', '% comments', 'Comments are closed')%
  #10  
Old Apr 29, 2009, 05:07 AM
bg74blogger
 
18 posts · Feb 2009
Sorry,
ich glaube wir reden/schreiben etwas aneinander vorbei . Deshalb jetzt mal meine Frage bzw. das Problem nochmal auf deutsch geschrieben.


Also, mit der alten Version vom Theme hat es soweit alles ganz toll geklappt. Ich habe bei einigen Artikeln die Kommentarfunktion deaktiviert und bei einigen die Funktion aktiviert, sodass die User dazu ihren Kommentar schreiben können/sollen.

Seit dem ich aber die aktuellste Version des Themes aktiviert habe, steht bei jedem Artikel "Leave a comment" obwohl das ja eigentlich nicht richtig ist es soll ja so wie mit dem alten Theme sein, das bei denen, wo die Kommentarfunktion aktiviert ist, "Leave a comment" steht und bei denen, wo es deaktiviert ist soll "Comments closed" stehen.

Wie bereits geschrieben habe ich die Settings für die Rubrik "Post/Page Item Infos" geresetten, aber weiterhin wird überall "Leave a comment" angezeigt

Ich hoffe jetzt ist es etwas verständlicher, wo mein Problem ist gerne kannst du mir auch eine PN zu der Sache schicken.

Vielen Dank für deinen schnellen Support (echt spitze!!)
Gruß Sven
  #11  
Old May 4, 2009, 10:21 AM
bg74blogger
 
18 posts · Feb 2009
Hey Flynn,

please take a look at this posting:
http://forum.bytesforall.com/showthr...=5709#post5709

Thats the same problem which I have
  #12  
Old May 5, 2009, 06:10 PM
Flynn's Avatar
Flynn
 
3,762 posts · Oct 2008
Munich, Germany
Looking into it
  #13  
Old May 7, 2009, 02:07 PM
bg74blogger
 
18 posts · Feb 2009
Hi,
for your information: I installed the version 3.3.3 but the same problem.

I also tried to reset the Theme Options with the button "Reset ALL Theme options", but no chance - same problem.

When you need any help to reproduce the problem, please send me a personal message. We also can chat over ICQ. I would like to help you.

Last edited by bg74blogger; May 7, 2009 at 02:36 PM.
  #14  
Old May 15, 2009, 06:21 AM
bg74blogger
 
18 posts · Feb 2009
Hey Flynn,

do you found the bug?

I also tried to install a new test-system (wordpress 2.7.1 included Atahualpa 3.3.3 without any plugin). Although the bug is available...

Is it possible that you forgot an if-statement to check if the option (Settings - Discussion - "Allow people to post comments on the article") is set? I think that is the reason, because this is the option which I have disabled - so all articles which I will publish are comment-disabled. Only if I really want comments to a special article I use the option "Add new article - Discussion - Allow comments on this post").

Greets Sven

Last edited by bg74blogger; May 15, 2009 at 07:23 AM.
  #15  
Old Sep 14, 2009, 04:10 PM
bg74blogger
 
18 posts · Feb 2009
Same problem with WP 2.8.4 and Atahualpa 3.4.1
  #16  
Old Sep 15, 2009, 05:10 AM
juggledad's Avatar
juggledad
 
22,089 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I believe this is related to the version of WP not Atahualpa. I just tested it with
WP 2.7.1 Atahualpa 3.3.3, 3.4.2 - > issue shows up
WP 2.8.4 Atahualpa 3.3.3, 3.4.2 - > no issue

So if all the hacking of earlier versions of WP weren't enough to make you upgrade...
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #17  
Old Sep 15, 2009, 05:23 AM
bg74blogger
 
18 posts · Feb 2009
Sorry but your answer is not clear for me.
The newest version of Wordpress and Atahualpa are installed.

But my problem is still available
  #18  
Old Sep 15, 2009, 05:33 AM
juggledad's Avatar
juggledad
 
22,089 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok, let's review it.

In WP 2.8.4,
1) you go to WP->Dashboard->Settings->Discussion->Default article settings - and uncheck 'Allow people to post comments on new articles'
2) you add a new post and make sure that at the bottom of the page 'Discuessions: Allow comments on this post' is unchecked
3) you go and view the post and it does not say 'comments are closed'

Is this what is happening?

When I do this I get the 'comments are closed'
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #19  
Old Sep 17, 2009, 04:34 AM
bg74blogger
 
18 posts · Feb 2009
Yes, thats right. I've done everything

BUT! you can take a look on my test-installation:
--> http://veilchen-blog.de/testing/

There you can see the problem... the text "Leave a comment" is wrong, in the previous version it was not there when comments are closed. I hope you understand my problem now

here is a screenshot of this problem:
http://veilchen-blog.de/testing/screenshot.jpg

It would be better when in the footer stands "Comments closed" or something else, but it is confusing for users when they click on "Leave a comment" and on the next page they see the text "Comments closed".

Last edited by bg74blogger; Sep 17, 2009 at 04:44 AM.
  #20  
Old Sep 17, 2009, 05:49 AM
juggledad's Avatar
juggledad
 
22,089 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok, (you quite sure your not on WP 2.7.x?)

Please do the following - edit bfa_postinfo.php and go to line 350. You should see a comment at that line '// Comment link'. Add teh following code right before the 'IF' statement on line 355
HTML Code:
        echo '* * * BFA->comment_matches=>'.print_r($comment_matches).'<=* * *<br> ';
this will dump the array that makes up the comment code and allow me to see what is happening a little more.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #21  
Old Sep 25, 2009, 02:09 PM
bg74blogger
 
18 posts · Feb 2009
Quote:
Originally Posted by juggledad
Ok, (you quite sure your not on WP 2.7.x?)
Yes I'm sure

Quote:
Originally Posted by juggledad
Please do the following - edit bfa_postinfo.php and go to line 350. You should see a comment at that line '// Comment link'. Add teh following code right before the 'IF' statement on line 355
HTML Code:
        echo '* * * BFA->comment_matches=>'.print_r($comment_matches).'<=* * *<br> ';
this will dump the array that makes up the comment code and allow me to see what is happening a little more.
I've done that. Please take a look at http://veilchen-blog.de/testing
  #22  
Old Sep 28, 2009, 07:10 AM
juggledad's Avatar
juggledad
 
22,089 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
edit bfa_postinfo.php and find the following line
in ver 3.4.2 it is line #355
in ver 3.4.3 it is line #351

HTML Code:
		if ( !comments_open() AND $comment_matches[8] == "dontshow" ) { 
and change it to this
HTML Code:
		if ( !comments_open() AND $comment_matches[8] == "Comments are closed" ) { 
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #23  
Old Sep 29, 2009, 05:47 AM
bg74blogger
 
18 posts · Feb 2009
Oh juggledad I think that was the reason of this bug.
Thats no bug of the Atahualpa theme? I think so.

Last question: is your realname JTM?
  #24  
Old Sep 29, 2009, 06:09 AM
juggledad's Avatar
juggledad
 
22,089 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Actually this isn't the correct fix. This is a bug that was introduced between 3.2 and 3.3. the fix I gave you will only work if you don't change the 4th parameter in the comments syntax at ATO->Edit POST/PAGE INFO ITEMS - if you change it from 'Comments are closed' the error will pop back up.

I'm still looking for the 'correct' solution

My initials are PMW
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #25  
Old Sep 29, 2009, 08:59 AM
juggledad's Avatar
juggledad
 
22,089 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
ok, the entire fix is in this post http://forum.bytesforall.com/showthr...5584#post15584
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Oct 3, 2009 at 05:50 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem with the &quot;Submit Comment&quot; Box lionel1 Comments, trackbacks & pings 4 Sep 4, 2009 01:06 AM
"Recent-comment" widget (list style) cosmiclove Sidebars & Widgets 5 Jul 13, 2009 06:05 PM
Changing Hover Color of "Submit Comment" Button adum Comments, trackbacks & pings 2 Jun 21, 2009 02:37 PM
Clicking "Leave a comment" does not lead to comment form Fux Comments, trackbacks & pings 2 May 4, 2009 11:34 PM
Customizing "Leave a Comment" text HenryGomez Post-Kicker, -Byline & -Footer 2 Feb 11, 2009 04:07 PM


All times are GMT -6. The time now is 10:15 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.