Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Web page broken after memory error and cache plugin install


  #1  
Old Mar 19, 2011, 10:23 PM
sofasurfer
 
14 posts · Mar 2011
Using Wordpress, Atahualpa theme and NexGen Gallery plugin.
I uploaded some images and got this error...

Fatal error: Out of memory (allocated 53739520) (tried to allocate 16189952 bytes) in /home/bwphoto/public_html/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 182

I contacted Hostgator chat and they told me to install WP SUPER CACHE and W3 TOTAL CACHE. The Super Cache was complicated and after install them both my images will not upload and the images I have will not display properly.

Chat told me they could not install these for me and I would have to do it myself. Seems to me that when a host sells you a product they aught to install the plugins to make it functional.

Looks like I have to wipe it all out and start from scratch because most of my posts are getting NO responses from people who might be able to help. I've been using 3 different forums and Wordpress people just do not want to help people.
  #2  
Old Mar 19, 2011, 11:11 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I doesn't seem like you should be getting out of memory errors with uploading images. How big were the images? What version of WordPres and Atahualpa?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Mar 20, 2011, 04:56 AM
juggledad's Avatar
juggledad
 
23,628 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Actually you could be running out of memory, it depends on how much memory you have been allocated by the host and they are the only ones that can up it. Some hosts allow you to create a php.ini file to increase the amount of memory, others do not. Lots of the 'cheap' hosts have restrictions.

wordpress uses some memory, atahualpa uses some memory, each plugin uses some memory and in addition, the system can be set to prevent uploads beyond a certian size. You can only reduce the number of plugins you are using, convince the host to up the amount of memory that you are allowed to use or switch hosts to one that gives you more memory.

I have to defend the host when they say you have to install the plugins. They did not sell you WordPress because it is free. They might have an install script for it for your convience, but there are thousands of plugins available. Should they be responsible for all of them?

So call them, or see if they have an FAQ about upping the amount of memory that PHP is allowed to use.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Mar 20, 2011, 07:10 AM
sofasurfer
 
14 posts · Mar 2011
According to them the situation is as it is because they are a shared host and they do not allocate adequete memory. Therefore I need to create a cache on my site. That may not be the exact terminology they stated but its the general idea. My point is that if they are going to require a cache to use their site as a normal person would use it, then they should make adding the cache a doable thing for beginners. They also said I would have to use older plugins. Now I have to figure out how to install omly old plugins. O crap! you think I have not already been more confused than I can bare. Just what I need is more confusion.
  #5  
Old Mar 20, 2011, 07:36 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Some of what you are saying seems odd to me. Like using older plugins. Could you supply
  • Version of WordPress
  • Version of Atahualpa
  • How many plugins do you have installed
  • Which of the Hostgator packages are you using
  • It would also be good to see a list of the plugins you are using
  • Link to the site
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Mar 20, 2011, 08:01 AM
sofasurfer
 
14 posts · Mar 2011
Thanks for taking an interest. I hope you can help me out a little. Heres the info.

Hostgator-Baby Plan
WordPress 3.1.
Atahualpa 3.6.4
Plugins that I did not install-Akismet, Hello Dolly, Jetpack
Plugins I did install-Catablog, NexGen Gallery, Scissors
After getting the memory problem I also installed W3 Total Cache. WP Super Cache is also supposedly required but I do not have it yet as it is to complicated.
Site- www.early1900photos.com
  #7  
Old Mar 20, 2011, 08:25 AM
sofasurfer
 
14 posts · Mar 2011
Hear is the text of the chat I had with Host Gator...

(05:16:25 PM) Jayne La: How may I assist you today?
(05:16:26 PM) dar: I am using Wordpress with the NexGen Gallery plugin. I
uploaded some images and got this error...

"Fatal error: Out of memory (allocated 53739520) (tried to allocate 16189952 bytes) in /home/bwphoto
/public_html/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on
line 182".

I tried to look at line 182 like it says but I see nothing there about
memory. Here is line 182...

$this->oldImage =
ImageCreateFromPng($this->fileName);

Someone told me that you can fix this
for me. If you can set my available memory to a higher level I would appreciate
it.
(05:16:59 PM)Various questions to varify my account
(05:26:44 PM) Jayne La: You are running out of memory on your plan. You can
reduce by installing old plugins or installing W3, or WordPress Super Cache
plugin.
(05:27:35 PM) dar: Is this a problem that is caused by having a "cheap" plan?
Will I need to make some purchases?
(05:31:22 PM) Jayne La: It is a problem of shared hosting. We do have to
protect the integrity of the server. However we do offer more php space than
our competitors, you will have to uninstall old plugins and run a cache on this
site.
(05:31:59 PM) dar: Thanks.
(05:32:17 PM) Jayne La: Here is a helpful link for your site
http://codex.wordpress.org/WordPress_Optimization
(05:32:49 PM) dar: I appreciate that

Last edited by sofasurfer; Mar 20, 2011 at 08:51 AM.
  #8  
Old Mar 20, 2011, 09:06 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Do you have any idea of how large the files you're trying to upload are?
  #9  
Old Mar 20, 2011, 09:26 AM
sofasurfer
 
14 posts · Mar 2011
Some of my image file are upwards of 25 mg. But I have trouble with much smaller also. It seems that success comes with files of 2 mg or smaller. HG chat told me that large files should not be a problem. But then instead of saying that HG would fix my problem they said to try using ftp, which I was able to uplaod large files with. However, by then I was having problems because of improper installation of the WP Super Cache plugin, I think.
I am really out of my league here. I do not even know what the memory issue is in regards to, uploads, storage, processing or what.
  #10  
Old Mar 20, 2011, 10:01 AM
juggledad's Avatar
juggledad
 
23,628 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Wow a 25 meg image, do you realize how long someone would have to wait for the page to render?
I try to keep my images to less than 100K.

One of the php options is how large a file you can upload and I would suspect it is much lower than 25meg.

Why are you trying to load such a large image?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Mar 20, 2011, 10:04 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
What Juggledad said. Sheesh. Maybe I could imagine making huge files available to purchase and download, with thumbnails to display them, but not to render on the screen.
  #12  
Old Mar 20, 2011, 10:11 AM
sofasurfer
 
14 posts · Mar 2011
I am using such large images because those are what I have. I don't want to bother reducing them at this point since I do not even know if that is the problem. My understanding is that they are automatically reduced by the host. I have asked what size to reduce them to but that is one of the many questions that nobody answered. I have not had trouble with slow loads yet, as like I said, I think they are automatically reduced. I noticed in file manager the original is stored and there are also 5 other smaller sizes stored, so I know that there is some automatic resizing going on.
Now, is my memory problem caused by image size or what? I never uploaded more than 5 or 6 so....
Whats the root cause of my problem? Whats my total memory available? What uses this memory, images, processing, plugins or what?
  #13  
Old Mar 20, 2011, 10:15 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
This is what I would do if I were you: delete all of those images from Hostgator. Disable all of your plugins. Then see if the site loads normally.

If so, then I would resize the images myself using Photoshop or some other photo editing application, making them no larger than 100K or so. Then enable the plugins one by one, checking each time to make sure all is well. Only when you have NextGen Gallery reactivated should you start working with your newly small photo files.

I use Hostgator for almost all of my Wordpress sites, and I've never had this problem, even for the sites using the Baby plan.
  #14  
Old Mar 20, 2011, 10:19 AM
sofasurfer
 
14 posts · Mar 2011
Okey Dokey!
Thanks for your attention and your advice. I shall do as you say.
I'm goin' in!!
  #15  
Old Mar 20, 2011, 10:23 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
OK, troops. Listen up. He's going in. If we don't hear from him in 1 hour, we'll send in the bloodhounds.
  #16  
Old Mar 20, 2011, 11:31 AM
sofasurfer
 
14 posts · Mar 2011
I removed some plugins. I removed W3 Total Cache which I then found was a mistake. It totally glitched me. Then I found a backup that I did 8 days ago. Restored it and the glitch was fixed. I do not understand though why a backup from 8 days ago left intact changes I made 4 days ago. Hmmm.
Anyway, I removed all optional plugins and themes that I had tried and decided not to use. I removed all images that I uploaded except for my header which is the only thing I have done right. I also found that there are about a million images packed away inside my file manager that do who-knows-what. I bet many of them can be removed later.
To be continued...

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Out of memory error line 2930 tlck9 New Versions, & Updating 4 Jan 26, 2011 05:13 PM
Should I Install W3 Total Cache Before My Plugins & Theme For Wordpress! highbids Plugins & Atahualpa 1 Jan 9, 2011 04:42 PM
Error: Exhausted Memory Size of Page Mande Center area post/pages 1 Jan 29, 2010 10:35 AM
[SOLVED] Can't install Sociable Plugin, get a Parsing error vadkins Plugins & Atahualpa 4 Dec 9, 2009 05:30 PM
web site broken, apparently in Atahualpa joe hark Atahualpa 3 Wordpress theme 4 Nov 7, 2009 11:59 AM


All times are GMT -6. The time now is 10:07 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.