Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Widgets not automatically styled like theme in update


  #1  
Old Mar 3, 2011, 12:46 AM
Sundrop
 
14 posts · Dec 2009
Since I updated to Atahualpa 3.6.4, I find that links, etc. are not styled in widgets the same way they are in the rest of the theme.

I've had to go in and set the CSS for the widgets so that the look there matched the rest of the site.

Is there a reason that it is better or necessary for 3.6.4 to be this way as opposed to the way it used to be?

Thanks.

Last edited by Sundrop; Mar 3, 2011 at 12:48 AM.
  #2  
Old Mar 3, 2011, 04:35 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
please go to ato->export/import settings and export your settings, then attach them to a reply. That way I can take a look in 3.5.3 and 3.6.4 of your settings and see what you mean.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 3, 2011, 09:48 AM
Sundrop
 
14 posts · Dec 2009
I added this to the CSS so that the site would behave as it had under the previous version of Atahualpa:

.widget .entry-meta a:link {font-weight: bold;}
.widget .entry-summary a:link {font-weight: bold;}
.widget .byline a:link {font-weight: bold;}
.widget h2.entry-title a:link {font-weight: bold;}
.widget .textwidget a:link {font-weight: bold;}
Attached Files
File Type: txt ata-exportsettings-20110303.txt (22.4 KB, 669 views)
  #4  
Old Mar 3, 2011, 09:05 PM
Sundrop
 
14 posts · Dec 2009
And I should add that I appreciate your interest and willingness to take a look at it, juggledad. Thanks.
  #5  
Old Mar 4, 2011, 05:50 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The issue you are seeing is because of an enhancement to the code. See BUGFIX 361-03: Allow Tag widget links to use Atahualpa widget link styling.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Mar 4, 2011, 10:45 AM
Sundrop
 
14 posts · Dec 2009
Thank you, juggledad.

I may use the fix recommended there, or perhaps I'll note it for future use in case it's needed since I have fixed my immediate issue with additions to CSS.

I have wondered if this was related to this issue mentioned in this other thread of tables not being styled the same in widgets as they are in the rest of the theme.

Thank you again.
  #7  
Old Mar 4, 2011, 11:48 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The problem with styling widgets is that Flynn (the developer of Atahualpa) has no control of what other people use as their naming conventions. If the widget creates a class of 'banana-frog' there is no way to predict that that class name will be used. This is why, when you go to style a widget, FireBug in FireFox can be your friend. You can see the CSS being used, the ID's and classes, so you can construct the CSS Insert you need.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Atahualpa update change my sizes for titles posts, widgets etc. bajads New Versions, & Updating 2 Jan 17, 2011 04:56 AM
Menu item without page link is not styled webalyst Page & Category Menu Bars 3 Dec 28, 2010 02:52 PM
Update blog theme: windows live writer bsekula Forum How-To 2 Oct 2, 2010 12:12 PM
[SOLVED] How do I (can I?) used styled text in the logo area? jahmin Header configuration & styling 2 Sep 19, 2010 06:52 AM


All times are GMT -6. The time now is 01:30 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.