Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Template with Custom Header -- No Image


  #1  
Old Mar 1, 2011, 04:03 PM
epsymp
 
37 posts · Jul 2010
So I made a template called forum.php:
<?php
/*
Template Name:forum
*/
?>

and I called the usual team:
<?php /* get all options: */
include (TEMPLATEPATH . '/functions/bfa_get_options.php');
include (TEMPLATEPATH . '/forumheader.php'); ?>


forumheader.php also wanted to call some friends, hence:
<!-- Header -->

<td id="header" colspan="<?php echo $cols; ?>">

<!-- <?php bfa_header_config($bfa_ata['configure_header']); ?> -->
<?php include (ABSPATH.'wp-content/themes/atahualpa353/forumheader.htm'); ?>

<?php wp_nav_menu( array( 'sort_column' => 'menu_order', 'container_class' => 'menu-header2' ) ); ?>

</td>
<!-- / Header -->


Forum .htm was there:

<html>
<head>
</head>
<body>

<!-- Header -->
<!-- <div id="imagecontainer" class="header-image-container" style="background: url('http://www.toadthejournal.com/wp-content/themes/atahualpa353/images/forum/art.jpg') top left no-repeat;"><div class="clickable">
<a class="divclick" title="Words" href="http://www.toadthejournal.com">&nbsp;</a></div></div> -->
<!-- / Header -->
</body>
</html>


and the menu showed up.

But alas, the header image was nowhere to be seen!

http://toadthejournal.com/?page_id=2119

Any ideas for how to get him to turn up?
  #2  
Old Mar 1, 2011, 04:47 PM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
use index.php as a base for a template.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 1, 2011, 05:07 PM
epsymp
 
37 posts · Jul 2010
hi juggle dad.

almost the whole thing is set, the only difference is at the top. I will show you ever code mention before "<?php /* If there are any posts: */"
(I'll leave out the template name section)



ON THE FORUM.PHP:

<?php /* get all options: */
# error_reporting(-1);
include (TEMPLATEPATH . '/functions/bfa_get_options.php');
global $bfa_ata;
include (TEMPLATEPATH . '/forumheader.php'); ?>



ON THE INDEX.PHP:
<?php /* get all options: */
# error_reporting(-1);
include (TEMPLATEPATH . '/functions/bfa_get_options.php');
global $bfa_ata;
get_header(); ?>


I assume
include (TEMPLATEPATH . '/forumheader.php'); ?>
is meant to replace
get_header(); ?>
in order to specify a different path for the header image.
  #4  
Old Mar 1, 2011, 08:26 PM
epsymp
 
37 posts · Jul 2010
Ok, so I think I found a better way to try this. I got the idea from reading an old post...

I think you might recommend something like this?

body.page-id-2119 div#imagecontainer {
background-image: url('http://toadthejournal.com.com/wordpress/wp-content/themes/atahualpa353/images/forum/art.jpg') !important;
}

Is this code correct? Any guess for why the header space is there, is a link...yet the image doesn't show?

Thanks.
  #5  
Old Mar 2, 2011, 05:02 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Is your site really toadthejournal.com.com? (see the code from the last post)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Mar 2, 2011, 05:23 AM
epsymp
 
37 posts · Jul 2010
I wish I could say that's what the problem was. I actually didn't make that mistake in the CSS.

body.page-id-2119 div#imagecontainer {
background-image: url('http://toadthejournal.com/wordpress/wp-content/forumheader/art.jpg') !important;
}

And I've now tried it with different images, so I know it's not an issue with the image.
  #7  
Old Mar 2, 2011, 06:11 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
if you enter the html of the image is should show, but when I enter
HTML Code:
http://toadthejournal.com/wordpress/wp-content/forumheader/art.jpg
I get a not found, so the image is either not there or there is a permission issue.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Mar 2, 2011, 05:10 PM
epsymp
 
37 posts · Jul 2010
I was playing around a little with what JD said in the last post.

This is the regular header location: http://toadthejournal.com/wordpress/...dFlyHeader.png
and the regular header works in the page, but if I just search that image there's also a Not Found.

Here's exactly what I have for the alternate header:
body.page-id-2119 div#imagecontainer {
background-image: url('http://toadthejournal.com/wordpress/wp-content/forumheader/Art.png') !important;
}

and here's the image path:
/var/www/html/wp-content/forumheader

the image Art.png is there, with permissions at 0777.

I understand if this isn't worth your time, I'm willing to give up, but if anyone has an idea let me know!

ES
  #9  
Old Mar 2, 2011, 05:14 PM
epsymp
 
37 posts · Jul 2010
Also, I know the image works, because if I put it in the header folder, it rotates with the usual header image.
  #10  
Old Mar 2, 2011, 05:20 PM
epsymp
 
37 posts · Jul 2010
...yes!

i just took out "wordpress" from the path. simple enough.


Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to make custom template with exact format except header and menus Rashell Header configuration & styling 4 Dec 14, 2009 07:57 PM
Custom links IN header image mkny13 Header configuration & styling 7 Jul 21, 2009 11:13 AM
Adding shortcode in custom template paulae Plugins & Atahualpa 1 May 21, 2009 04:20 PM
Creating custom post template paulae Atahualpa 3 Wordpress theme 3 Mar 18, 2009 10:36 AM


All times are GMT -6. The time now is 12:10 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.