Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

Comments allowed on specific pages


  #1  
Old Jan 13, 2011, 02:09 PM
brodammer
 
18 posts · Aug 2010
Hello, I would like to have comments allowed on only a few pages of our site. We are a library and I will be putting a book up for discussion. We would like users to answer but only on that page for now. There may be a few other pages like that in the future but for now I really need it on just one. I have looked through threads multiple times and don't see an answer for this.
  #2  
Old Jan 13, 2011, 03:16 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you are allowing comments on pages,
Go to dashboard->pages edit the page you don't want comments on, find the section 'discussion' and uncheck the 'Allow Comments' box
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 13, 2011, 03:59 PM
brodammer
 
18 posts · Aug 2010
I am using 3.5.1 and I don't see a discussion section on the edit page. Do I need to upgrade or something. I only want it on one page. Does this mean I will have to open it to all and then deactivate it on all but one?
  #4  
Old Jan 13, 2011, 05:58 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
go to ato-Style & configure COMMENTS and there is an option to allow comments on pages (this is an Atahualpa feature, you normally don't have comments tied to pages.)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Mar 16, 2011, 08:29 AM
rperkins3
 
5 posts · Oct 2010
I also wanted the comments to appear only on one "page" page. Unchecking the "allow comments" box, as described in this thread, worked. However, for the pages that have the "do not allow" box checked, the words "comments are closed" appear. Is there a way to remove this on the pages that the user is not allowed to leave a comment? Thank you.
  #6  
Old Mar 16, 2011, 11:25 AM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
one easy way would be to go to ato->Style & configure COMMENTS->Comments Are Closed text and blank out the option. However this would effect All places where the comments are closed, posts as well.

A more elegant way would be to change the option value to
HTML Code:
<p class="comment_closed">Comments are closed.</p>
then add a CSS Insert
HTML Code:
body.page p.comment_closed {display:none;}
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
comments box

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
hide title on specific pages lambdaka Center area post/pages 0 Jul 10, 2010 09:25 AM
How to put specific SWF files on specific pages as header images? kippiper Header configuration & styling 2 Dec 10, 2009 08:23 AM
Signatures allowed for donors Flynn Announcements 0 Jul 22, 2009 08:17 AM
How do I allow readers to search and go to specific comments? rewardshelp Comments, trackbacks & pings 3 Jun 29, 2009 08:31 PM
Fatal error: Allowed memory size ver3.1 aliferste Atahualpa 3 Wordpress theme 2 Dec 20, 2008 03:03 AM


All times are GMT -6. The time now is 05:01 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.