Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

Is there a known bug with featured image captions and excerpts?


  #1  
Old Jan 12, 2011, 07:24 PM
singledudetravel
 
35 posts · Jan 2011
I have found that when I switched to excerpt view if the featured image has a caption it displays incorrectly on the front page. Instead of not displaying at all on the front page, or displaying under the image the caption appears as the first line of the excerpt as if it's the first line of the article. I have actually had similar problems with other themes. Any way to fix this?

Thanks.
  #2  
Old Jan 12, 2011, 08:35 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What is your version of Atahualpa and WP?
What is the URL point to the issue?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 13, 2011, 06:27 AM
singledudetravel
 
35 posts · Jan 2011
"What is your version of Atahualpa and WP?" The latest of both: Wordpress 3.0.4 and Atahualpa 3.6.1.

"What is the URL point to the issue?"

http://www.singledudetravel.com/ - on our latest post "Central America: “The Stepping-Stone”" (if it hasn't scrolled down by the time you read this) you will see what looks like the first line of the post "Costa Rican Chicas" but really that should simply be the featured image capture.

I have a similar (but worse problem) with WP Cover theme where sometimes it shows some of the [caption] code. That's why I thought it might be some kind of a known issue.

Thank you.
  #4  
Old Jan 13, 2011, 07:07 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
How are you defining the thumbnail? as a featured image? or do you use a plugin?
please attach a copy of your settings (ato->export/import settings)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jan 13, 2011, 07:47 AM
singledudetravel
 
35 posts · Jan 2011
Just using the normal built in functionality. There's no plugins involved that I know of. Here is the settings and screen shot of the image definition.


Here you go. Thanks.

Last edited by singledudetravel; Jan 27, 2011 at 03:46 PM.
  #6  
Old Jan 14, 2011, 10:29 AM
singledudetravel
 
35 posts · Jan 2011
Here is a screen shot and the actual code involved:

HTML Code:
[caption id="attachment_183" align="alignleft" width="300" caption="Costa Rican Chicas"]<a href="http://www.singledudetravel.com/wp-content/uploads/2011/01/costa-rican-chicas.jpg"><img class="size-medium wp-image-183" title="Costa Rican Chicas" src="http://www.singledudetravel.com/wp-content/uploads/2011/01/costa-rican-chicas-300x241.jpg" alt="Costa Rican Chicas" width="300" height="241" /></a>[/caption]
Thanks.

Last edited by singledudetravel; Jan 27, 2011 at 03:46 PM.
  #7  
Old Jan 27, 2011, 12:04 PM
singledudetravel
 
35 posts · Jan 2011
Is there any hope of fixing this some how?

Thanks.
  #8  
Old Jan 27, 2011, 01:54 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
it's not a bug, the [caption..] is a short code, it gets expanded into HTML code. All html is stripped from a excerpt or ignored by default.

You need to look at your site when the issue appears. Then look at the the browsers 'view source' option to look at the code that was generated. Now find what the [caption] shortcode was changed to and add that HTML to the 'Do not exclude' section of the excerpt page.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Jan 27, 2011, 01:57 PM
singledudetravel
 
35 posts · Jan 2011
Quote:
Originally Posted by juggledad
it's not a bug, the [caption..] is a short code, it gets expanded into HTML code. All html is stripped from a excerpt or ignored by default.

You need to look at your site when the issue appears. Then look at the the browsers 'view source' option to look at the code that was generated. Now find what the [caption] shortcode was changed to and add that HTML to the 'Do not exclude' section of the excerpt page.
great. makes perfect sense. I think i can handle that. thank you.
  #10  
Old Jan 27, 2011, 02:58 PM
singledudetravel
 
35 posts · Jan 2011
Quote:
Originally Posted by juggledad
it's not a bug, the [caption..] is a short code, it gets expanded into HTML code. All html is stripped from a excerpt or ignored by default.

You need to look at your site when the issue appears. Then look at the the browsers 'view source' option to look at the code that was generated. Now find what the [caption] shortcode was changed to and add that HTML to the 'Do not exclude' section of the excerpt page.
Is there a chance this just isn't fixable? The only thing I could find to add to exclude was the <div> tag but adding that to exclude created other worse formatting errors...

Thanks.
  #11  
Old Jan 27, 2011, 03:28 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Did you not see the <img> ??
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Jan 27, 2011, 03:36 PM
singledudetravel
 
35 posts · Jan 2011
Quote:
Originally Posted by juggledad
Did you not see the <img> ??
Yes (sorry didn't include in my post) but that one doesn't help either.
  #13  
Old Jan 27, 2011, 03:41 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what post is displaying the issue? The site looks fine.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Jan 27, 2011, 03:47 PM
singledudetravel
 
35 posts · Jan 2011
Quote:
Originally Posted by juggledad
what post is displaying the issue? The site looks fine.
Well yes because I keep changing it back when it fails so the site doesn't look all screwed up. Attached screen shot is the result of adding <img>, <div> and <span> to exclusions. I tried them all individually and they each produce a different kind of mis formatting.
Attached Thumbnails
Click image for larger version

Name:	Untitled.png
Views:	535
Size:	122.8 KB
ID:	1083  
  #15  
Old Jan 27, 2011, 04:00 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I can not recreate your issue and if I can't see it on your site, there is not much I can do.

Document a sample, exactly how you add both the image and the featured image to the pos. It maybe that I'm doing it differently.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #16  
Old Mar 19, 2011, 10:35 PM
Hui-Neng
 
1 posts · Mar 2011
Hi,

I came across the same type of error on my site. Here's how I recreate it.

I had set the excerpt length to default of 55. When I use the wordpress post editor's "Insert More Tag" function, it will override the excerpt function in Atahualpa.

I fixed by forcing all excerpts to go to be the excerpted version in the else statement. I am not sure why (count($words) < $post_content_length) causes an error, but it does on my site. Once I commented out the below section, the bug went away.

Quote:
// Custom Excerpts

if (count($words) < $post_content_length) {
// use the teaser and its 'read more'
$bfa_ata_more_tag_final = str_replace("%post-title%", the_title('', '', false), $bfa_ata['more_tag']);
$text = the_content($bfa_ata_more_tag_final);
return $text;
} else {
I hope this helps!

Hui-Neng
  #17  
Old May 27, 2011, 03:45 PM
cliffbird
 
46 posts · Jul 2009
I have been experiencing the same problem - when a post is displayed as a excerpt the image caption becomes the first line of the post.

I was able to fix this by simply filling in the excerpt field with a excerpt when creating a post rather then leaving the excerpt field blank.

Bookmarks

Tags
excerpts, image captions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Captions Showing in Excerpts - Is there a way to remove them? adum Excerpts, Read more, Pagination 4 Oct 5, 2010 06:41 AM
Captions in Excerpts and "Share" text in Excerpts cvan Excerpts, Read more, Pagination 1 Oct 2, 2010 05:03 PM
Image Captions on Excerpts Jurgen Estanislao Forum How-To 0 Aug 13, 2010 10:56 PM
Links in image captions paulae Atahualpa 3 Wordpress theme 1 Jul 16, 2009 09:01 AM
Captions won't show under image vka2b Atahualpa 3 Wordpress theme 0 Mar 24, 2009 09:01 PM


All times are GMT -6. The time now is 10:16 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.