Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Title looks weird with Yoast Wordpress SEO


  #1  
Old Dec 22, 2010, 11:07 AM
knife
 
11 posts · Dec 2010
Hi, I've installed the Yoast Wordpress SEO plugin on my blog and now my titles look weird. For example, on the main page the title now looks like this: Sarapen >> Sarapen. If I go into a post it looks like this: Post Title >> SarapenSarapen. I think it does something with titles for SEO, but when I go to the Options page I see that all of the Title options are still blank.

How do I fix this? Should I just uninstall the plugin? It has a bunch of pretty handy stuff so I'm wary of doing it. For now, I have it deactivated.
  #2  
Old Dec 22, 2010, 11:09 AM
knife
 
11 posts · Dec 2010
Oops, pretend the arrows are going in the other direction. So it actually looks like this:

Sarapen << Sarapen
Post Title << SarapenSarapen
  #3  
Old Dec 22, 2010, 03:59 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I don't see that on Firefox or IE
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #4  
Old Dec 22, 2010, 09:11 PM
knife
 
11 posts · Dec 2010
Sorry, I deactivated the plugin. I've reactivated it and I can see the messed up title in Firefox.
  #5  
Old Dec 23, 2010, 07:06 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Quote:
Originally Posted by knife
Sorry, I deactivated the plugin. I've reactivated it and I can see the messed up title in Firefox.
I can't duplicate this issue. Do you have the latest version (0.2.1)?

I happen to like this plugin but as pransyt suggested you could try another to see how it works for you. Make sure and have just have one activated at a time.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Dec 23, 2010, 01:32 PM
knife
 
11 posts · Dec 2010
Yup, everything is set to the latest version, Wordpress, Atahualpa, and the SEO plugin. I guess I'll try that All in One SEO pack.
  #7  
Old Dec 23, 2010, 04:23 PM
knife
 
11 posts · Dec 2010
I looked into it some more and someone instructs you to do this:

Quote:
Be aware that for WordPress SEO to be able to modify your page titles, the title section of your header.php file should look like this:

<title><?php wp_title(''); ?></title>

If you can't modify or don't know how to modify your template, check the box below. Be aware that changing your template will be faster.

Force rewrite titles
I tried looking but couldn't find what I was supposed to modify in the header.php file, so I checked the "Force rewrite titles" box. The title thing is kind of fixed now except the title for my front page is "Sarapen -" with a hyphen. Plus I prefer the << arrows, but instead it uses the hyphen too so that titles in posts and pages look like this: Post Title - Sarapen. Any clues on replacing the hyphen and removing it from the front page title?
  #8  
Old Dec 23, 2010, 04:31 PM
juggledad's Avatar
juggledad
 
23,573 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Make sure you have ATO->Configure SEO->Use Bytes For All SEO options? set to 'NO'
that will cause the code to use
HTML Code:
<title><?php wp_title('&laquo;', true, 'right'); ?><?php bloginfo('name'); ?></title>
to build the title otherwise it uses the blog name or the page name or post name (if a single page)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Dec 23, 2010, 05:57 PM
knife
 
11 posts · Dec 2010
I've never touched that menu so it's already set to the default 'NO' option.
  #10  
Old Dec 24, 2010, 08:05 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I just found out that the WordPress SEO conflicts with Kimily Flash embed plugin and gave me the same symptoms. I switched to another flash embedding plugin and all is good. I like the new flash embed plugin better too. If you don't have Kimily Flash embed installed you probably have another plugin conflicting with Yoast's plugin.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old Dec 24, 2010, 04:38 PM
knife
 
11 posts · Dec 2010
I don't have that plugin installed so I guess it's something else. I think I'll stick with the slightly odd-looking title until the plugin author issues an update, apparently his users talk about it on his forum so it should be on his radar.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] New Wordpress SEO plugin compatible? JaneD Plugins & Atahualpa 13 Oct 27, 2010 08:26 PM
[SOLVED] Removing Blog Title for SEO Blackjax Header configuration & styling 3 Aug 22, 2010 02:31 AM
SEO Title Tag 2.3.3 and Atahualpa sparksmex Plugins & Atahualpa 1 Nov 8, 2009 12:33 PM
SEO Title doesn't work permutations Plugins & Atahualpa 3 May 14, 2009 02:36 PM


All times are GMT -6. The time now is 12:23 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.