Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Working with a PNG header?


  #1  
Old Dec 21, 2010, 03:04 PM
implet
 
26 posts · Dec 2010
I am trying to use a transparent header file. I would like the site background to show through. I also plan on adding buttons to the right side of it (contact, etc) if that matters. I tried to set the background to transparent in this piece of code from the insert area:

Code:
div#imagecontainer { 
border-top: solid 5px #333; 
border-bottom: solid 5px #333; 
background-color: black !important;
}
That code was already there, but I added a background-color: black !important; to it. It works with any color I specify, but won't work when I just say transparent. It just turns white when I try to.

Website is here.
  #2  
Old Dec 21, 2010, 03:10 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
If you want a partially transparent header image I would just create the image as png with transparency at the level you want.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Dec 21, 2010, 03:21 PM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
that's because the header image is sitting on top of the container and the container has a background color of White set so the white shows. (ato->Style & configure LAYOUT->Layout Container Style)

The container is sitting on top of the background, so it will cover the background image with white unless you make it transparent also.

The code in the CSS inserts is from a demo style that is given, there are 4 of them in the style folder. If you haven't done much to the site, go to ato->export/import settings and export your settings (this way you can get back to where you are right now.) Then get a copy of the tHeme on your computer and if you look in the atahualpa/styles folder you will see some styles.

At ato->export/import settings IMPORT 'ata-classic.txt' - this is the theme with no extra options set. It is a great place to start off from.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Dec 21, 2010, 03:58 PM
implet
 
26 posts · Dec 2010
Thank you very much for the assistance! The answer to one question led me to two more however.

1) There appears to be a border in color #eee I think, and I can't find it in the options for the life of me!

2) Is there a way I can get a background area (just like the one on the navigation widget) for the content area?
  #5  
Old Dec 21, 2010, 04:06 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
For question 1 look in ATO>Style Posts & Pages. You should see a border in the first box. You could put a background color in that same box to take care of question 2.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Dec 22, 2010, 03:18 PM
implet
 
26 posts · Dec 2010
Thank you, this cleared everything up. I notice some threads say [Closed] when the question is answered. Do I do that myself, or do the moderators close it?
  #7  
Old Dec 22, 2010, 04:22 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You can close it by going to Thread Tools at the top of the thread and click on "Mark Thread as Solved". I will do that for you on this one.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
rotating header image not working after images/header folder delete cpickeri Header configuration & styling 7 Oct 12, 2011 05:03 AM
background7.png (no repeat but more like 90% width) igabriela Header configuration & styling 1 Aug 12, 2010 04:20 AM
[SOLVED] PNG image with transparency not displaying correctly scombridae1969 Center area post/pages 4 Aug 5, 2010 12:24 PM
logo.png - question Goggo Header configuration & styling 3 Apr 14, 2010 02:25 PM
IE Png Fix not working? SteelersFan Atahualpa 3 Wordpress theme 1 Nov 22, 2009 02:19 AM


All times are GMT -6. The time now is 11:05 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.