Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] How to get atahualpa to display h1 tags around title.


  #1  
Old Dec 12, 2010, 12:31 PM
Cheers
 
105 posts · Jun 2010
I have been doing a number of SEO analysis' of my website and consistently I am told there are no h1 tags on the home page or on post pages. Can you please tell me how I can force Atahualpa to designate my titles as h1? Some even suggest that it wouldn't hurt if both the <title><h1>This Would Be My Title</h1></title> surrounded the title as it would then be seen in the source code.

Incidentally, I am using a custom Graphic in my logo header area. The website is winekitmaking.com

Assistance greatly appreciated.

Last edited by Cheers; Dec 12, 2010 at 12:36 PM.
  #2  
Old Dec 12, 2010, 12:42 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
In ATO>Configure SEO set "Make Post/Page Titles H1?" to Yes.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Dec 12, 2010, 12:48 PM
Cheers
 
105 posts · Jun 2010
That setting is already set to "Yes" and still when you look at the source code, the title is only surrounded by <title></title> tags. Remember, I'm not using the "Style & edit HEADER AREA" settings for "Show Blog Title" or for "Show Tag Line". I am using only a graphic image to display my Blog title and tag line. So I am reliant upon displaying the Wordpress General setting for title.

Quote:
Originally Posted by lmilesw
In ATO>Configure SEO set "Make Post/Page Titles H1?" to Yes.

Last edited by Cheers; Dec 12, 2010 at 12:55 PM.
  #4  
Old Dec 12, 2010, 03:46 PM
KatyDigg's Avatar
KatyDigg
 
319 posts · Jul 2009
Same situation as Cheers

I have ATO > Make Post / Page Titles > set to Yes
  #5  
Old Dec 12, 2010, 04:47 PM
juggledad's Avatar
juggledad
 
23,569 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
in order to have an <h1> on the front page, when the front page is the blog page, you must have eithor ato->Style & edit HEADER AREA->Show Blog Title? set to YES or
ato->Header Image->Overlay Blog TITLE over Header Image(s)? set to YES
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Dec 12, 2010, 04:57 PM
Cheers
 
105 posts · Jun 2010
OK. But if I don't want to do either? Is there any way to insert the Blog Title into the footer and use Z index and absolute positioning to force it under the header image in a centered blog? There must be some way to have the Title show in the page source as a h1 without annihilating the look of your home page. You guys are "code Geniuses"
and I suspect that you can do anything with code. It's only us "ignorant few" that are helpless when it comes to code. (That's a BIG compliment to You!) And, Well meaning.
  #7  
Old Dec 12, 2010, 05:03 PM
juggledad's Avatar
juggledad
 
23,569 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
use '.blogtitle {display:none !important;}' in css inserts
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Dec 12, 2010, 07:25 PM
Cheers
 
105 posts · Jun 2010
I did that and set "Show Blog Title to "Yes", but still no h1 tags around the title. However, the blog title at least doesn't show on the home page. Just need to get those h1 tags around the title in the source code. I even dumped the browser cache.

Last edited by Cheers; Dec 12, 2010 at 07:31 PM.
  #9  
Old Dec 12, 2010, 08:01 PM
juggledad's Avatar
juggledad
 
23,569 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You now have an H! around the blog title. This is from the source of your page
HTML Code:
><h1 class="blogtitle"><a href="https://winekitmaking.com/">Your Wine Kit Making Blog</a></h1>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Dec 13, 2010, 05:08 AM
KatyDigg's Avatar
KatyDigg
 
319 posts · Jul 2009
In order to have <h1> heading on the front page, when the front page is the blog page...

In ATO> Configure SEO > "Make Post/Page Titles H1?" was set to YES.

And so, in addition, I have set to Yes:
ATO > Style & edit HEADER AREA > Show Blog Title? YES
And then inserted the following CSS script:
.blogtitle {display:none !important;}
And, hey presto! Home Page Analysis is
  #11  
Old Dec 13, 2010, 05:32 AM
Cheers
 
105 posts · Jun 2010
Thank you very much to Juggledad and lmilesw. Your assistance is very much appreciated. And, Thanks very much to Berean for a great synopsis to the problem.

Problem solved.

Bookmarks

Tags
h1 tags, seo, title tags

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you suppress/hide title tags in widgets? Wyro Sidebars & Widgets 2 Feb 28, 2010 06:05 PM
BugFix 344 Title tags in Page Menu Bar Henry64 Old Version fixes and change logs 1 Oct 5, 2009 07:39 AM
How to configure title tags for page menu bar? upscho Page & Category Menu Bars 2 Feb 25, 2009 01:26 PM


All times are GMT -6. The time now is 01:38 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.