Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » Forum Usage » Forum How-To »

[SOLVED] Gave my home page the wrong name and now the site isn't working


  #1  
Old Nov 12, 2010, 11:17 PM
kagorges's Avatar
kagorges
 
10 posts · Nov 2009
San Francisco Bay Area
I have wordpress installed in the root directory drkatiegriffin.com. I set my home page to be a static page. But then I stupidly named it welcome. So now instead of wordpress thinking drkatiegriffin.com is the home page it thinks drkatiegriffin.com/welcome is the home page. So if I look at the page source for any of the wordpress pages it refers to all the wordpress stuff as being in drkatiegriffin.com/welcome/..... and of course the stuff isn't in there because it's in the root directory which is where it would have looked if I hadn't named the home page 'welcome' but left it null.

And now I can't get into wp-admin to change it because wp-admin is in the root, but now wordpress is looking for it in drkatiegriffin.com/welcome/wp-admin.....

Is there somewhere I can fix this in the code and then have access to wp-admin again so I can rename it to nothing (null)?
  #2  
Old Nov 12, 2010, 11:35 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Did you change WordPress address (URL) or the site address (URL) in the WordPress general settings? Just renaming the home page to welcome should do nothing on its own.

If you did change those URLs you will have to get into the Options table of the database via your control panel and change those two URLs to what the URL of your site is.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Nov 16, 2010, 03:13 AM
angélica
 
9 posts · Aug 2010
UK
What about wp-config.php

Everything about your install is in that file, including database.

Password is there but scrambled...can always ask for new one once you get the site back.
  #4  
Old Nov 16, 2010, 09:04 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You can't get to the WordPress Address and Site Address setting in wp-config.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Nov 16, 2010, 05:22 PM
kagorges's Avatar
kagorges
 
10 posts · Nov 2009
San Francisco Bay Area
I must have changed the url in the wordpress settings -- because I was working behind an existing html site. Then when I went live, wordpress pointed to the new url.

I fixed it in the sql database options table -- thank you for your help!

Bookmarks

Tags
home page, root directory

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
SEO in home page Not working vipsky Atahualpa 3 Wordpress theme 13 Oct 27, 2010 02:05 PM
Page Title wrong - showing from another site! kippiper Header configuration & styling 8 Feb 16, 2010 08:18 PM
[SOLVED] Comments are directed to a page that isn't there? kevandali Comments, trackbacks & pings 3 Jul 27, 2009 06:06 AM
HELP!! Site isn't running anymore! PrettyChicky Installing & running WordPress 3 Jun 12, 2009 07:01 AM
Front/Home Page (only) not working after domain change prophet224 Atahualpa 3 Wordpress theme 1 May 12, 2009 02:17 PM


All times are GMT -6. The time now is 03:03 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.