Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Excerpts, Read more, Pagination »

Too much space between excerpts


  #1  
Old Apr 5, 2009, 08:47 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
If there is a theme options way to decrease the space between excerpts, I haven't found it.

I would like to cut about half the space you see now:

http://www.larchmontgazette.com/wp27/
  #2  
Old Apr 5, 2009, 04:25 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
That's the overall bottom margin for post containers

div.post {
margin: 0 0 30px 0;
}

Can be set at Atahualpa Theme Options -> Post / Page Styling -> POST Container

It applies to post containers on single post pages and page pages, too. If the sidebars are short on single post pages or page pages, you might want to keep the bottom margin below the post container. You could do this by adding a overall bottom padding to the middle column td#middle { padding-bottom: 30px } or by adding margin-bottom to post containers on single post pages and page pages only, through a CSS insert:

HTML Code:
body.body-page div.post,
body.body-single div.post {
margin-bottom: 30p;
}
  #3  
Old Apr 5, 2009, 04:45 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I'm keeping you busy today, dear Flynn.

OK, I made it 12px, which tightens up the headlines quite nicely. It looks fine in Firefox and Safari. I haven't tested it in MSIE yet.

I think I'll be OK without the other code, since we have ads and other widgets running in all the sidebars. They should keep the post pages long enough.
  #4  
Old May 5, 2009, 06:19 AM
AroundWellington
 
4 posts · May 2009
Atahualpa is an awesome theme! Have a look at what we have done so far at: aroundwellington.net

As soon as I can get with my wife (the owner) about a donation - it will be made.

I am hoping I am in the right area here. I think I am having a problem with post containers too but in the other direction - not enough space between posts. And changing the suggested variables has had no effect.

As you can see on the home page and other multi-post pages (like AW Stories of the Month), the posts are jammed together. We have been physically adding lines into the posts to create spaces between older and newer posts, but that's not a good solution.

Any help will be greatly appreciated.

Last edited by AroundWellington; May 5, 2009 at 06:20 AM. Reason: sp
  #5  
Old May 5, 2009, 07:37 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You should add, at Theme Options -> Post/Page Styling -> Post Container

margin: 0 0 50px 0;

or

margin-bottom: 50px;

If that does not work I'd need to see this in action
  #6  
Old May 5, 2009, 10:33 PM
AroundWellington
 
4 posts · May 2009
Thanks for the response Flynn. I get nothing. I even reduced the number to 0, and raised it as high a 150, and still nothing in either direction.

One thing I didn't mention: Most of the pages that are linked on the left column are static pages with a VERY Spartan individualized template assigned to each that draws the posts from the associated category exclusively. I don't know if my templates may be lacking something that permits the formatting command to work.

What can I post for you to see where the problem lies?
  #7  
Old May 5, 2009, 10:42 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
The URL of the site
  #8  
Old May 5, 2009, 10:51 PM
AroundWellington
 
4 posts · May 2009
aroundwellington.net

Thanks,
JM
  #9  
Old May 5, 2009, 11:15 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I don't see any page with more than one post, only static pages, which all have a single post/page container. You're trying to put space between sections of a single page container.

Looks like you pasted from MS Word which added a whole bunch of unnecessary code. Surprisingly it looks like it didn't mess up the site in IE but I have not looked at every page.

To put space above a headline, i.e. "AROUND WELLINGTON STORIES OF THE MONTH", edit the post and add or modify the top margin in the inline style. Change

<h1 style="margin: 0in 0in 0pt; text-align: justify;">

to i.e.

<h1 style="margin: 80px 0 0 0; text-align: justify;">
  #10  
Old May 6, 2009, 12:57 PM
AroundWellington
 
4 posts · May 2009
Thanks Flynn, that works but I need a more "mindless solution" without having to edit each new post (and re-edit all the old ones).

I'm sure the solution is to add a loop to my templates to convert them from single to multi-post. I am needing to learn more about multi vs single post, and I have found a good discussion about it on the WordPress site. As I dig deeper I know I will come up with more questions.

Thanks again for your help thus far!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excerpts on homepage not working adelante Excerpts, Read more, Pagination 9 Oct 30, 2009 05:52 PM
[SOLVED] Excerpts have huge amounts of space between them. V.3.2 and WP 2.8 hankphone Excerpts, Read more, Pagination 3 Jun 24, 2009 08:40 AM
Excerpts paulharrisjr Atahualpa 3 Wordpress theme 1 Apr 1, 2009 06:57 PM
number of excerpts on homepage luc Excerpts, Read more, Pagination 3 Mar 4, 2009 08:38 AM
Excerpts Issues RuthSmith Excerpts, Read more, Pagination 1 Feb 26, 2009 06:49 PM


All times are GMT -6. The time now is 01:05 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.