Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Problem with Atahualpa 3.5 and Dynamic Content gallery 3.3


  #1  
Old Oct 26, 2010, 12:17 PM
plaw193
 
2 posts · Oct 2010
Hi:

I installed dynamic content gallery in Atahualpa 3.5 and uploaded images to posts as a test. Images are appearing in the posts and in the gallery and that is ok. However all of the images are appearing on each of the pages and that should not be . Can you help with this problem. Thanks in advance
Here's an example of the problem http://www.francis-lauconstruction.com/contact-us/
  #2  
Old Oct 26, 2010, 05:49 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Does it work as expected with the 2010 theme? If so then this is a question for the plugin developers.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Oct 26, 2010, 06:04 PM
plaw193
 
2 posts · Oct 2010
Quote:
Originally Posted by lmilesw
Does it work as expected with the 2010 theme? If so then this is a question for the plugin developers.
Thanks, I'll contact the developers
  #4  
Old Oct 31, 2010, 04:55 PM
Candy
 
9 posts · Oct 2010
I am having this same problem.
The issue seems to stem from Atahualpa.

(I am using atahualpa 3.4.9 and Dynamic content gallery 3.3.2.)

I have a static page set for my home page.
And the page called Blog set to host all of my posts.

When I pop in this code: <?php dynamic_content_gallery(); ?>
in the proper place, the gallery displays perfectly.
However, it displays on the home page AND at the top of the blog page. It also shows the images separated out on each of the pages.

I found this code to put into Atahualpas Enter Center Column section that took away the issue on the other static pages and then the plugin showed up on the Static Home page and the blog page.

Would making a separate home.php file work?

And I had this same thing happen with Featured Content Gallery too.

Yet, I would like to note that Featured Content Gallery works with an older version of atahualpa with no issues.

This seems to me like it's an issue with Atahualpa since I am using the same versions of Dynamic Content Gallery in the past. I just don't know what's changed.

Does anyone have any insight?

Or can you suggest another plugin that would do the same thing? I would like the rotating plugin to only appear on the home page (static).

Thanks!
  #5  
Old Oct 31, 2010, 06:15 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
When I pop in this code: <?php dynamic_content_gallery(); ?>
in the proper place, the gallery displays perfectly.
However, it displays on the home page AND at the top of the blog page. It also shows the images separated out on each of the pages.
and just where might it be that you 'pop in this code'?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Oct 31, 2010, 06:24 PM
Candy
 
9 posts · Oct 2010
Into index.php underneath get_header(); ?>

I think you said on an earlier thread to put it directly into index.php and not into the Center Content section under Atahualpa Theme Options. Or maybe it was just a thread I read where you responded.

On the other sites I have running WP + Atahualpa + FCG/DCG I have the code in the same spot in index.php.
  #7  
Old Oct 31, 2010, 06:47 PM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
well wrap a php if around it and test for the front page 'if ( is_front() ) .....'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Oct 31, 2010, 08:39 PM
Candy
 
9 posts · Oct 2010
OK,
I added this:

Code:
<?php if( is_home() ) 
  { ?>

    <?php dynamic_content_gallery();
  }
?>
Underneath:
Code:
get_header(); ?>
in the index.php file

And now, the DCG is showing up on the Blog page, not the home page. Here is link to the site: http://173.83.156.13/


At least it's not showing up in both places, although I DO want it to show up on the home page.

I feel like I'm close--do you see what I need to do at this point?
Or why it isn't showing up on the home page?
  #9  
Old Oct 31, 2010, 10:07 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I have always put the code for that in ATO>Style & edit Center Column>Content Above the Loop to avoid editing theme files and it worked for me. I also used the conditional to limit to the front page as well. If you are using a static front page you will probably have to use
is_page('99') instead of is_home() where 99 is the page id of the static page.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #10  
Old Nov 1, 2010, 03:45 AM
juggledad's Avatar
juggledad
 
23,672 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Note I sad to use 'is_front()' and you used 'is_home()'? the HOME page is the blog page no matter where it is, the FRONT page is the landing page (page you see when you type 'yourdomain.com').

if the blog page si teh landing page then it is both the HOME and FRONT page.

confusing no? This is a WordPress definition.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Nov 1, 2010, 07:58 AM
Candy
 
9 posts · Oct 2010
OK- Juggledad, I changed home to front like the below:

Code:
<?php if( is_front() ) 
  { ?>

    <?php dynamic_content_gallery();
  }
?>
And then this error popped up right below the DCG:


Code:
Fatal error: Call to undefined function is_front() in /hsphere/local/home/c307655/dulcedesignscandy.com/wp-content/themes/atahualpa/functions.php(507) : eval()'d code on line 1
So I switched it to what lmilesw suggested. The page ID of the home page is 4 and I moved the code into the 'enter center column' like this:

Code:
<?php if( is_page('4') ) 
  { ?>

    <?php dynamic_content_gallery();
  }
?>
It's still showing up on the home page AND the blog page. How can I exclude the blog page?

Thank you both. I am thoroughly confused.
  #12  
Old Nov 1, 2010, 08:45 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Did you try putting the code in the Content Above the Loop box in the theme options?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #13  
Old Nov 1, 2010, 08:51 AM
Candy
 
9 posts · Oct 2010
lmilesw-- yes, that is where it is right now.
  #14  
Old Nov 1, 2010, 09:10 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Try this code. As I looked at what you had there was some code missing at the end.
PHP Code:
<?php if( is_page('4') ) { ?> 
<?php dynamic_content_gallery(); ?>
<?php 
?>
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #15  
Old Nov 1, 2010, 09:34 AM
Candy
 
9 posts · Oct 2010
Quote:
Originally Posted by lmilesw
Try this code. As I looked at what you had there was some code missing at the end.
PHP Code:
<?php if( is_page('4') ) { ?> 
<?php dynamic_content_gallery(); ?>
<?php 
?>
I just swapped what I had with what you provided (thank you!) and there is no difference.

Can I exclude the blog page somehow? (blog ID = 8)

And I double checked all my settings-- home page is a static page called home (id = 4). Posts page is blog page (id = 8)

I just don't understand why it is showing up on the Home and the Blog page, but not any of the other pages.

I also keep finding threads on several websites with this same problem, but none of them are solved--it seems like if I can just exclude the page, then wouldn't that take care of the page? I just don't know how to write that in.

This is everything I have in the Content Above The Loop Sectionbottom two things I did not add)
Code:
<?php if( is_page('4') ) { ?> 
<?php dynamic_content_gallery(); ?>
<?php } ?>


<?php /* For MULTI post pages if activated at ATO -> Next/Previous Navigation: */
bfa_next_previous_page_links('Top'); ?>

<?php /* For the plugin Page2Cat http://wordpress.org/extend/plugins/page2cat/ */
if( is_category() AND function_exists('page2cat_output')) { page2cat_output($cat); } ?>
  #16  
Old Nov 1, 2010, 10:18 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Just to un-confuse things a bit. Am I correct in assuming you only want this to show on the home page? If so have you tried just putting
PHP Code:
<?php dynamic_content_gallery(); ?>
in the Content above the loop box and setting the DCG setting to only show on that page? Also you might have to set the Javascript Options for DCG to JQuery instead of Mootools which is the default.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #17  
Old Nov 1, 2010, 10:44 AM
Candy
 
9 posts · Oct 2010
Ok, this appears to be working, aside from one small item.

Just to write it out, here's what I did:

I left this in the content above the loop section:
Code:
<?php if( is_page('4') ) { ?> 
<?php dynamic_content_gallery(); ?>
<?php } ?>
In DCG, I disabled mootools and set it to appear only on one page by ID (in my case, the ID = 4)

When I only had this:
Code:
<?php dynamic_content_gallery(); ?>
In the Content Above The Loop section, we still had issues with the slideshow showing up all over the place.

I noticed that the name of the carousel (default is Featured Article...I changed it to Spotlight) was showing up on the Blog page still. See attached Screen Shot.

I unchecked Display Carousel in DCG and left the word Spotlight in the label field.

It still showed up.

I completely deleted Spotlight (while leaving it unchecked)

And it went away.

Is this really fixed? No idea, but that is where I am.

You may mark this as solved, and thank you for your help.

I am still wondering though, is there a way to exclude a certain page by ID in PHP, just like how this:
Code:
<?php if( is_page('4') ) { ?>
Calls a particular page?
Attached Thumbnails
Click image for larger version

Name:	Picture 2.png
Views:	486
Size:	44.9 KB
ID:	866  
  #18  
Old Nov 1, 2010, 11:44 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
This should work to show on all but a static home page with an ID of 4
Code:
<?php if( is_page('4') ) { ?> 
<?php } else { ?>
<?php dynamic_content_gallery(); ?>
<?php } ?>
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Add columns in footer with widgets/dynamic content marced Post-Kicker, -Byline & -Footer 1 Sep 7, 2010 10:31 PM
[SOLVED] Dynamic Content Gallery koinonos Plugins & Atahualpa 7 Aug 18, 2010 04:35 PM
Dynamic Content Gallery + Atahualpa 3.5.1 + Wordpress 3.0 DOESN't Work sweeper240 Plugins & Atahualpa 3 Jul 5, 2010 04:02 PM
[SOLVED] Gallery breaking problem with NextGEN and Atahualpa acabtp Plugins & Atahualpa 3 Jul 9, 2009 07:06 PM


All times are GMT -6. The time now is 11:18 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.