Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

[SOLVED] Page tab height issue: page link tabs higher than page menu bar


  #1  
Old Jun 11, 2009, 11:45 PM
Fux
 
142 posts · Apr 2009
Hey,

the image says more than a million words:



Why does this ("ledge") happen? I did only change the colors, nothing else. It also happens on the top level, which makes the page menu bar appear "broken" on the right of the last link. I fixed that by using a "%bar" in the header with a solid line of the same color as the page menu bar - but that's a quite dirty workaround. Is there no other way to fix this?

Also, "capitalize" does not seem to work for the page menu links, at least not with Arial and Tahoma.

Cheers,
Felix
  #2  
Old Jun 12, 2009, 04:23 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What version of WP and Atahualpa are you on? Please post the url
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jun 12, 2009, 05:27 AM
Fux
 
142 posts · Apr 2009
WP 2.7, Atahualpa 3.3.3. I've already reworked that site, but it also happens here: http://s275144270.online.de/jt/ - I turned off the "%bar2" which I use to fix the problem. Right on top of the page menu is "%bar1" which fixes the issue - on the bottom line next to "Kontakt" you can see what I'm talking about.
I'll have to change the site back in ~24hrs, so I hope you can take a look in the meantime.
  #4  
Old Jun 12, 2009, 06:49 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Try this, add the following to ATO->HTML/CSS Inserts->CSS Inserts:
HTML Code:
ul.rMenu-hor li
	{
	margin-bottom: 0px;
	}
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jun 12, 2009, 12:31 PM
Fux
 
142 posts · Apr 2009
Thanks, but: No, tha doesn't fix it. I wonder whether I'm the only one who encountered this.
  #6  
Old Jun 13, 2009, 02:37 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Hmmm that's strange. I copied the geenrated source of your page and changing that did the trick...Ah HA!.. I just looked at your page source again, you made a typo and left off the 'u' at the begining. You have
HTML Code:
l.rMenu-hor li {
margin-bottom: 0px;
}
when it should be
HTML Code:
ul.rMenu-hor li {
margin-bottom: 0px;
}
Darn typo's....
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jun 15, 2009, 11:54 AM
Fux
 
142 posts · Apr 2009
Yepp, that's it. Thank you yo much.
But do you know why this happens at all? And would this fix every occurence of it in the pages menu bar (i.e. the sub-menu items)
  #8  
Old Jun 15, 2009, 01:30 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The original setting is as follows and there is the explaination:

margin-bottom: -1px; /* this is so if we apply a bottom border to the UL element it will render behind, but inline with the bottom border of the LI elements. Default: -1px */
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Oct 27, 2010, 12:21 PM
esvl
 
16 posts · Sep 2010
France
Damned
I have the same pb with a brand new installed WP 3.0.1 and Atahualpa 3.5.3 (both on last Firefox version on MacOS & Windows).
Any hint? Thanks!

Here:
http://www.urlgone.com/603a96/
  #10  
Old Oct 27, 2010, 03:33 PM
esvl
 
16 posts · Sep 2010
France
This :
ul.rMenu-hor li {margin-bottom: 0px; }
is already in Atahualpa 3.5.3

I tried with
ul.rMenu-hor li {margin-bottom: -1px; }
which make thinks aligned for one menu, and not the other one.

I am surprised the point was not reported before? wasn't it?
  #11  
Old Oct 28, 2010, 05:00 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
esvl - what you are seeing is an offset of the light and dark grey of the menu vrs the light and dark gray lines that make up the background image for the page (ato->Body, Text & Links->Body Style)

You are using the sample style (it's loaded as a default) that demonstrates some of the styling you can do with Atahualpa. There are several in the 'styles' subfolder - but to use them you must have them loaded on your local computer (down load a copy of the theme to your local machine)

go rename the background image (put an 'x' in the name) and you will see the page without the background image.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Oct 29, 2010, 11:14 AM
esvl
 
16 posts · Sep 2010
France
Thank you!
I didn't have seen the style folder. I have tried the other ones, and ata-classic looks to be a quite good point to start with.
I have a little problem however... with the style, I lose the 2nd menu. Do you see why?
When I come back to the previous style (ata-default), I get it back (with the previous mentioned pixel pb).
The 2 menus are correctly set...

http://www.urlgone.com/603a96/
  #13  
Old Oct 29, 2010, 12:47 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
if you want both the page and category menus, make sure you have %pages and %cats in ato->Style & edit HEADER AREA->Configure Header Area
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Oct 30, 2010, 03:42 AM
esvl
 
16 posts · Sep 2010
France
I've got it! Thanks juggledad!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get a category link into the Page Menu Bar? billzarchy@gmail.com Page & Category Menu Bars 1 Jun 8, 2009 01:18 PM
how to put external link in page menu bar deltatango Page & Category Menu Bars 2 Jun 7, 2009 12:29 AM
Configuring a Page Navigation Tab Link OneSister Page & Category Menu Bars 2 Apr 16, 2009 01:42 PM
How do I add an icon to a page menu link in page menu bar? bcorrigan Page & Category Menu Bars 9 Apr 6, 2009 02:35 PM
Page Menu Bar Issue with IE7 jyoung Page & Category Menu Bars 1 Mar 12, 2009 02:57 AM


All times are GMT -6. The time now is 03:57 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.