Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] How to change theme to use all included files only by https?

Old Mar 7, 2013, 12:50 AM
6 posts · Jun 2010
I have a membership website with Atahualpa and aMember v4. The new version of aMember has a great option where it frames the user signup page within the Wordpress theme, so there is consistency for the user in terms of logo, menu bar, footer, etc.

However, when I choose this option, I can only get a partially encrypted page, which will scare off potential customers that don't see the lock icon. I asked tech support at aMember about this and they said to: change your wordpress theme so it uses all included files (css,js,images) only by https.

I have confirmed that my logo image is being pulled via https as the lock icon appears if I go directly to the logo location. But other elements of the Atahualpa header or footer are not using all included files only by https.

How can I change this so that Atahualpa is offering up all https elements in the header and footer?

I am not sure if this can be done, but I am happy to make donation to anyone that can provide a solution that I can implement easily.


Last edited by goldstockbull; Mar 7, 2013 at 12:56 AM.
Old Mar 7, 2013, 04:48 AM
juggledad's Avatar
23,762 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what version of Atahualpa are you on?
as of 3.7.10 Atahualpa supports HTTPS
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
Old Mar 7, 2013, 10:39 AM
6 posts · Jun 2010
Hi Jugglehead,

I am using 3.7.10 and the header/footer are still not allowing for full encrypted HTTPS. Any thoughts on how to make sure the theme pulls only secure elements?

Old Mar 7, 2013, 03:00 PM
6 posts · Jun 2010
This has been solved. In case anyone else has the same issue, here is what I did...

Go to Wordpress > General Settings > Worpress Address (URL) and Site Address (URL)

Change these URLs from http to https

Also, I had statcounter plugin enabled which was in the footer of every page and not pulling using https. I edited the plugin file to change all http to https.

Atahualpa/Wordpress is now serving all secure files to my header and footer and I get a full encrypted page with the lock icon in my browser windows.


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
https with multisite fox-didl Multisite 1 Jul 14, 2012 09:30 AM
Upgrade theme when non-theme files are in existing theme folder ewlong New Versions, & Updating 7 Sep 27, 2011 12:53 AM
Thoughts on editing theme files lmilesw Atahualpa 3 Wordpress theme 0 Jun 2, 2010 07:16 AM

All times are GMT -6. The time now is 01:07 AM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.