Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Big Trouble getting "Admin Links Widget" to work


  #1  
Old Apr 9, 2009, 07:20 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Big Trouble getting "Admin Links Widget" to work

I'm posting here because this "widget" installs as plugin and then "appears" as a sidebar widget.

I installed and activated the "Admin Links Widget" http://wordpress.org/extend/plugins/...idebar-widget/

Simply, I can't get the widget to appear in either sidebar at all, ever. I contacted the author http://kdmurray.net/2007/08/14/wordp...-links-widget/ who suggested there might be some interaction happening with other widgets I was running.

I removed ALL widgets from BOTH sidebars except for "Admin Links" without any joy. And then I started deactivating plugins.

I disabled:
cforms
Inline Posts
WP Shopping Cart
CMS Navigation

The still active plugins are:
Akismet
All in One SEO Pack
Page Management Dropdown
Plugin Central
WP-DBManager
WP-PageNavi
WP Super Cache

I'm at my wits end. I "know" the widget is "there" -- if you go to http://www.shepherdjim.com/ you can see that the left sidebar is empty -- NOT showing the "To put some content here, ..." notice you see in the unpopulated right sidebar. If I remove the widget from the left sidebar, the "To put some content here, ..." then appear there as well.

WP is installed in a subdir /wp/ and I have things set up so you don't need to enter /wp/ as part of the URL. Could that have anything to do with the problem?

EDIT / Update: I just realized that I'm not running the latest version of theme Atahualpa on www.shepherdjim.com so quickly installed the newest 3.3.2 -- there's no change. This plugin/widget still refuses to show itself. ???

Has anyone had experience with this plugin? Keith Murray, the author, has gone to the trouble of installing Atahualpa and reports he's not having any problems.

Last edited by Shepherd Jim; Apr 9, 2009 at 09:47 AM. Reason: update info re theme version (see bold red)
  #2  
Old Apr 9, 2009, 07:42 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Can you turn on the "Default" theme for a moment to see if this caused by Atahualpa? You should remove the widget from Atahualpa's sidebar first to make sure Atahualpa doesn't hold the widget hostage.
  #3  
Old Apr 10, 2009, 06:28 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Well. I installed the widget. Sounds like a great idea. It shows up in the sidebar, but nothing happens when I click on a link. It's because the links are not pointing to where the admin is; the widget thinks admin is in the root, but it's in /wp27/. Clicking on a link makes the front page, root/index.php, load instead, even if I was on another post when I clicked.

I will try to edit the plugin code and report back.

REPORTING IN, SIR:

OK, it's simple. Sounds like you have the same setup I do. I used the plugin editor to change
Code:
if (is_page() && $show_editthispage) {
			  echo '<li><a href="'.$blog_url.'/wp-admin/page.php?action=edit&post=';
			  the_id();
			  echo '">Edit This Page</a>';
to
Code:
if (is_page() && $show_editthispage) {
			  echo '<li><a href="'.$blog_url.'/wp27/wp-admin/page.php?action=edit&post=';
			  the_id();
			  echo '">Edit This Page</a>';
Several instances of that, for each option. It really works! Now I just have to logout and come back as non-admin and make sure it's not showing.

Flynn, could there be a security concern with this plugin?

Last edited by paulae; Apr 10, 2009 at 06:42 AM. Reason: found solution
  #4  
Old Apr 10, 2009, 07:54 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Hello Flynn & Paula!

I've now tried everything that the BOTH of you have suggested and still am unable to even make this widget appear in either sidebar, functioning or not.

Paula, I went to Keith Murray's (author of the "Links Admin Widget"/plugin) website and commented in with what you'd discovered about the plugin apparently assuming that WP must be installed in the root. Hopefully he can work a fix into the code that will preclude us having to go in and mess around.

The fact that I have never even been able to make this widget appear on either of my sites is worrying. Besides the "not installed in the root" problem that Paula has uncovered, I'm guessing something about the redirection I have set up so as to not show the "/wp/" AND do show the "www" in the browser's URL window may be creating trouble.

While better minds than mine mull this all over I am going to retire to the sidelines and finish updating the Atahualpa version I'm running on www.ShepherdJim.com.
  #5  
Old Apr 10, 2009, 03:59 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Well, I have www showing in the settings, and I have the WP files in /wp27/ and index.php in the root, and all is well now. Make sure your ISP people check that your .htaccess file is set up right. I'd deactivate and fully delete the plugin and make sure it left no artifacts in the plugins root, then try it again from scratch.
  #6  
Old Apr 11, 2009, 07:54 PM
MrGibbage
 
2 posts · Apr 2009
I also just installed this widget, and WP 2.7.1, and cannot see the Admin Links widget in the sidebar under any circumstances. I tried the default theme and a couple of others, no joy. Standing by to help in any way I can.

Skip

Bookmarks

Tags
admin links, keith murray, widget

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] change header image to link to external page when clicked bilwebore Header configuration & styling 9 Sep 23, 2009 04:06 PM
request: please add "links.php" page template. dhani Atahualpa 3 Wordpress theme 0 May 22, 2009 03:36 AM
Having trouble with the "now reading" plugin displaying pictures... widget CSS jmesax Sidebars & Widgets 3 Mar 28, 2009 11:44 PM
[SOLVED] How should top level &quot;button&quot; work on a menu bar? Shepherd Jim Page & Category Menu Bars 2 Mar 14, 2009 02:30 PM
"Remove 2nd footer link to BFA" doesn't work Flynn Atahualpa 3 Wordpress theme 0 Dec 13, 2008 04:47 PM


All times are GMT -6. The time now is 11:31 AM.


Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.