Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Anyway to make this theme load faster?


  #1  
Old Sep 19, 2009, 04:10 PM
johnd28
 
29 posts · Sep 2009
Hi,

I have a wordpress CMS site running on this theme that is loading kind of slowly.

When I look at the code of the pages generated, it seems there's a lot of code at the top before the actual content. Is all this code necessary? Doesn't it slow down the site?

Another question is how to make the center container load before the left sidebar. This will allow the readers to start reading while both sidebars load.

How can this be done?

Thanks, John
p.s. any other tips to make the site load faster will be appreciated.
  #2  
Old Sep 20, 2009, 06:22 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
See Theme Options -> Configure CSS & JS to make these files external

Use Wp Super Cache or WP Cache 2 as plugin, make sure you run a PHP cache like XCache, have mod_deflate (Apache 2) or mod_gzip (Apache 1) or Gzip (other webservers) enabled by the web host. The performance of the web server (hardware and software) and MySQL server can have a much greater impact than optimizations on the theme.

The center column content cannot be loaded before the left sidebar in this type of layout. This is the price for the better stability of this layout compared to "source ordered" DIV only, floated layouts. You'd have to put both sidebars on the right sidebars if you're concerned about the source order.

Combining all plugin CSS files into one CSS file and all plugin JS files into one JS would also help. PHP Speedy is supposed to do that. http://www.turleando.com.ar/autoptimize/ might be better according to http://andybeard.eu/2065/wordpress-comment-seo.html
  #3  
Old Sep 26, 2009, 08:29 PM
sharialexander
 
5 posts · Sep 2009
Sorry to bug you on this, but I've been searching the forum and haven't been able to solve this for myself.

My blog (www.presentingmatters.com/blog) is still running very slow. I have made the CSS and JS an external file.

I'm confused about the advice about gzip. Is that a plug-in or do I call my host to make that adjustment?

Any advice is greatly appreciated!!!! Thanks bunches!
  #4  
Old Sep 27, 2009, 04:10 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Gzip or mod_deflate is something the host would have to set or install
  #5  
Old Sep 27, 2009, 01:57 PM
johnd28
 
29 posts · Sep 2009
Hi Flynn,

Thank you for your suggestions, I will talk with my hosting company which is godaddy.

However, I have tried t turn CSS and JS files to external with horrible results. The blog just lost its shape. I am using supercache but the blog is still loading super slowly.

In IE it is even worse than Firefox and I am losing visitors. I don't know why IE behaves much worse, but it's close to impossible to go from one page to the next.

My blog is a CMS at http://www.WorldofDiets.com

Do you have any idea on how to make it fly?

Thanks
John

Last edited by johnd28; Sep 27, 2009 at 10:23 PM.
  #6  
Old Sep 27, 2009, 02:45 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
are you on a shared server or a dedicated one? That can make a big difference.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Sep 27, 2009, 10:34 PM
bushtool's Avatar
bushtool
 
93 posts · May 2009
Your site is very fast on both IE and firefox for me. About 2 seconds page
  #8  
Old Sep 27, 2009, 10:38 PM
bushtool's Avatar
bushtool
 
93 posts · May 2009
According to pingdom, this twitter button is causing a slowdown

http://www.worldofdiets.com/%3C?phpb...buttons-06.png
  #9  
Old Sep 27, 2009, 10:52 PM
johnd28
 
29 posts · Sep 2009
Hi,

thank you for all your suggestions.

I removed the widget with the twitter button. However, it only appeared on the home page and the other pages were just as slow.

I'm surprised to read that for some of you the site loaded fast. It's super slow here and from other PCs I tried.

I will try to install the xcache plugin.

When I moved the CSS and JS files to external, the site lost its design. Any ideas on that?

I am running PHP widgets in the sidebars to run the navigation links, should I remove them to make the site run faster?

I will talk with the hosting company and see if they have any ideas.

I believe I'm on a shared hosting server at godaddy, but at 500-1000 visitors a day or so, I doubt if a dedicated server is merited, do you? Are any of you experiencing similar problems with godaddy? Godaddy also offers what they call virtual dedicated servers. Is that a worthwhile option?

Any more ideas on how to run the site faster would be great. Thank you guys so much for your advice?
  #10  
Old Sep 28, 2009, 03:37 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what version of Atahualpa, WP and PHP/?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Sep 28, 2009, 06:09 AM
johnd28
 
29 posts · Sep 2009
Hi,

I'm using WP 2.8.4

Atahualpa 3.4.2

PHP 4.3.11
  #12  
Old Sep 28, 2009, 07:23 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
First thiing I would do is upgrade to php5 - I think there is a setting you can add to the .htaccess file to do this - search the godaddy FAQ for directions. php4 will cause some problems
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #13  
Old Sep 28, 2009, 02:46 PM
Gravity's Avatar
Gravity
 
34 posts · Sep 2009
I am using W3 Total Cache and it has features to minify and compress code, plus page caching. I have no compatibility problems with Atahualpa (nor a bunch of other plugins I use) and find it an excellent way to provide Digg-protection plus speed.

The help file for Total Cache linked me to this superb free analysis tool, too, which identifies where the slowdowns might be.

Last edited by Gravity; Sep 28, 2009 at 02:49 PM.
  #14  
Old Sep 28, 2009, 03:22 PM
johnd28
 
29 posts · Sep 2009
Hi,

I changed the PHP version. It is now 5.2.5. The blog is still very slow. SOme of the pages take 5-6 seconds to load.

Is this W3 Total Cache any better than Super-cache. I also ran the diagnostic tool you suggested but can't figure out what it's saying or what can be done about the results.

As to Xcache, I'm not too techy, so I will probably have to hire someone to do this for me.

I am beginning to believe that this theme is just slower than others. Are you guys running fat loading blogs with it?
  #15  
Old Sep 28, 2009, 03:33 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I'm now seeing 1-3 second load times - how much faster do you want it? (that was a retorical question )
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #16  
Old Sep 28, 2009, 03:34 PM
johnd28
 
29 posts · Sep 2009
That's strange. I'm getting 5-8 seconds
  #17  
Old Sep 28, 2009, 03:43 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
remember there are a ton of variables that will determine the time it takes for you to see the page.
- how fast is your computer?
- how many processes are running on it
- are you running hard wired or wireless
- - if wireless
- - - how fast is the wireless
- - - much interference is there on the channel you chose
- how fast is your connection to your isp
- how many hops is it from you to the computer the site is hosted on
- what kind of actrivity is going on at each machine along the way
- what the machine activity where your site is hosted
- if grabbing things from other sites (ad's feeds etc) how many hops to the source, speed on machines etc etc

if you have two computers at the same location but one is a 256meg 1.5 GZ machine running 100 processes, and the other is a 4gig 3Gz machine with basically nothing running, do you thiink the page loads will be the same?

tons of variables...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #18  
Old Sep 30, 2009, 08:42 PM
sharialexander
 
5 posts · Sep 2009
Okay, so...I did the external CSS and JS files. I had my host do the gzip-dmoz-thingy for Apache. My blog (www.presentingmatters.com/blog) is still running very slow. Could someone take a look at it and tell me if I'm completely missing something? Sorry I'm not the most technically-minded person, but I'm really hoping to solve this problem. Thank you to all of you who have helped. I really appreciate it!
  #19  
Old Oct 1, 2009, 06:05 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Hi there. I just went to your site, and it did take a long time. You don't have the timer enabled (you can do that in the footer settings, to show the load time at the bottom of the page), but I'd say it took 7 or 8 seconds, at least, in Firefox on a fast cable connection at 8am.

One thing I noticed while watching the lower left corner of the browser as the page was loading: It seemed to hang for the longest time on Apture. I looked at your source code, and that appears to be the video embedded object. Have you tried the page without that in there?

That said, I also think the theme takes too long to load, compared to other themes I've tried.
  #20  
Old Oct 1, 2009, 07:19 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
one of the problems is that this image does not exist
HTML Code:
http://presentingmatters.com/blog/wp-content/themes/atahualpa342/images/inputbackgr.gif
and a lot of time is spent looking for it.

Also your 'body' background has this
HTML Code:
background:url(presentingmatters.com/blog/wp-content/themes/atahualpa342/images/inputbackgr-red.gif) repeat top left
change it to
HTML Code:
background:url(http://presentingmatters.com/blog/wp-content/themes/atahualpa342/images/inputbackgr-red.gif) repeat top left
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #21  
Old Oct 5, 2009, 09:48 AM
sharialexander
 
5 posts · Sep 2009
Okie-dokie...I made the image adjustments that Juggledad suggested and added the timer paulae suggested into the source code. It says it takes about 7 seconds. Now, I hope I'm not crazy in wanting it to be closer to 2 or 3 seconds. Is there something I'm missing? I go to other sites with this theme and it doesn't take that long.

I REALLY appreciate all your help! Hoping to get this solved. Thanks!
  #22  
Old Oct 5, 2009, 10:12 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
According to your source code, you have a favicon, but I don't see one. The HTML is looking for one, and maybe that's causing some delay in initial loading of the page.
HTML Code:
<link rel="shortcut icon" href="http://presentingmatters.com/blog/wp-content/themes/atahualpa342/images/favicon/PMfavicon.ico" />
Another thing I noticed is this:
HTML Code:
<div id="imagecontainer" class="header-image-container" style="background: url('http://presentingmatters.com/blog/wp-content/themes/atahualpa342/images/header/[color="Red"]Adjusted Wordpress Banner.jpg[/color]') top center no-repeat;"><div class="opacityleft">&nbsp;</div><div class="opacityright">&nbsp;</div></div>
		</td>
Browsers and Unix don't like Mac-style file names with spaces in them. I don't know if that causes any problems here or not, but I just noticed it.
  #23  
Old Oct 5, 2009, 12:00 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
sharialexander
your background gif is still formed wrong and you loose 3 seconds for it not to be found. Fix it!
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #24  
Old Oct 5, 2009, 12:34 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
BTY for anyone interested. I did a little test of a new site I'm working on - very basic - using Firebug and looking at the entire load time. I flushed the local cache each time - the times are in seconds.

1) CSS External/Java External - 2.82
2) CSS External/Java Internal - 2.45
3) CSS Internal/Java External - 2.29
4) CSS Internal/Java Internal - 1.64

so it added a lottle over a second if the CSS and Java was external. - food for thought
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #25  
Old Oct 5, 2009, 01:45 PM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Interesting. I thought having CSS and JS external was supposed to make the site load faster, not slower!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atahualpa SLOW to load! rackphoto Atahualpa 3 Wordpress theme 6 Feb 27, 2012 03:12 AM
Image too small at 770 px for Atahualpa theme - any way to make it stretch to 100%? houston777 Header configuration & styling 1 Jul 5, 2009 04:25 PM
Inserting Flash into Header - Will not Load gotogirl1113 Header configuration & styling 3 Jun 23, 2009 07:51 PM
[SOLVED] Atahualpa load time! wrastler Atahualpa 3 Wordpress theme 21 Jun 9, 2009 08:11 AM
Avatar load times and XHTML under leave a reply Artists Garden Atahualpa 3 Wordpress theme 2 Jan 18, 2009 08:24 AM


All times are GMT -6. The time now is 08:54 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.