Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating » Old Version fixes and change logs »

Atahualpa 3.5.2 released, WP3 ready


  #1  
Old Jul 19, 2010, 03:52 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Atahualpa 3.5.2 released, WP3 ready

See http://wordpress.bytesforall.com/?p=93

  • With the new WP3 menu system
  • Export/Import system now uses the JSON format instead of the serialized/base64_encode format used in 3.5.1
  • The reason for the change is that Wordpress.org won't list the base64_ version due to the malicious things often done with base64. Sorry I should have thought about that. base64 encoding the settings files seemed to be a quick fix for the issues many users had with the settings files.
  • Unfortunately this means that if you exported a settings file in 3.5.1 and want to import that in 3.5.2, you'd need to do some legwork: Download this zip file, extract it, rename the "uploadBASE64.php" to "upload.php" and replace the existing "upload.php" in Atahualpa 3.5.2 with it.
  • If you don't have old settings files that you want to import then you don't need to do the steps described above
This release was mainly about the new WP3 menu system and the change of the settings file format. I will add the bug fixes that Juggledad posted, in the next release

Last edited by juggledad; Jul 19, 2010 at 07:48 PM.
  #2  
Old Jul 19, 2010, 04:39 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
This is GREAT. Thanks Flynn
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Jul 19, 2010, 06:03 PM
Sonja
 
3 posts · Jul 2010
S.F. bay area
Thanks for the WP3.0 menu upgrade.

Does that mean that bugfixes 351-01 thru 351-06 (http://forum.bytesforall.com/showthread.php?t=7973) are not in 3.5.2, but will be in 3.5.3 ?
  #4  
Old Jul 19, 2010, 06:10 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
That's correct Sonja although if you use the WP menu you don't need the sub menu bug fix.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Jul 19, 2010, 09:52 PM
Kesava
 
21 posts · Jun 2010
As I am happy using the custom menu widgets and don't need the 3.0 menu feature, is there any point in me upgrading? I'm running 3.4.9 at the moment and have no problems.
  #6  
Old Jul 19, 2010, 09:56 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
If you aren't anxious for the WP menu integration you can certainly wait until all the bug fixes are in place before upgrading Kesava.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Jul 20, 2010, 02:25 AM
perplex
 
6 posts · Jul 2010
Very cool!

Thanx!
  #8  
Old Jul 20, 2010, 10:58 AM
Kazna
 
13 posts · Jan 2010
The new version is great, thanks for all the efforts. But there's one thing i thought you've missed , that the bug where hyphens, commas,.. not displayed is still there although we had the fix here http://forum.bytesforall.com/showthread.php?t=8037 :D
  #9  
Old Jul 25, 2010, 04:36 AM
karas
 
1 posts · Jul 2010
Thank you! I actually registered this morning just to find the answer to this question. Worked great
  #10  
Old Jul 31, 2010, 05:17 AM
kjetil
 
45 posts · Jul 2009
Oslo - Norway
Send a message via Skype™ to kjetil
Quote:
Unfortunately this means that if you exported a settings file in 3.5.1 and want to import that in 3.5.2, you'd need to do some legwork: Download this zip file, extract it, rename the "uploadBASE64.php" to "upload.php" and replace the existing "upload.php" in Atahualpa 3.5.2 with it.
I still have a couple of sites on ata 3.4.6 (and WP291) that I'd like to upgrade to ata 353.
1) Would I have to go through this legwork to avoid problems/ loosing settings? Is it necessary to export/import the settings not to loos them? (I have a lot of extra css etc - could I eventually just copy/paste that code to be safe?)
2) Would I also have to go via ata 3.5.2 (the first version where the export/import was mentioned, I believe) to avoid loosing settings?
3) Finally, should I wait upgrading to 3.5 before I've upgraded the sites to WP 3.0? (Difficult anyway because not all plugins are updated, but that's an other story)
Thanks - again
__________________
Kjetil
- Dolcevita.no
  #11  
Old Jul 31, 2010, 06:25 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Quote:
Originally Posted by kjetil
1) Would I have to go through this legwork to avoid problems/ losing settings? Is it necessary to export/import the settings not to lose them? (I have a lot of extra css etc - could I eventually just copy/paste that code to be safe?)
2) Would I also have to go via ata 3.5.2 (the first version where the export/import was mentioned, I believe) to avoid loosing settings?
3) Finally, should I wait upgrading to 3.5 before I've upgraded the sites to WP 3.0? (Difficult anyway because not all plugins are updated, but that's an other story)
Thanks - again
  1. That legwork is only if you exported from 3.5.1 and want to import to 3.5.2 or 3.5.3. If you do a manual upgrade your settings should be transferred.
  2. You don't have to go to 3.5.2 first
  3. Whether you upgrade WordPress or Atahuapa first is not important.
Most importantly you should do a MANUAL upgrade meaning DON'T use the automatic upgrade feature of WordPress. Just upload the 3.5.3 folder via FTP to your WP themes folder. Then activate it and see what happens. If you have issues just reactivate 3.4.6 and tell us what the issue is. You will need to copy the image files you uploaded for 3.4.6 into the corresponding folders for 3.5.3 and change image paths in the ATO but that doesn't take very long.

If you still are uncertain about anything concerning the procedure please ask before doing the upgrade.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #12  
Old Jul 31, 2010, 01:17 PM
kjetil
 
45 posts · Jul 2009
Oslo - Norway
Send a message via Skype™ to kjetil
Great - thanks Miles(?) - just as I hoped it should be!
Thanks also for pointing out the transfer of the image folder - to keep header images, our logo and favicon. Easy to forget.
I always do upgrades manually. Its safer.

The only real legwork then will be the remaking of our templates. We use different templates for different categories (to make each of them individually postable), and since the index.php file (which all the templates are based on) is changed now (between 251 and 252 I believe), we can't just transfer all those old templates to the atahualpa253 folder.
I just mention this in case it can be useful for others )

Ready for upgrades! (as soon as we've tested all our plugins on WP3)
__________________
Kjetil
- Dolcevita.no

Last edited by kjetil; Jul 31, 2010 at 01:19 PM.
  #13  
Old Nov 8, 2010, 03:32 PM
kjetil
 
45 posts · Jul 2009
Oslo - Norway
Send a message via Skype™ to kjetil
In short: I'm stuck
(And: Your might need to rewind a bit - I'm late with our final upgrade.)
Now, after upgrading three other sites (all from WP291 to 301 and At 246 to 353) without problems, our main site is just chaos. Basically it looks like no CSS is working.
My main question is if there might be any other steps I must do to make this work.
I've done all the upgrades manually (yes, I follow a detailed list). In addition to the normal upload'n activate stuff I've
- copied over all needed images (for headers, favicon) and
- I've rebuilt new templates. This was easy because I've used identical templates on this site. (The /cucina part of dolcevita.no has its own WP install.)
- Also, I've uploaded the two fixes (this and this) that have done the job fine on the other sites.
As for now, the main part of dolcevita.no is on WP301 but back on At246 - where eg submenus won't work. This makes the site inaccessible.
Should I upgrade the theme via some other version, do some export/imort or some other magic...?
Any hint would be VERY MUCH appreciated!
Thanks,
__________________
Kjetil
- Dolcevita.no

Last edited by kjetil; Nov 8, 2010 at 03:34 PM. Reason: Missing details
  #14  
Old Nov 23, 2010, 02:43 PM
trusktr
 
16 posts · Jul 2010
I have 3.5.3 and i tried this fix but I still can't import my settings. I keep getting the same "Sorry, but .... doesn't appear to be a valid Atahualpa settings file" error.

How can I import these settings without breaking an arm and a leg trying to re-implement all the settings?
  #15  
Old Nov 23, 2010, 03:16 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
What version of Atahualpa were the settings exported from?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #16  
Old Nov 23, 2010, 03:26 PM
trusktr
 
16 posts · Jul 2010
I'm not sure, i'm awaiting the reply from the guy who sent me the settings. I did however try using the base64 upload.php but it still didn't work, so perhaps one of his plugins is messing up the export.
We shall soon see!
  #17  
Old Nov 23, 2010, 03:30 PM
trusktr
 
16 posts · Jul 2010
Hey, check it out, this is the settings file i was trying to import.
Attached Files
File Type: txt ata-rollingreleasecom-20101123.txt (20.3 KB, 1714 views)
  #18  
Old Nov 23, 2010, 05:00 PM
juggledad's Avatar
juggledad
 
23,743 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Send me the file. It's probably an export from 3.4.9?? And the format changed. There is a way to change the import code ( you can see how if you look at the 3.5.2 install notes)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #19  
Old Nov 23, 2010, 07:42 PM
trusktr
 
16 posts · Jul 2010
I attached the file above. I just found out though that my friend exported it from 3.5.3, it won't import for me in a brand new install of 3.5.3 so it leads me to believe that perhaps some settings are interfering on my server...

I'll take a look at the install notes too (3.5.2 only or 3.5.3 too?).
  #20  
Old Nov 23, 2010, 08:27 PM
juggledad's Avatar
juggledad
 
23,743 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Make sure your friend used the optional ato->Export/Import settings and not some other way of exporting it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #21  
Old Nov 25, 2010, 03:41 PM
trusktr
 
16 posts · Jul 2010
I fixed the file. So for some reason, the file contained 15 or so lines (instead of just one). For some reason my friend's export made a new line at every ">" symbol of any html tags. Strange huh!?

So i replaced each new line with a space, and it worked. Basically, by having multiple lines, i think atahualpa was seeing extra newline characters in the string of settings and didn't know what to do.

The fix was simple: just go to the end of the first line, press delete, then add a space... then repeat again until all lines are one single line.
  #22  
Old Nov 25, 2010, 06:12 PM
juggledad's Avatar
juggledad
 
23,743 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What version did you export the settings from?
Attach a copy and I'll try importing them.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #23  
Old Nov 27, 2010, 09:10 AM
AB4C
 
4 posts · Nov 2010
Hi,

I am new to having a website/blog. I downloaded my first (premium) theme on 10/22/10. I spent a lot of time on it and wasn't able to get past some bugs that were making my site not function properly. I wasn't getting the problem solved with the developer.

About two weeks after that I downloaded a free theme through Wordpress. I really like this theme but there are constant bugs with this theme that make my site not function properly. Many people on the forum have the same problems. When the theme is updated those bugs may be fixed only to have new bugs. I'm tired of dealing with it. In the last two weeks I have updated this theme 3 times (4 total downloads of it).

So - my question:

After doing research I have decided to go with Atahualpa but on the forum I see that there are bugs with different releases (especially the last one 3.5.3??). Which release should I download that I will have the least problems with?

By the way - I do not know anything about CSS or adding things to my "files". I need a theme to work without me having to do anything to it/my files.

Thanks in advance for your help!

AB4C
  #24  
Old Nov 27, 2010, 01:10 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You should download Atahualpa 3.5.3 from wordpress.bytesforall.com and apply the bug fixes as outlined in the New Versions and updating thread. It's not too complicated and if you have questions you can just ask here.

To get the most out of Atahualpa you should start learning some CSS but we can help you there or you can go to w3schools.com for tutorials.

Not having to make changes to your "files" (other than bug fixes) is one of the great things about Atahualpa. Items that take editing the them files with other themes can be done in the theme options with Atahualpa. Again don't feel daunted by the many configuration choices as we are always here to help.

When I first installed this theme I was challenged by the number of configuration options but soon came to realize that is the power of this theme. As I have mentioned before it is powerful but the price for that is a bit of a learning curve but there is much documentation built right into the theme and this forum can help as well.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #25  
Old Nov 27, 2010, 04:43 PM
AB4C
 
4 posts · Nov 2010
Hi,

Thank you for your quick response.

I have heard that there are over 300 customizations. Can some of these settings be left at default?

I am concerned about changing themes right now with it being "prime" shopping time and Cyber Monday less than 2 days away.

I will check out the site you referred me to for CSS tutorials - but - I'm wondering between those tutorials, waiting for help/responses on the forum and setting up the theme if I should wait until after Christmas?

I have managed to change a few things on my site (with my current theme) so that the "bugs" won't be so obvious to customers. I could get by.

Let me know what you think. I really have no idea what to do with the "bug fixes" for 3.5.3.

Thanks!

AB4C

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No Atahualpa theme option in WP3.0 multi-site ccloskey New Versions, & Updating 2 Sep 3, 2010 08:24 AM
Atahualpa 3.5.1 released Flynn Old Version fixes and change logs 46 May 31, 2010 08:27 AM
Making Atahualpa WP 3.0-ready for new menu function paulae New Versions, & Updating 4 May 31, 2010 07:45 AM
Atahualpa 3.5.0 released Flynn Old Version fixes and change logs 14 May 27, 2010 04:51 PM
Atahualpa 3.1 released Flynn New Versions, & Updating 0 Dec 18, 2008 08:07 PM


All times are GMT -6. The time now is 12:01 PM.


Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.