Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Php problem and a fix


  #1  
Old Dec 14, 2008, 03:18 AM
js9600
 
29 posts · Dec 2008
Besides the problem already mentioned here I had one more. Theme could be installed, though style sheet not entirely functional in preview, but any change I made in settings was never saved. Fix was to change a couple of settings in my hosts control panel (GUI for php.ini editing). Actually nothing to do with php but with an extension, hardening thingy called Suhosin. Well, before:

suhosin.post.max_vars = 200
suhosin.request.max_vars = 200

I increased both to 2048 and theme settings are now saved. Google for how to change, seems like a common "tweak" to increase default. At least new to my host.
  #2  
Old Dec 14, 2008, 11:51 AM
bseppa
 
55 posts · Dec 2008
I think I may have this problem but I don't understand your solution. Can you elaborate? Who do you use for hosting?

Thanks!
  #3  
Old Dec 14, 2008, 01:16 PM
js9600
 
29 posts · Dec 2008
Well if you have that extension you must get access to its settings. Just like with php. Can be done in various ways depending on this and that. My host dont allow much fiddling about with php.ini at all so they have a page with allowed settings to change. Those 2 I listed are in there.

Take a look at this Setting-up-a-secure-and-fast-php-build-for-litespeed/ At the bottom you see a [suhosin] section. Put that in php.ini - or better just those 2 I used and see what happens. I dont know about "suhosin.so", suhosins own ini-thingy I guess. I think you can also set up this in a .htaccess file but not sure - depends on how you host. Check this google search

I guess you know about phpinfo? Anyway, put code below in a file you can name whatever as long as it has extension of .php, then run it from server. Will tell settings, including those about Suhosin. I have mine at www.js9600.dk/phpinfo.php Pumping default 200 to more definitely made version 3 save settings. Scroll way down and you find Suhosin section.

Code:
<?php
// Show all information, defaults to INFO_ALL
phpinfo();
?>

Last edited by js9600; Dec 14, 2008 at 01:18 PM.
  #4  
Old Dec 19, 2008, 01:15 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Thanks for providing this info, js9600.

It seems that the suhosin default value for max variables that can be sent at once is 200, and Atahualpa 3 sends slightly more than that (around 215) when saving the options.

I will have to make the theme save one option at a time or one menu tab page at a time in a later version.

Use the fix provided in the first post of this thread by js9600 if you use Atahualpa 3.1.1 and cannot save any options for seemingly mysterious reasons. It should however be enough if you set the max to 300 or 250:

suhosin.post.max_vars = 300
suhosin.request.max_vars = 300

UPDATE: This is already fixed in the next release.

Last edited by juggledad; Feb 22, 2011 at 06:13 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
php in footer.php - links to just show up on homepage chris Atahualpa 3 Wordpress theme 6 May 9, 2010 01:50 PM
[SOLVED] messed up header.php and footer.php monochrome Header configuration & styling 0 Jun 20, 2009 03:16 PM
Fix Background? Antsliedown Atahualpa 3 Wordpress theme 0 May 7, 2009 09:44 AM
[SOLVED] HOW to fix my Comments feed? Shepherd Jim RSS, Feeds & Subscribing 5 Mar 29, 2009 02:15 PM
Problem in archive.php jrodon Atahualpa 3 Wordpress theme 1 Feb 15, 2009 07:03 AM


All times are GMT -6. The time now is 08:49 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.