Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Catching up on the upgrades


  #1  
Old Mar 27, 2010, 01:25 AM
ozbod
 
59 posts · Jan 2010
Stamford, Lincs, England
Hi my wife is running version 3.4.3 which is working fine apart from realising the probelms with the comments which we hope would get fixed through the upgrade process. She has customised it quite extrensively to suit her needs.

We now see that version 3.4.6 has become available, as we have never performed a theme upgrade before we would like to ask, if it's possible to go straight from 3.4.3 to 3.4.6 in one upgrade or do we need to apply other upgrade before the latest.

I realise that we should do a full back up of both web files, including images etc. and the database before proceeding.

Is it then simply a matter of ftping the new files up and overwriting the existing ones on the server.

If we see significant changes after upgrade can we upload backed up files to fix them or will there be compatibility issues.

Any hints, tipos or pointers would be great.

Many thanks

Dave
  #2  
Old Mar 27, 2010, 07:40 AM
juggledad's Avatar
juggledad
 
23,535 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Step 0 - backup your database!!!

All your OPTIONS are saved in the DB - anything you set via the Atahualpa Theme Option.

Any change you make to a piece of code (like js.php, bfa_header_config.php) or any images you have uploaded to any of the theme folders may be overridden if you use the wordpress atuomatic update or manually ftp fhe files TO THE SAME FOLDER

This is why I manually install the theme. I create a folder with the version number (atahualpa333, atahualpa341, atahualpa346 etc) and upload the theme into it. This way, when I go to the theme picker I will have multiple versions to choose from. Then I can switch back and forth till I'm satisfied, then I delete the old folder.

NOTE: If you do it this way, and have used a URL in the options, you will probably have to change the url to the new name of the atahualpa folder. For example:

'background url("http://mydomain.com/wordpress/wp-content/theme/atahualpa333/image/header/image1.jpg")'

would have to be changed to

'background url("http://mydomain.com/wordpress/wp-content/theme/atahualpa346/image/header/image1.jpg")'

As always, before doing an update, make sure you back things up so you can roll back to where youwere before the update in case something goes wrong.

And only update one thing at a time! (don't update wordpress, the theme, php and add 10 new plugins at the same time unless you LIKE pain)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 27, 2010, 09:32 AM
ozbod
 
59 posts · Jan 2010
Stamford, Lincs, England
Hi,

thank you for your very quick reply, now I have roadmap so to speak of what to do and how to progress.

I will attemp to do this tomorrow when I am less tired, just completed a 700+ mile trip to Holland and back on my motorcycle, need a clear head to do this update.

All the best and thanks again

Dave
  #4  
Old Mar 31, 2010, 03:59 AM
ozbod
 
59 posts · Jan 2010
Stamford, Lincs, England
Hi all went well with the upgrade thank you, just one more thing which is what we are hoping the upgrade would fix.

We are still not seeing a comments box on a post that already has a comment, I did discover a post elswhere in the forum but relating to this but wanted to make sure it would work with the newest version

Best regards

Dave
  #5  
Old Mar 31, 2010, 04:54 AM
juggledad's Avatar
juggledad
 
23,535 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
see (http://forum.bytesforall.com/showthread.php?t=5031) BUGFIX - 3.4.1->3.4.6 - Comment form will not show up after first comment on a PAGE
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Mar 31, 2010, 05:00 AM
ozbod
 
59 posts · Jan 2010
Stamford, Lincs, England
Hi,

you beat me to it, we found the fix and applied it and it works fine thanks. Now I need to a find the fix so we can get more than one comment on the pages (if this is posible).

All the best

Dave
  #7  
Old Mar 31, 2010, 11:19 AM
juggledad's Avatar
juggledad
 
23,535 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
did you do the fix to the wordpress code?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Apr 1, 2010, 01:12 AM
ozbod
 
59 posts · Jan 2010
Stamford, Lincs, England
Hi,

we got the upgrade to version 3.4.6 installed and working then we got the comments box of posts with more than one existing post working, we are still trying to work out why we have a similar problem with "pages" in that we can have one comment on a page and then the comments box is not available anymore.

Any pointers you could offer would be great.

Thanks

Dave
  #9  
Old Apr 1, 2010, 02:58 AM
juggledad's Avatar
juggledad
 
23,535 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
did you apply the patch's (note the plural) form the thread I pointed to in post # 5?
one is to a piece of wordpress code,
the other is replacing the Atahaulpa comments.php
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Apr 2, 2010, 03:01 AM
ozbod
 
59 posts · Jan 2010
Stamford, Lincs, England
Yep, cracked it now thank you all comments boxes working on posts and pages, I think I thiought I had uploaded the comments.php but for some reason I hadn't.

Very many thanks again for your help

Dave

All times are GMT -6. The time now is 09:48 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.