Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

[SOLVED] Weird Pages Menu issue - One menu on Home page, another everywhere else


 
Prev Previous Post   Next Post Next
  #1  
Old Mar 14, 2015, 05:06 PM
markzip
 
60 posts · Jan 2010
[SOLVED] Weird Pages Menu issue - One menu on Home page, another everywhere else

WP 4.4.1
Atahualpa 3.7.15
www.indonesiaetc.com

My Header section in ATO is
Code:
%logo %image %bar2 %bar2 %bar2 %pages %bar2 %bar2
And there should be 11 items on my "Pages" menu. 10 pages and a "Home". I am not using a Custom Menu

When a non-signed in reader (ie. a regular person) goes to the home page at www.indonesiaetc.com they see no extra bars above and below and only 10 items (9 pages and Home). In this order:
HOME MEDIA EVENTS SLIDESHOWS VIDEOS REFERENCES ABOUT CONTACT DONATE
The page called "Ebook" is missing.

BUT, when they go to another page, say "Events" at http://indonesiaetc.com/events/ they get the correct menu with the extra bars above and below and all 11 items and in the correct order:
HOME EBOOK MEDIA VIDEOS SLIDESHOWS EVENTS REFERENCES ABOUT CONTACT DONATE

If I try it on my browser which is signed in to the WP back-end I get the correct menu even on the Home page.
If I try it on any of my other browsers, and am signed out, I get incorrect results.
If I take one of the previously signed-out browsers and now sign in to the WP back-end, I get the correct result.
If I try it on my laptop (Chrome, FF) I get the same results as on my desktop (ie. incorrect)
If I try it on my phone (Dolphin, Chrome) I get the correct results.
All of the above are on the same network.

My friend across town (thus a different network) gets the same result on FF and Mac OSX

I have gone through each page which is supposed to be on the menu and assigned page order values the way I want them (eBook=2, Media=3, Videos=4, etc.)
I have turned off all caching on the site. There is an old .htaccess file in root, left over from the caching plugin, could it be this? How could that explain both new and old menus being visble on the same site?

I have no idea what to try next.

Thanks

Last edited by markzip; Mar 14, 2015 at 05:07 PM. Reason: tags
 

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Home link in page menu on all pages except home page - possible? morgana123 Page & Category Menu Bars 4 Jun 10, 2014 09:13 AM
[SOLVED] Hide %Pages Menu On Home Page bswb97 Page & Category Menu Bars 3 Dec 4, 2011 08:13 PM
Really Weird Static Front / Home Page Issue mr2020 Atahualpa 3 Wordpress theme 3 Nov 23, 2010 05:24 AM
[SOLVED] menu background image only shows up on home page, missing on pages/post Athena account2 Page & Category Menu Bars 5 Mar 4, 2010 04:53 AM
Weird appearance of page menu bar in IE8 lhanft Page & Category Menu Bars 4 Feb 24, 2010 03:35 PM


All times are GMT -6. The time now is 12:28 PM.


Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.