Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Ata version 3.5.3 (bfa_ata4) compatability issue with php version php 5.2.12


  #1  
Old Dec 1, 2010, 09:20 AM
bettykin
 
3 posts · Jul 2010
Hi all,

As you can see from my header, I'm running Ata version 3.5.3 and Wordpress 3.0.2. Over the Thanksgiving weekend, my host (Aplus.net) upgraded the shared server to PHP v5.2.12. Since then my site will not retain the Ata custom settings.

In searching the forums, I've discovered that in version 3.5.3 all custom settings live in option "bfa_ata4" in the database.
http://forum.bytesforall.com/showthr...light=bfa_ata4
Using the suggestions in this post, I've:

-Deleted and rebuilt the "bfa_ata4" option using the import/export menu.
-Deleted and reloaded the ata 3.5.3 theme
Neither worked.

I should add that I'm able to import and apply my correct settings but my site "resets" itself back to the default settings the next day. Which makes me suspect a problem with my host or the daily back-up process. That got me to this post...

http://forum.bytesforall.com/showthr...light=bfa_ata4

If I'm reading this correctly, it looks like there might be some incompatibility between my server php version and Ata 3.5.3, therefore, I'm copying this post to my host and opening a service ticket as well.

My question for the forum (finally!):
Short of going back to Ata 3.5.2, can I either: 1) prevent option bfa_ata4 from being rewritten daily (presumably with the automated back-up); or 2) create a new DB option containing my custom settings that would override bfa_ata4?
Has anyone else had their settings "reset" over night?

I've attached before and after screen shots of my site.

Any insight is greatly appreciated.
Attached Thumbnails
Click image for larger version

Name:	Screen shot 2010-11-29 at 6.45.53 PM.jpg
Views:	556
Size:	98.4 KB
ID:	922  Click image for larger version

Name:	Screen shot 2010-11-29 at 6.42.22 PM.jpg
Views:	575
Size:	129.6 KB
ID:	923  
  #2  
Old Dec 1, 2010, 12:30 PM
vincent
 
64 posts · Nov 2010
Quote:
Originally Posted by bettykin
Hi all,
As you can see from my header, I'm running Ata version 3.5.3 and Wordpress 3.0.2. Over the Thanksgiving weekend, my host (Aplus.net) upgraded the shared server to PHP v5.2.12. Since then my site will not retain the Ata custom settings.
I can only give you a little 'insights' in case it helps.

I have no issues with ATA 3.5.3 on a shared server running:
Apache version 2.2.15
PHP version 5.2.13
MySQL version 5.0.91-community

Curious as to why your host only just upgraded to PHP 5.2.12 instead of 5.2.13
Either way, my guess is it's not the PHP version causing your problems.

Best wishes,

- Vincent

Last edited by vincent; Dec 1, 2010 at 12:35 PM.
  #3  
Old Dec 1, 2010, 03:27 PM
bettykin
 
3 posts · Jul 2010
Vincent,

Thanks for the reply.

I was also surprised to find out my hosting company is running 5.2.12 but that seems to be par for the course with Aplus.net.
  #4  
Old Dec 1, 2010, 07:51 PM
juggledad's Avatar
juggledad
 
23,551 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The bfa_ata4 is a row in the wp-options table inside the database. Unless there is something causing a rollback of the transaction, once it is written it should remain in the database. If it is changed the next day, I would be all over the host to find out what is causing this to be restored. The reason I would be all over them is if the database is being restored the everything should be gone, not just one record. So if someone went in and made a comment...gone. It you have e-commerce and info is stored in the db...gone. If you add a post...gone.

The bfa_ata4 is just another row in the wp-options table. You need to take a look at all the overnight activity against your database...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Dec 6, 2010, 11:53 AM
bettykin
 
3 posts · Jul 2010
Juggledad,

Thanks for that info. Strangely enough, after I submitted a service ticket with my host, the problem disappeared and now they're running php 5.12.13 on my shared server.

I think we can mark this problem solved.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pls help me change this code<title><?php bloginfo('name'); ?><?php wp_title(); ?></ti tobywinn Header configuration & styling 1 Nov 18, 2011 12:51 PM
Auto Upgrade Not the Latest Ata Version joan New Versions, & Updating 1 Jul 20, 2010 12:46 PM
Using ATA header php file outside of Wordpress but in same directory jaxon Header configuration & styling 1 Feb 25, 2010 03:21 PM
Conditional PHP issue MyJourneytoMillions Center area post/pages 6 Feb 10, 2010 04:11 PM
[SOLVED] Can't upload the latest version to my Dashboard because I have older version rhymes New Versions, & Updating 2 Apr 25, 2009 11:22 PM


All times are GMT -6. The time now is 04:17 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.